summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/meta/external-poky-toolchain.bb
diff options
context:
space:
mode:
authorSaul Wold <Saul.Wold@intel.com>2010-11-22 13:57:13 +0000
committerRichard Purdie <rpurdie@linux.intel.com>2010-11-22 13:57:13 +0000
commitcfe12efb5ec9586dab6961f141d52b103bd8b1d1 (patch)
tree7108e22aa7ddf6cfc2f1b6c6b73a811187706ecb /meta/recipes-core/meta/external-poky-toolchain.bb
parent762fd6b7b3b22d7a8cb80ef9e9ba62e7ef21af3e (diff)
downloadpoky-cfe12efb5ec9586dab6961f141d52b103bd8b1d1.tar.gz
Meta: Recipe Reogranization
This is the next stage of recipe reorganization, in this stage many recipes where moved to a new meta-demoapps layer since this is more appropriate for demo usage then the core. Additional some recipes were moved to meta-extras to indicate they may be depercated at a future time. A number of recipes were modified since dependencies need to be corrected. Signed-off-by: Saul Wold <Saul.Wold@intel.com>
Diffstat (limited to 'meta/recipes-core/meta/external-poky-toolchain.bb')
-rw-r--r--meta/recipes-core/meta/external-poky-toolchain.bb42
1 files changed, 42 insertions, 0 deletions
diff --git a/meta/recipes-core/meta/external-poky-toolchain.bb b/meta/recipes-core/meta/external-poky-toolchain.bb
new file mode 100644
index 0000000000..a387ab3e60
--- /dev/null
+++ b/meta/recipes-core/meta/external-poky-toolchain.bb
@@ -0,0 +1,42 @@
1PROVIDES = "\
2 linux-libc-headers \
3 virtual/${TARGET_PREFIX}gcc \
4 virtual/${TARGET_PREFIX}gcc-intermediate \
5 virtual/${TARGET_PREFIX}gcc-initial \
6 virtual/${TARGET_PREFIX}binutils \
7 virtual/${TARGET_PREFIX}libc-for-gcc \
8 virtual/libc \
9 virtual/libintl \
10 virtual/libiconv \
11 virtual/linux-libc-headers "
12RPROVIDES = "glibc-utils libsegfault glibc-thread-db libgcc-dev libstdc++-dev libstdc++"
13PACKAGES_DYNAMIC = "glibc-gconv-*"
14INHIBIT_DEFAULT_DEPS = "1"
15PR = "r1"
16
17PSTAGING_DISABLED = "1"
18
19# License applies to this recipe code, not the toolchain itself
20LICENSE = "MIT"
21
22do_install() {
23 if [ ! -e ${prefix}/environment-setup ]; then
24 echo "The Poky toolchain could not be found in ${prefix}!"
25 exit 1
26 fi
27
28 install -d ${DEPLOY_DIR}/ipk/
29 install -d ${STAGING_DIR}/pkgdata/
30 install -d ${STAGING_DIR_TARGET}/shlibs/
31 install -d ${STAGING_DIR_TARGET}/${base_libdir}/
32 install -d ${STAGING_DIR_TARGET}/${libdir}/
33 install -d ${STAGING_DIR_TARGET}/${includedir}/
34
35 cp -ar ${prefix}/ipk/* ${DEPLOY_DIR}/ipk/
36 cp -ar ${prefix}/pkgdata/* ${STAGING_DIR}/pkgdata/
37 cp -ar ${prefix}/${TARGET_SYS}/shlibs/* ${STAGING_DIR_TARGET}/shlibs/
38 cp -ar ${prefix}/${TARGET_SYS}/lib/* ${STAGING_DIR_TARGET}/${base_libdir}/
39 cp -ar ${prefix}/${TARGET_SYS}/usr/include/* ${STAGING_DIR_TARGET}/${includedir}/
40 cp -ar ${prefix}/${TARGET_SYS}/usr/lib/* ${STAGING_DIR_TARGET}/${libdir}/
41}
42