summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/meta/cve-update-db-native.bb
diff options
context:
space:
mode:
authorMarta Rybczynska <rybczynska@gmail.com>2022-05-02 16:25:35 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2022-05-14 20:26:34 +0100
commitdd76704ea5e05a317b454726958c350996b6462b (patch)
tree075832bf1a8d6b50d2a488a9d81356d513c1ef48 /meta/recipes-core/meta/cve-update-db-native.bb
parent66b0097533ebf8ddac25f75af1f87b02ecaec37f (diff)
downloadpoky-dd76704ea5e05a317b454726958c350996b6462b.tar.gz
cve-update-db-native: update the CVE database once a day only
The update of the NVD database was expected to happen once per hour. However, the database file date changes only if the content was actually updated. In practice, the check worked for the first hour after the new download. As the NVD database changes usually only once a day, we can just update it less frequently. (From OE-Core rev: d0a56ad3a278e18e766f833619cf97869bdf6a4c) Signed-off-by: Marta Rybczynska <marta.rybczynska@huawei.com> Signed-off-by: Luca Ceresoli <luca.ceresoli@bootlin.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org> (cherry picked from commit 35bccdedadeaba820d58b69fe74ce5e4c1f577e3) Signed-off-by: Steve Sakoman <steve@sakoman.com> (cherry picked from commit 88f2fb1581a17b2cf59a694ca9afb89e38ed40b5) Signed-off-by: Steve Sakoman <steve@sakoman.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core/meta/cve-update-db-native.bb')
-rw-r--r--meta/recipes-core/meta/cve-update-db-native.bb4
1 files changed, 2 insertions, 2 deletions
diff --git a/meta/recipes-core/meta/cve-update-db-native.bb b/meta/recipes-core/meta/cve-update-db-native.bb
index 50052f8532..a6144979f0 100644
--- a/meta/recipes-core/meta/cve-update-db-native.bb
+++ b/meta/recipes-core/meta/cve-update-db-native.bb
@@ -42,10 +42,10 @@ python do_fetch() {
42 if os.path.exists(db_file): 42 if os.path.exists(db_file):
43 os.remove(db_file) 43 os.remove(db_file)
44 44
45 # Don't refresh the database more than once an hour 45 # The NVD database changes once a day, so no need to update more frequently
46 try: 46 try:
47 import time 47 import time
48 if time.time() - os.path.getmtime(db_file) < (60*60): 48 if time.time() - os.path.getmtime(db_file) < (24*60*60):
49 return 49 return
50 except OSError: 50 except OSError:
51 pass 51 pass