summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/meta/buildtools-tarball.bb
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2013-06-07 11:05:01 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-06-07 16:48:30 +0100
commit58feddba96ba08b88d42d27fd848e2968bb01845 (patch)
treef1928a232b4276848b065f539055d7ad157812f1 /meta/recipes-core/meta/buildtools-tarball.bb
parent80d631657404669dbbf0ee88f68e5eb79a469bc6 (diff)
downloadpoky-58feddba96ba08b88d42d27fd848e2968bb01845.tar.gz
python-external-tarball: Modernise and rename
The external-python-tarball was intended to provide python for those users who didn't have python 2.6. It has been unloved for a while so this refreshes it a bit. Specifically: * Include git and tar since these can have version issues on some systems * Rename to buildtools-tarball to better reflect its purpose * Remove the site-config file from the tarball, its pointless * Prune down the environment file to just cover PATH and OECORE_NATIVE (which is needed to correctly install the tarball) * Add missing grp module (used by do_package) from the unixadmin package (From OE-Core rev: c8de009e96930709efe8f6aa4e65dd04a48081f2) Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core/meta/buildtools-tarball.bb')
-rw-r--r--meta/recipes-core/meta/buildtools-tarball.bb47
1 files changed, 47 insertions, 0 deletions
diff --git a/meta/recipes-core/meta/buildtools-tarball.bb b/meta/recipes-core/meta/buildtools-tarball.bb
new file mode 100644
index 0000000000..076fe36d11
--- /dev/null
+++ b/meta/recipes-core/meta/buildtools-tarball.bb
@@ -0,0 +1,47 @@
1DESCRIPTION = "Meta package for building a standalone python tarball and other key build tools"
2LICENSE = "MIT"
3LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=3f40d7994397109285ec7b81fdeb3b58 \
4 file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
5
6TOOLCHAIN_TARGET_TASK ?= ""
7
8TOOLCHAIN_HOST_TASK ?= "\
9 nativesdk-python-core \
10 nativesdk-python-textutils \
11 nativesdk-python-sqlite3 \
12 nativesdk-python-pickle \
13 nativesdk-python-logging \
14 nativesdk-python-elementtree \
15 nativesdk-python-curses \
16 nativesdk-python-compile \
17 nativesdk-python-compiler \
18 nativesdk-python-fcntl \
19 nativesdk-python-shell \
20 nativesdk-python-misc \
21 nativesdk-python-multiprocessing \
22 nativesdk-python-subprocess \
23 nativesdk-python-xmlrpc \
24 nativesdk-python-netclient \
25 nativesdk-python-netserver \
26 nativesdk-python-distutils \
27 nativesdk-python-unixadmin \
28 nativesdk-chrpath \
29 nativesdk-tar \
30 nativesdk-git \
31 "
32
33TOOLCHAIN_OUTPUTNAME ?= "${SDK_NAME}-buildtools-nativesdk-standalone-${DISTRO_VERSION}"
34
35RDEPENDS = "${TOOLCHAIN_HOST_TASK}"
36
37EXCLUDE_FROM_WORLD = "1"
38
39inherit meta
40inherit populate_sdk
41
42create_sdk_files_append () {
43 rm -f ${SDK_OUTPUT}/${SDKPATH}/site-config*
44
45 cat ${SDK_OUTPUT}/${SDKPATH}/environment-setup* | grep " PATH=\|OECORE_NATIVE_SYSROOT" > ${WORKDIR}/envtmp
46 mv ${WORKDIR}/envtmp ${SDK_OUTPUT}/${SDKPATH}/environment-setup*
47}