summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/libxml/libxml2_2.9.8.bb
diff options
context:
space:
mode:
authorAndrej Valek <andrej.valek@siemens.com>2018-03-20 10:47:15 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-05-04 13:28:01 +0100
commitce8d120bfc1015ea23944ebbcfa3b536eeea2d6c (patch)
tree9f6060962683a67e4390f794f560bfc9a1ae1f80 /meta/recipes-core/libxml/libxml2_2.9.8.bb
parent49e0838e1d2cb9e07b0e66a1220f13be251f255c (diff)
downloadpoky-ce8d120bfc1015ea23944ebbcfa3b536eeea2d6c.tar.gz
libxml2: 2.9.7 -> 2.9.8
(From OE-Core rev: de24ead63802523daa19ce8528ac95d9e041eaf8) Signed-off-by: Andrej Valek <andrej.valek@siemens.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core/libxml/libxml2_2.9.8.bb')
-rw-r--r--meta/recipes-core/libxml/libxml2_2.9.8.bb104
1 files changed, 104 insertions, 0 deletions
diff --git a/meta/recipes-core/libxml/libxml2_2.9.8.bb b/meta/recipes-core/libxml/libxml2_2.9.8.bb
new file mode 100644
index 0000000000..d55e650911
--- /dev/null
+++ b/meta/recipes-core/libxml/libxml2_2.9.8.bb
@@ -0,0 +1,104 @@
1SUMMARY = "XML C Parser Library and Toolkit"
2DESCRIPTION = "The XML Parser Library allows for manipulation of XML files. Libxml2 exports Push and Pull type parser interfaces for both XML and HTML. It can do DTD validation at parse time, on a parsed document instance or with an arbitrary DTD. Libxml2 includes complete XPath, XPointer and Xinclude implementations. It also has a SAX like interface, which is designed to be compatible with Expat."
3HOMEPAGE = "http://www.xmlsoft.org/"
4BUGTRACKER = "http://bugzilla.gnome.org/buglist.cgi?product=libxml2"
5SECTION = "libs"
6LICENSE = "MIT"
7LIC_FILES_CHKSUM = "file://Copyright;md5=2044417e2e5006b65a8b9067b683fcf1 \
8 file://hash.c;beginline=6;endline=15;md5=96f7296605eae807670fb08947829969 \
9 file://list.c;beginline=4;endline=13;md5=cdbfa3dee51c099edb04e39f762ee907 \
10 file://trio.c;beginline=5;endline=14;md5=6c025753c86d958722ec76e94cae932e"
11
12DEPENDS = "zlib virtual/libiconv"
13
14SRC_URI = "http://www.xmlsoft.org/sources/libxml2-${PV}.tar.gz;name=libtar \
15 http://www.w3.org/XML/Test/xmlts20080827.tar.gz;name=testtar \
16 file://libxml-64bit.patch \
17 file://runtest.patch \
18 file://run-ptest \
19 file://python-sitepackages-dir.patch \
20 file://libxml-m4-use-pkgconfig.patch \
21 file://0001-Make-ptest-run-the-python-tests-if-python-is-enabled.patch \
22 file://fix-execution-of-ptests.patch \
23 "
24
25SRC_URI[libtar.md5sum] = "b786e353e2aa1b872d70d5d1ca0c740d"
26SRC_URI[libtar.sha256sum] = "0b74e51595654f958148759cfef0993114ddccccbb6f31aee018f3558e8e2732"
27SRC_URI[testtar.md5sum] = "ae3d1ebe000a3972afa104ca7f0e1b4a"
28SRC_URI[testtar.sha256sum] = "96151685cec997e1f9f3387e3626d61e6284d4d6e66e0e440c209286c03e9cc7"
29
30BINCONFIG = "${bindir}/xml2-config"
31
32PACKAGECONFIG ??= "python \
33 ${@bb.utils.filter('DISTRO_FEATURES', 'ipv6', d)} \
34"
35PACKAGECONFIG[python] = "--with-python=${PYTHON},--without-python,python3"
36PACKAGECONFIG[ipv6] = "--enable-ipv6,--disable-ipv6,"
37
38inherit autotools pkgconfig binconfig-disabled ptest
39
40inherit ${@bb.utils.contains('PACKAGECONFIG', 'python', 'python3native', '', d)}
41
42RDEPENDS_${PN}-ptest += "make ${@bb.utils.contains('PACKAGECONFIG', 'python', 'libgcc python3-core python3-logging python3-shell python3-stringold python3-threading python3-unittest ${PN}-python', '', d)}"
43
44RDEPENDS_${PN}-python += "${@bb.utils.contains('PACKAGECONFIG', 'python', 'python3-core', '', d)}"
45
46RDEPENDS_${PN}-ptest_append_libc-glibc = " glibc-gconv-ebcdic-us glibc-gconv-ibm1141 glibc-gconv-iso8859-5"
47
48export PYTHON_SITE_PACKAGES="${PYTHON_SITEPACKAGES_DIR}"
49
50# WARNING: zlib is required for RPM use
51EXTRA_OECONF = "--without-debug --without-legacy --with-catalog --without-docbook --with-c14n --without-lzma --with-fexceptions"
52EXTRA_OECONF_class-native = "--without-legacy --without-docbook --with-c14n --without-lzma --with-zlib"
53EXTRA_OECONF_class-nativesdk = "--without-legacy --without-docbook --with-c14n --without-lzma --with-zlib"
54EXTRA_OECONF_linuxstdbase = "--with-debug --with-legacy --with-docbook --with-c14n --without-lzma --with-zlib"
55
56python populate_packages_prepend () {
57 # autonamer would call this libxml2-2, but we don't want that
58 if d.getVar('DEBIAN_NAMES'):
59 d.setVar('PKG_libxml2', '${MLPREFIX}libxml2')
60}
61
62PACKAGES += "${PN}-utils ${PN}-python"
63
64FILES_${PN}-staticdev += "${PYTHON_SITEPACKAGES_DIR}/*.a"
65FILES_${PN}-dev += "${libdir}/xml2Conf.sh ${libdir}/cmake/*"
66FILES_${PN}-utils += "${bindir}/*"
67FILES_${PN}-python += "${PYTHON_SITEPACKAGES_DIR}"
68
69do_configure_prepend () {
70 # executables take longer to package: these should not be executable
71 find ${WORKDIR}/xmlconf/ -type f -exec chmod -x {} \+
72}
73
74do_compile_ptest() {
75 oe_runmake check-am
76}
77
78do_install_ptest () {
79 cp -r ${WORKDIR}/xmlconf ${D}${PTEST_PATH}
80 if [ "${@bb.utils.filter('PACKAGECONFIG', 'python', d)}" ]; then
81 sed -i -e 's|^\(PYTHON = \).*|\1${USRBINPATH}/${PYTHON_PN}|' \
82 ${D}${PTEST_PATH}/python/tests/Makefile
83 grep -lrZ '#!/usr/bin/python' ${D}${PTEST_PATH}/python |
84 xargs -0 sed -i -e 's|/usr/bin/python|${USRBINPATH}/${PYTHON_PN}|'
85 fi
86 #Remove build host references from various Makefiles
87 find "${D}${PTEST_PATH}" -name Makefile -type f -exec \
88 sed -i \
89 -e 's,--sysroot=${STAGING_DIR_TARGET},,g' \
90 -e 's|${DEBUG_PREFIX_MAP}||g' \
91 -e 's:${HOSTTOOLS_DIR}/::g' \
92 -e 's:${RECIPE_SYSROOT_NATIVE}::g' \
93 -e 's:${RECIPE_SYSROOT}::g' \
94 -e 's:${BASE_WORKDIR}/${MULTIMACH_TARGET_SYS}::g' \
95 -e '/^RELDATE/d' \
96 {} +
97}
98
99do_install_append_class-native () {
100 # Docs are not needed in the native case
101 rm ${D}${datadir}/gtk-doc -rf
102}
103
104BBCLASSEXTEND = "native nativesdk"