summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/libxml/libxml2_2.9.4.bb
diff options
context:
space:
mode:
authorPeter Kjellerstedt <peter.kjellerstedt@axis.com>2017-06-09 21:34:24 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-06-12 23:01:22 +0100
commit4495e78917be867413c324b89a58facbeacb7eb8 (patch)
treee99523dc2de862b81797394c932061d26e441399 /meta/recipes-core/libxml/libxml2_2.9.4.bb
parent3a9a5e85e850e68bc405fa27b97c29b8b5a1ceb2 (diff)
downloadpoky-4495e78917be867413c324b89a58facbeacb7eb8.tar.gz
libxml2: Make ptest run the Python tests if Python support is enabled
Since we go through the trouble of copying the Python tests, we may as well actually run them... This also avoids the following QA issue: ERROR: libxml2-2.9.4-r0 do_package_qa: QA Issue: /usr/lib/libxml2/ptest/python/tests/push.py contained in package libxml2-ptest requires /usr/bin/python, but no providers found in RDEPENDS_libxml2-ptest? [file-rdeps] (From OE-Core rev: 65bc9fac6dc6ba5252bf105659724c768d65f9d9) Signed-off-by: Peter Kjellerstedt <peter.kjellerstedt@axis.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core/libxml/libxml2_2.9.4.bb')
-rw-r--r--meta/recipes-core/libxml/libxml2_2.9.4.bb11
1 files changed, 9 insertions, 2 deletions
diff --git a/meta/recipes-core/libxml/libxml2_2.9.4.bb b/meta/recipes-core/libxml/libxml2_2.9.4.bb
index ea0d3b88af..4f60781d22 100644
--- a/meta/recipes-core/libxml/libxml2_2.9.4.bb
+++ b/meta/recipes-core/libxml/libxml2_2.9.4.bb
@@ -24,7 +24,8 @@ SRC_URI = "ftp://xmlsoft.org/libxml2/libxml2-${PV}.tar.gz;name=libtar \
24 file://libxml2-CVE-2016-4658.patch \ 24 file://libxml2-CVE-2016-4658.patch \
25 file://libxml2-fix_NULL_pointer_derefs.patch \ 25 file://libxml2-fix_NULL_pointer_derefs.patch \
26 file://CVE-2016-9318.patch \ 26 file://CVE-2016-9318.patch \
27 " 27 file://0001-Make-ptest-run-the-python-tests-if-python-is-enabled.patch \
28 "
28 29
29SRC_URI[libtar.md5sum] = "ae249165c173b1ff386ee8ad676815f5" 30SRC_URI[libtar.md5sum] = "ae249165c173b1ff386ee8ad676815f5"
30SRC_URI[libtar.sha256sum] = "ffb911191e509b966deb55de705387f14156e1a56b21824357cdf0053233633c" 31SRC_URI[libtar.sha256sum] = "ffb911191e509b966deb55de705387f14156e1a56b21824357cdf0053233633c"
@@ -43,7 +44,7 @@ inherit autotools pkgconfig binconfig-disabled ptest
43 44
44inherit ${@bb.utils.contains('PACKAGECONFIG', 'python', 'python3native', '', d)} 45inherit ${@bb.utils.contains('PACKAGECONFIG', 'python', 'python3native', '', d)}
45 46
46RDEPENDS_${PN}-ptest += "make ${@bb.utils.contains('PACKAGECONFIG', 'python', 'python3-core', '', d)}" 47RDEPENDS_${PN}-ptest += "make ${@bb.utils.contains('PACKAGECONFIG', 'python', 'libgcc python3-core python3-argparse python3-logging python3-shell python3-signal python3-stringold python3-threading python3-unittest ${PN}-python', '', d)}"
47 48
48RDEPENDS_${PN}-python += "${@bb.utils.contains('PACKAGECONFIG', 'python', 'python3-core', '', d)}" 49RDEPENDS_${PN}-python += "${@bb.utils.contains('PACKAGECONFIG', 'python', 'python3-core', '', d)}"
49 50
@@ -77,6 +78,12 @@ do_configure_prepend () {
77 78
78do_install_ptest () { 79do_install_ptest () {
79 cp -r ${WORKDIR}/xmlconf ${D}${PTEST_PATH} 80 cp -r ${WORKDIR}/xmlconf ${D}${PTEST_PATH}
81 if [ "${@bb.utils.filter('PACKAGECONFIG', 'python', d)}" ]; then
82 sed -i -e 's|^\(PYTHON = \).*|\1${USRBINPATH}/${PYTHON_PN}|' \
83 ${D}${PTEST_PATH}/python/tests/Makefile
84 grep -lrZ '#!/usr/bin/python' ${D}${PTEST_PATH}/python |
85 xargs -0 sed -i -e 's|/usr/bin/python|${USRBINPATH}/${PYTHON_PN}|'
86 fi
80} 87}
81 88
82do_install_append_class-native () { 89do_install_append_class-native () {