summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/libxcrypt/libxcrypt_4.4.1.bb
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2018-12-17 11:40:04 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-12-18 16:19:34 +0000
commit195c763eff990cd6d45813ba56005bd3e5dda5ba (patch)
tree970ecffd93ba09ee375f836caa0d59db0c8224c6 /meta/recipes-core/libxcrypt/libxcrypt_4.4.1.bb
parentd59c162a3303a2b31f1df3680c25fdd86551eac4 (diff)
downloadpoky-195c763eff990cd6d45813ba56005bd3e5dda5ba.tar.gz
libxcrypt: Upgrade to 4.4.1 release
License-Update: New files added to existing list Add -Wno-error=missing-attributes to compiler flags, this helps in compiling with gcc 9.0, eventually, the code should be fixed Add a patch to fix x32 build (From OE-Core rev: 59be9254df9ffeda594b21af8be433564c898474) Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core/libxcrypt/libxcrypt_4.4.1.bb')
-rw-r--r--meta/recipes-core/libxcrypt/libxcrypt_4.4.1.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/meta/recipes-core/libxcrypt/libxcrypt_4.4.1.bb b/meta/recipes-core/libxcrypt/libxcrypt_4.4.1.bb
new file mode 100644
index 0000000000..5e5d7c077c
--- /dev/null
+++ b/meta/recipes-core/libxcrypt/libxcrypt_4.4.1.bb
@@ -0,0 +1,29 @@
1SUMMARY = "Extended cryptographic library (from glibc)"
2DESCRIPTION = "Forked code from glibc libary to extract only crypto part."
3HOMEPAGE = "https://github.com/besser82/libxcrypt"
4SECTION = "libs"
5LICENSE = "LGPLv2.1"
6LIC_FILES_CHKSUM ?= "file://LICENSING;md5=e28ba6195a4e39904919b78a92bcf27e \
7 file://COPYING.LIB;md5=4fbd65380cdd255951079008b364516c \
8"
9
10inherit autotools pkgconfig
11
12# v4.4.1
13SRCREV ?= "b8714d4e9e37cf0d511917bd5eea0e51e4a397d5"
14SRCBRANCH ?= "develop"
15
16SRC_URI = "git://github.com/besser82/libxcrypt.git;branch=${SRCBRANCH} \
17 file://0001-Add-x32-specific-inline-asm.patch \
18 "
19
20PROVIDES = "virtual/crypt"
21
22FILES_${PN} = "${libdir}/libcrypt*.so.* ${libdir}/libcrypt-*.so ${libdir}/libowcrypt*.so.* ${libdir}/libowcrypt-*.so"
23
24S = "${WORKDIR}/git"
25
26BUILD_CPPFLAGS = "-I${STAGING_INCDIR_NATIVE} -std=gnu99"
27TARGET_CPPFLAGS = "-I${STAGING_DIR_TARGET}${includedir} -Wno-error=missing-attributes"
28
29BBCLASSEXTEND = "nativesdk"