summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/libxcrypt/libxcrypt_4.1.1.bb
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2018-08-08 10:04:21 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-08-15 09:44:33 +0100
commit5601ae14d13ef66329ba9746f9dc378986dbabe2 (patch)
tree8f11ad1e25665d407d6c49334979429f0860f666 /meta/recipes-core/libxcrypt/libxcrypt_4.1.1.bb
parenta66052b36418ed3a2971993af3404fb08a1d5f30 (diff)
downloadpoky-5601ae14d13ef66329ba9746f9dc378986dbabe2.tar.gz
libxcrypt: Upgrade to 4.1.1
license update: Remove CDDL code with Public Domain pieces https://github.com/besser82/libxcrypt/commit/c76847e3be40c4ac0d78bc8518502418c6207144#diff-fdcb2380ff1eeea2e5795ec115ba1c0d inherit pkgconfig as it uses pkg-config during build (From OE-Core rev: 600b1f7da1bc308a52b566b77c994a90ed744b7e) Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core/libxcrypt/libxcrypt_4.1.1.bb')
-rw-r--r--meta/recipes-core/libxcrypt/libxcrypt_4.1.1.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/meta/recipes-core/libxcrypt/libxcrypt_4.1.1.bb b/meta/recipes-core/libxcrypt/libxcrypt_4.1.1.bb
new file mode 100644
index 0000000000..61ea22e4ea
--- /dev/null
+++ b/meta/recipes-core/libxcrypt/libxcrypt_4.1.1.bb
@@ -0,0 +1,27 @@
1SUMMARY = "Extended cryptographic library (from glibc)"
2DESCRIPTION = "Forked code from glibc libary to extract only crypto part."
3HOMEPAGE = "https://github.com/besser82/libxcrypt"
4SECTION = "libs"
5LICENSE = "LGPLv2.1"
6LIC_FILES_CHKSUM ?= "file://LICENSING;md5=cb3ca4cabd2447a37bf186fad6f79852 \
7 file://COPYING.LIB;md5=4fbd65380cdd255951079008b364516c \
8"
9
10inherit autotools pkgconfig
11
12SRCREV ?= "21b455b68baad279e6a3936faced16c5e5634376"
13SRCBRANCH ?= "master"
14
15SRC_URI = "git://github.com/besser82/libxcrypt.git;branch=${SRCBRANCH} \
16 "
17
18PROVIDES = "virtual/crypt"
19
20FILES_${PN} = "${libdir}/libcrypt*.so.* ${libdir}/libcrypt-*.so ${libdir}/libowcrypt*.so.* ${libdir}/libowcrypt-*.so"
21
22S = "${WORKDIR}/git"
23
24BUILD_CPPFLAGS = "-I${STAGING_INCDIR_NATIVE} -std=gnu99"
25TARGET_CPPFLAGS = "-I${STAGING_DIR_TARGET}${includedir}"
26
27BBCLASSEXTEND = "nativesdk"