summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/libxcrypt/libxcrypt.bb
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2018-12-26 12:09:50 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-12-27 22:52:58 +0000
commit1ef07c387ff1a5497151e453f2ca47c75d5135b2 (patch)
tree5f4e7b9b4863c5314e4c4b26423be63348fb21e5 /meta/recipes-core/libxcrypt/libxcrypt.bb
parentd80ada6025de5cc017a8997d9705bcc94411ca42 (diff)
downloadpoky-1ef07c387ff1a5497151e453f2ca47c75d5135b2.tar.gz
libxcrypt: Upgrade to 4.4.2
Licence-Update: Copyright Alexander Peslyak; 0-clause BSD added see https://github.com/besser82/libxcrypt/commit/e07290ec7c3de301ce2b813ee2b42131bef2b119 Rename recipe to ve versionless and add PV in recipe itself, makes it easy to traverse git history Drop upstreamed patch (From OE-Core rev: 2eae2d53df739acc2f89599a9296ccacbafebb60) Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core/libxcrypt/libxcrypt.bb')
-rw-r--r--meta/recipes-core/libxcrypt/libxcrypt.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/meta/recipes-core/libxcrypt/libxcrypt.bb b/meta/recipes-core/libxcrypt/libxcrypt.bb
new file mode 100644
index 0000000000..3b9af6d739
--- /dev/null
+++ b/meta/recipes-core/libxcrypt/libxcrypt.bb
@@ -0,0 +1,30 @@
1SUMMARY = "Extended cryptographic library (from glibc)"
2DESCRIPTION = "Forked code from glibc libary to extract only crypto part."
3HOMEPAGE = "https://github.com/besser82/libxcrypt"
4SECTION = "libs"
5LICENSE = "LGPLv2.1"
6LIC_FILES_CHKSUM ?= "file://LICENSING;md5=be275bc7f91642efe7709a8ae7a1433b \
7 file://COPYING.LIB;md5=4fbd65380cdd255951079008b364516c \
8"
9
10inherit autotools pkgconfig
11
12PV = "4.4.2"
13# v4.4.2
14SRCREV ?= "cf6abf18083566ec1612af27982a5160c9e0f137"
15SRCBRANCH ?= "develop"
16
17SRC_URI = "git://github.com/besser82/libxcrypt.git;branch=${SRCBRANCH} \
18 "
19
20PROVIDES = "virtual/crypt"
21
22FILES_${PN} = "${libdir}/libcrypt*.so.* ${libdir}/libcrypt-*.so ${libdir}/libowcrypt*.so.* ${libdir}/libowcrypt-*.so"
23
24S = "${WORKDIR}/git"
25
26BUILD_CPPFLAGS = "-I${STAGING_INCDIR_NATIVE} -std=gnu99"
27TARGET_CPPFLAGS = "-I${STAGING_DIR_TARGET}${includedir} -Wno-error=missing-attributes"
28CPPFLAGS_append_class-nativesdk = " -Wno-error=missing-attributes"
29
30BBCLASSEXTEND = "nativesdk"