summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/kbd/kbd_2.2.0.bb
diff options
context:
space:
mode:
authorAlexander Kanavin <alex.kanavin@gmail.com>2019-12-05 16:43:43 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-12-09 12:00:42 +0000
commit7c8a6cbf42271442189e463e9f8772521b4f263d (patch)
tree52710c090fa5a2d5e72804878a07798762121ad3 /meta/recipes-core/kbd/kbd_2.2.0.bb
parent491aac8f8f46bd5501203fef57e33f3ed871555c (diff)
downloadpoky-7c8a6cbf42271442189e463e9f8772521b4f263d.tar.gz
kbd: update to 2.2.0
Rebase set-proper-path-of-resources.patch Add a patch to address a string format error; as it modifies a .l file, add a dependency on flex which is processing that into C source code. License-Update: file with copyright statements was replaced with original GPLv2 text (From OE-Core rev: 729ac34dce472378cec5447c366a28de2081e7de) Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core/kbd/kbd_2.2.0.bb')
-rw-r--r--meta/recipes-core/kbd/kbd_2.2.0.bb67
1 files changed, 67 insertions, 0 deletions
diff --git a/meta/recipes-core/kbd/kbd_2.2.0.bb b/meta/recipes-core/kbd/kbd_2.2.0.bb
new file mode 100644
index 0000000000..9556302ab5
--- /dev/null
+++ b/meta/recipes-core/kbd/kbd_2.2.0.bb
@@ -0,0 +1,67 @@
1SUMMARY = "Keytable files and keyboard utilities"
2HOMEPAGE = "http://www.kbd-project.org/"
3# everything minus console-fonts is GPLv2+
4LICENSE = "GPLv2+"
5LIC_FILES_CHKSUM = "file://COPYING;md5=892f569a555ba9c07a568a7c0c4fa63a"
6
7inherit autotools gettext ptest pkgconfig
8
9DEPENDS += "flex-native"
10
11RREPLACES_${PN} = "console-tools"
12RPROVIDES_${PN} = "console-tools"
13RCONFLICTS_${PN} = "console-tools"
14
15SRC_URI = "${KERNELORG_MIRROR}/linux/utils/${BPN}/${BP}.tar.xz \
16 file://run-ptest \
17 ${@bb.utils.contains('DISTRO_FEATURES', 'ptest', 'file://set-proper-path-of-resources.patch', '', d)} \
18 file://0001-analyze.l-add-missing-string-format.patch \
19 "
20
21SRC_URI[md5sum] = "d1d7ae0b5fb875dc082731e09cd0c8bc"
22SRC_URI[sha256sum] = "21a1bc5f6fb3b18ce9fdd717e4533368060a3182a39c7155eaf7ec0f5f83e9f7"
23
24PACKAGECONFIG ?= "${@bb.utils.filter('DISTRO_FEATURES', 'pam', d)} \
25 ${@bb.utils.contains('PTEST_ENABLED', '1', 'tests','', d)} \
26 "
27
28PACKAGECONFIG[pam] = "--enable-vlock, --disable-vlock, libpam,"
29PACKAGECONFIG[tests] = "--enable-tests, --disable-tests, libcheck"
30
31do_compile_ptest() {
32 oe_runmake -C ${B}/tests dumpkeys-fulltable alt-is-meta
33}
34
35do_install_ptest() {
36 install -D ${B}/tests/Makefile ${D}${PTEST_PATH}/tests/Makefile
37 sed -i -e '/Makefile:/,/^$/d' -e '/%: %.in/,/^$/d' \
38 -e 's:--sysroot=${STAGING_DIR_TARGET}::g' \
39 -e 's:${DEBUG_PREFIX_MAP}::g' \
40 -e 's:${HOSTTOOLS_DIR}/::g' \
41 -e 's:${RECIPE_SYSROOT_NATIVE}::g' \
42 -e 's:${RECIPE_SYSROOT}::g' \
43 -e 's:${S}/config/missing::g' \
44 -e 's:${WORKDIR}::g' \
45 -e '/libkeymap_.*_SOURCES =/d' -e '/$(EXEEXT):/,/^$/d' ${D}${PTEST_PATH}/tests/Makefile
46
47 find ${B}/tests -executable -exec install {} ${D}${PTEST_PATH}/tests \;
48 find ${S}/tests \( -name \*.map -o -name \*.bin -o -name \*.output \) -exec install {} ${D}${PTEST_PATH}/tests \;
49
50 install -D -m 755 ${S}/config/test-driver ${D}${PTEST_PATH}/config/test-driver
51}
52
53PACKAGES += "${PN}-consolefonts ${PN}-keymaps ${PN}-unimaps ${PN}-consoletrans"
54
55FILES_${PN}-consolefonts = "${datadir}/consolefonts"
56FILES_${PN}-consoletrans = "${datadir}/consoletrans"
57FILES_${PN}-keymaps = "${datadir}/keymaps"
58FILES_${PN}-unimaps = "${datadir}/unimaps"
59
60RDEPENDS_${PN}-ptest = "make"
61
62inherit update-alternatives
63
64ALTERNATIVE_${PN} = "chvt deallocvt fgconsole openvt showkey"
65ALTERNATIVE_PRIORITY = "100"
66
67BBCLASSEXTEND = "native"