summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/kbd/kbd_2.0.3.bb
diff options
context:
space:
mode:
authorAlexander Kanavin <alexander.kanavin@linux.intel.com>2015-12-14 13:26:29 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-12-16 12:12:17 +0000
commitfef0ec64d672663c7fc267f01c6a57e58ec0ac87 (patch)
tree329994b4a3fb01c9ac4214316db06e57ed45b762 /meta/recipes-core/kbd/kbd_2.0.3.bb
parent8668e1798b2dbb546b5c0737f019999ffba3d4b1 (diff)
downloadpoky-fef0ec64d672663c7fc267f01c6a57e58ec0ac87.tar.gz
kbd: update to 2.0.3
0003-Only-inluclude-kernel-headers-with-glibc.patch is handling #include lines that are no longer present in the upstream source so it was dropped. (From OE-Core rev: 3232c56c01631953445429d1eb7ab532404d6271) Signed-off-by: Alexander Kanavin <alexander.kanavin@linux.intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core/kbd/kbd_2.0.3.bb')
-rw-r--r--meta/recipes-core/kbd/kbd_2.0.3.bb36
1 files changed, 36 insertions, 0 deletions
diff --git a/meta/recipes-core/kbd/kbd_2.0.3.bb b/meta/recipes-core/kbd/kbd_2.0.3.bb
new file mode 100644
index 0000000000..746b68adee
--- /dev/null
+++ b/meta/recipes-core/kbd/kbd_2.0.3.bb
@@ -0,0 +1,36 @@
1SUMMARY = "Keytable files and keyboard utilities"
2# everything minus console-fonts is GPLv2+
3LICENSE = "GPLv2+"
4LIC_FILES_CHKSUM = "file://COPYING;md5=a5fcc36121d93e1f69d96a313078c8b5"
5DEPENDS = "libcheck"
6
7inherit autotools gettext ptest pkgconfig
8
9RREPLACES_${PN} = "console-tools"
10RPROVIDES_${PN} = "console-tools"
11RCONFLICTS_${PN} = "console-tools"
12
13SRC_URI = "${KERNELORG_MIRROR}/linux/utils/${BPN}/${BP}.tar.xz \
14 file://uclibc-stdarg.patch \
15 "
16
17SRC_URI[md5sum] = "231b46e7142eb41ea3ae06d2ded3c208"
18SRC_URI[sha256sum] = "7a899de1c0eb75f3aea737095a736f2375e1cbfbe693fc14a3fe0bfb4649fb5e"
19
20PACKAGECONFIG ?= "${@bb.utils.contains('DISTRO_FEATURES', 'pam', 'pam', '', d)}"
21PACKAGECONFIG[pam] = "--enable-vlock, --disable-vlock, libpam,"
22
23PACKAGES += "${PN}-consolefonts ${PN}-keymaps ${PN}-unimaps ${PN}-consoletrans"
24
25FILES_${PN}-consolefonts = "${datadir}/consolefonts"
26FILES_${PN}-consoletrans = "${datadir}/consoletrans"
27FILES_${PN}-keymaps = "${datadir}/keymaps"
28FILES_${PN}-unimaps = "${datadir}/unimaps"
29
30inherit update-alternatives
31
32ALTERNATIVE_${PN} = "chvt deallocvt fgconsole openvt"
33ALTERNATIVE_PRIORITY = "100"
34
35BBCLASSEXTEND = "native"
36PARALLEL_MAKEINST = ""