summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/kbd/kbd_2.0.1.bb
diff options
context:
space:
mode:
authorTudor Florea <tudor.florea@enea.com>2014-10-16 03:05:19 +0200
committerTudor Florea <tudor.florea@enea.com>2014-10-16 03:05:19 +0200
commitc527fd1f14c27855a37f2e8ac5346ce8d940ced2 (patch)
treebb002c1fdf011c41dbd2f0927bed23ecb5f83c97 /meta/recipes-core/kbd/kbd_2.0.1.bb
downloadpoky-daisy-140929.tar.gz
initial commit for Enea Linux 4.0-140929daisy-140929
Migrated from the internal git server on the daisy-enea-point-release branch Signed-off-by: Tudor Florea <tudor.florea@enea.com>
Diffstat (limited to 'meta/recipes-core/kbd/kbd_2.0.1.bb')
-rw-r--r--meta/recipes-core/kbd/kbd_2.0.1.bb35
1 files changed, 35 insertions, 0 deletions
diff --git a/meta/recipes-core/kbd/kbd_2.0.1.bb b/meta/recipes-core/kbd/kbd_2.0.1.bb
new file mode 100644
index 0000000000..998a2d39b2
--- /dev/null
+++ b/meta/recipes-core/kbd/kbd_2.0.1.bb
@@ -0,0 +1,35 @@
1SUMMARY = "Keytable files and keyboard utilities"
2# everything minus console-fonts is GPLv2+
3LICENSE = "GPLv2+"
4LIC_FILES_CHKSUM = "file://COPYING;md5=a5fcc36121d93e1f69d96a313078c8b5"
5DEPENDS = "libcheck"
6
7inherit autotools gettext ptest
8
9RREPLACES_${PN} = "console-tools"
10RPROVIDES_${PN} = "console-tools"
11RCONFLICTS_${PN} = "console-tools"
12
13SRC_URI = "${KERNELORG_MIRROR}/linux/utils/${BPN}/${BP}.tar.bz2 \
14 file://uclibc-stdarg.patch \
15 "
16
17SRC_URI[md5sum] = "f80b93a6abddb6cc2a3652daaf7562ba"
18SRC_URI[sha256sum] = "223d60bb6882323cca161aeb5965590768b2f590fd7cddbf27511ad0ba7a429e"
19
20PACKAGECONFIG ?= "${@base_contains('DISTRO_FEATURES', 'pam', 'pam', '', d)}"
21PACKAGECONFIG[pam] = "--enable-vlock, --disable-vlock, libpam,"
22
23PACKAGES += "${PN}-consolefonts ${PN}-keymaps ${PN}-unimaps ${PN}-consoletrans"
24
25FILES_${PN}-consolefonts = "${datadir}/consolefonts"
26FILES_${PN}-consoletrans = "${datadir}/consoletrans"
27FILES_${PN}-keymaps = "${datadir}/keymaps"
28FILES_${PN}-unimaps = "${datadir}/unimaps"
29
30inherit update-alternatives
31
32ALTERNATIVE_${PN} = "chvt deallocvt fgconsole openvt"
33ALTERNATIVE_PRIORITY = "100"
34
35BBCLASSEXTEND = "native"