summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/jpeg/jpeg_8d.bb
diff options
context:
space:
mode:
authorMarko Lindqvist <cazfi74@gmail.com>2012-05-13 21:37:03 +0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-05-24 08:51:42 +0100
commit24038ec86e825fc3a4f1ffc6c89b605becac0f36 (patch)
tree243c0b8736bd72258d4bc4405f81e461a0d3f074 /meta/recipes-core/jpeg/jpeg_8d.bb
parent319b6f2708bbf71adb518b832309e891cb9edfb1 (diff)
downloadpoky-24038ec86e825fc3a4f1ffc6c89b605becac0f36.tar.gz
jpeg: update to upstream version 8d
* fix_for_automake_1.11.2.patch removed as issue resolved upstream * Have README as license file instead of several source files that just refer to it (From OE-Core rev: 330173c75426aa38919091da9ae8a9e90de9e0e2) Signed-off-by: Marko Lindqvist <cazfi74@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core/jpeg/jpeg_8d.bb')
-rw-r--r--meta/recipes-core/jpeg/jpeg_8d.bb55
1 files changed, 55 insertions, 0 deletions
diff --git a/meta/recipes-core/jpeg/jpeg_8d.bb b/meta/recipes-core/jpeg/jpeg_8d.bb
new file mode 100644
index 0000000000..61f1c2e038
--- /dev/null
+++ b/meta/recipes-core/jpeg/jpeg_8d.bb
@@ -0,0 +1,55 @@
1SUMMARY = "libjpeg is a library for handling the JPEG (JFIF) image format."
2DESCRIPTION = "libjpeg contains a library for handling the JPEG (JFIF) image format, as well as related programs for accessing the libjpeg functions."
3HOMEPAGE = "http://www.ijg.org/"
4BUGTRACKER = ""
5
6LICENSE ="BSD-3-Clause"
7LIC_FILES_CHKSUM = "file://README;md5=4f46756b064c225fae088903300e5c98"
8
9SECTION = "libs"
10
11DEPENDS = "libtool-cross"
12DEPENDS_virtclass-native = "libtool-native"
13
14PR = "r0"
15
16SRC_URI = "http://www.ijg.org/files/jpegsrc.v${PV}.tar.gz \
17 file://debian-libjpeg7_7-1.diff"
18
19SRC_URI[md5sum] = "52654eb3b2e60c35731ea8fc87f1bd29"
20SRC_URI[sha256sum] = "00029b1473f0f0ea72fbca3230e8cb25797fbb27e58ae2e46bb8bf5a806fe0b3"
21
22inherit autotools
23
24EXTRA_OECONF="--enable-static --enable-shared"
25EXTRA_OEMAKE='"LIBTOOL=${STAGING_BINDIR_CROSS}/${HOST_SYS}-libtool"'
26
27CFLAGS_append = " -D_REENTRANT"
28
29do_configure_prepend () {
30 rm -f ${S}/ltconfig
31 rm -f ${S}/ltmain.sh
32}
33
34do_install() {
35 install -d ${D}${bindir} ${D}${includedir} \
36 ${D}${mandir}/man1 ${D}${libdir}
37 oe_runmake 'DESTDIR=${D}' install
38}
39
40PACKAGES =+ "jpeg-tools "
41DESCRIPTION_jpeg-tools = "The jpeg-tools package includes the client programs for access libjpeg functionality. These tools allow for the compression, decompression, transformation and display of JPEG files."
42FILES_jpeg-tools = "${bindir}/*"
43
44BBCLASSEXTEND = "native"
45
46pkg_postinst_${PN}_linuxstdbase () {
47 if [ "$D" = "" ]; then
48 if [ ! -e ${libdir}/libjpeg.so.62 ]; then
49 JPEG=`find ${libdir} -type f -name libjpeg.so.\*.\*.\*`
50 ln -sf `basename $JPEG` ${libdir}/libjpeg.so.62
51 fi
52 else
53 exit 1
54 fi
55}