summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/initrdscripts/initramfs-live-install-efi_1.0.bb
diff options
context:
space:
mode:
authorDarren Hart <dvhart@linux.intel.com>2012-07-03 21:05:46 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-07-19 17:49:48 +0100
commit64f7feb5c37d06e1985c59106cf2f7cd286fd0b8 (patch)
treea016868a9546b81060b0d3b5ff9e33fcea46bad6 /meta/recipes-core/initrdscripts/initramfs-live-install-efi_1.0.bb
parentd36fa9a8835cd5aa6e14800d862b1a9da4dae30a (diff)
downloadpoky-64f7feb5c37d06e1985c59106cf2f7cd286fd0b8.tar.gz
EFI: Make installer EFI aware
[YOCTO #1919] Create a basic EFI installer script modeled after the existing installer and add it to a new initramfs-live-install-efi recipe. Update the init-live.sh script to distinguish between LABEL=install and LABEL=install-efi and select the appropriate script. Add the efi installer to core-image-minimal-initramfs. Update grub-efi.bbclass to use "LABEL=install-efi" when it detects a label of "install". This is clearly not ideal, but a proper fix would involve decoupling the LABELS assignment from the image-live.bbclass usage of SYSLINUX_LABELS. We should be able to address that in a follow-on clean-up series. V2: Include missing initramfs-live-install-efi_1.0.bb V3: Rebase after Radu's console_params fix (From OE-Core rev: 4bce3417917a3e88ba6529db394525fba82e0699) Signed-off-by: Darren Hart <dvhart@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core/initrdscripts/initramfs-live-install-efi_1.0.bb')
-rw-r--r--meta/recipes-core/initrdscripts/initramfs-live-install-efi_1.0.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/meta/recipes-core/initrdscripts/initramfs-live-install-efi_1.0.bb b/meta/recipes-core/initrdscripts/initramfs-live-install-efi_1.0.bb
new file mode 100644
index 0000000000..8ad47d476b
--- /dev/null
+++ b/meta/recipes-core/initrdscripts/initramfs-live-install-efi_1.0.bb
@@ -0,0 +1,22 @@
1DESCRIPTION = "A live image init script for grub-efi"
2LICENSE = "MIT"
3LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
4SRC_URI = "file://init-install-efi.sh"
5
6PR = "r0"
7
8RDEPENDS_${PN} = "parted e2fsprogs-mke2fs dosfstools"
9
10do_install() {
11 install -m 0755 ${WORKDIR}/init-install-efi.sh ${D}/install-efi.sh
12}
13
14# While this package maybe an allarch due to it being a
15# simple script, reality is that it is Host specific based
16# on the COMPATIBLE_HOST below, which needs to take precedence
17#inherit allarch
18INHIBIT_DEFAULT_DEPS = "1"
19
20FILES_${PN} = " /install-efi.sh "
21
22COMPATIBLE_HOST = "(i.86|x86_64).*-linux"