summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/images/build-appliance-image_15.0.0.bb
diff options
context:
space:
mode:
authorKosta Zertsekel <zertsekel@gmail.com>2018-11-04 21:24:46 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-11-07 23:08:55 +0000
commit92027161b5a4cb22e8f3f7fb5bd1bdd1babd2cfc (patch)
tree0b1b43383c27544743b8aaf2453d5cbf787cf759 /meta/recipes-core/images/build-appliance-image_15.0.0.bb
parentff842fe7771e399498264e14fa04a1d7935322a3 (diff)
downloadpoky-92027161b5a4cb22e8f3f7fb5bd1bdd1babd2cfc.tar.gz
meta: Use double colon for chown OWNER:GROUP
Rationale - excerp from `info chown` ==================================== OWNER‘:’GROUP If the OWNER is followed by a colon and a GROUP (a group name or numeric group ID), with no spaces between them, the group ownership of the files is changed as well (to GROUP). Some older scripts may still use ‘.’ in place of the ‘:’ separator. POSIX 1003.1-2001 (*note Standards conformance::) does not require support for that, but for backward compatibility GNU ‘chown’ supports ‘.’ so long as no ambiguity results. New scripts should avoid the use of ‘.’ because it is not portable, and because it has undesirable results if the entire OWNER‘.’GROUP happens to identify a user whose name contains ‘.’. (From OE-Core rev: 185918234a07cb506d7d7464a49ac33972c7d963) Signed-off-by: Kosta Zertsekel <zertsekel@gmail.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core/images/build-appliance-image_15.0.0.bb')
-rw-r--r--meta/recipes-core/images/build-appliance-image_15.0.0.bb6
1 files changed, 3 insertions, 3 deletions
diff --git a/meta/recipes-core/images/build-appliance-image_15.0.0.bb b/meta/recipes-core/images/build-appliance-image_15.0.0.bb
index 6abab60d7f..f03ef969ad 100644
--- a/meta/recipes-core/images/build-appliance-image_15.0.0.bb
+++ b/meta/recipes-core/images/build-appliance-image_15.0.0.bb
@@ -79,7 +79,7 @@ fakeroot do_populate_poky_src () {
79 echo "# export ALL_PROXY=https://proxy.example.com:8080" >> ${IMAGE_ROOTFS}/home/builder/.bashrc 79 echo "# export ALL_PROXY=https://proxy.example.com:8080" >> ${IMAGE_ROOTFS}/home/builder/.bashrc
80 echo "# export ALL_PROXY=socks://socks.example.com:1080" >> ${IMAGE_ROOTFS}/home/builder/.bashrc 80 echo "# export ALL_PROXY=socks://socks.example.com:1080" >> ${IMAGE_ROOTFS}/home/builder/.bashrc
81 81
82 chown -R builder.builder ${IMAGE_ROOTFS}/home/builder/poky 82 chown -R builder:builder ${IMAGE_ROOTFS}/home/builder/poky
83 chmod -R ug+rw ${IMAGE_ROOTFS}/home/builder/poky 83 chmod -R ug+rw ${IMAGE_ROOTFS}/home/builder/poky
84 84
85 # Assume we will need CDROM to install guest additions 85 # Assume we will need CDROM to install guest additions
@@ -107,8 +107,8 @@ fakeroot do_populate_poky_src () {
107 pip3_install_params="${pip3_install_params} --proxy ${http_proxy}" 107 pip3_install_params="${pip3_install_params} --proxy ${http_proxy}"
108 fi 108 fi
109 pip3 install ${pip3_install_params} 109 pip3 install ${pip3_install_params}
110 chown -R builder.builder ${IMAGE_ROOTFS}/home/builder/.local 110 chown -R builder:builder ${IMAGE_ROOTFS}/home/builder/.local
111 chown -R builder.builder ${IMAGE_ROOTFS}/home/builder/.cache 111 chown -R builder:builder ${IMAGE_ROOTFS}/home/builder/.cache
112} 112}
113 113
114IMAGE_PREPROCESS_COMMAND += "do_populate_poky_src; " 114IMAGE_PREPROCESS_COMMAND += "do_populate_poky_src; "