summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/ifupdown/ifupdown_0.8.35.bb
diff options
context:
space:
mode:
authorAlexander Kanavin <alex.kanavin@gmail.com>2020-01-14 14:59:56 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2020-01-16 22:33:09 +0000
commit83b900fec5e07414b0f06fc1ecc11ed145cc19d5 (patch)
treed7a94dec0c2a2dc1e185824395233e60537d596e /meta/recipes-core/ifupdown/ifupdown_0.8.35.bb
parentf0028da1e63c7cf1536dff7ff11e9de424dc2be2 (diff)
downloadpoky-83b900fec5e07414b0f06fc1ecc11ed145cc19d5.tar.gz
ifupdown: update 0.8.22 -> 0.8.35
Remove inet-6-.defn-fix-inverted-checks-for-loopback.patch as it is difficult to rebase and not clear if still necessary. (From OE-Core rev: 127cc7193a4d696ca7829fc0b36624ef8a1bc312) Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core/ifupdown/ifupdown_0.8.35.bb')
-rw-r--r--meta/recipes-core/ifupdown/ifupdown_0.8.35.bb47
1 files changed, 47 insertions, 0 deletions
diff --git a/meta/recipes-core/ifupdown/ifupdown_0.8.35.bb b/meta/recipes-core/ifupdown/ifupdown_0.8.35.bb
new file mode 100644
index 0000000000..0de97fe372
--- /dev/null
+++ b/meta/recipes-core/ifupdown/ifupdown_0.8.35.bb
@@ -0,0 +1,47 @@
1SUMMARY = "ifupdown: basic ifup and ifdown used by initscripts"
2DESCRIPTION = "High level tools to configure network interfaces \
3This package provides the tools ifup and ifdown which may be used to \
4configure (or, respectively, deconfigure) network interfaces, based on \
5the file /etc/network/interfaces."
6LICENSE = "GPLv2"
7LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f"
8
9SRC_URI = "git://salsa.debian.org/debian/ifupdown.git;protocol=https \
10 file://defn2-c-man-don-t-rely-on-dpkg-architecture-to-set-a.patch \
11 file://99_network \
12 file://0001-Define-FNM_EXTMATCH-for-musl.patch \
13 file://0001-Makefile-do-not-use-dpkg-for-determining-OS-type.patch \
14 "
15SRCREV = "4af76318cfc57f8e4a44d357104188666213bd4b"
16
17S = "${WORKDIR}/git"
18
19
20inherit update-alternatives
21
22do_compile () {
23 chmod a+rx *.pl *.sh
24 oe_runmake 'CC=${CC}' "CFLAGS=${CFLAGS} -Wall -W -D'IFUPDOWN_VERSION=\"${PV}\"'"
25}
26
27do_install () {
28 install -d ${D}${mandir}/man8 \
29 ${D}${mandir}/man5 \
30 ${D}${base_sbindir}
31
32 # If volatiles are used, then we'll also need /run/network there too.
33 install -d ${D}/etc/default/volatiles
34 install -m 0644 ${WORKDIR}/99_network ${D}/etc/default/volatiles
35
36 install -m 0755 ifup ${D}${base_sbindir}/
37 ln ${D}${base_sbindir}/ifup ${D}${base_sbindir}/ifdown
38 install -m 0644 ifup.8 ${D}${mandir}/man8
39 install -m 0644 interfaces.5 ${D}${mandir}/man5
40 cd ${D}${mandir}/man8 && ln -s ifup.8 ifdown.8
41}
42
43ALTERNATIVE_PRIORITY = "100"
44ALTERNATIVE_${PN} = "ifup ifdown"
45
46ALTERNATIVE_LINK_NAME[ifup] = "${base_sbindir}/ifup"
47ALTERNATIVE_LINK_NAME[ifdown] = "${base_sbindir}/ifdown"