summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/ifupdown/ifupdown_0.8.2.bb
diff options
context:
space:
mode:
authorAlexander Kanavin <alexander.kanavin@linux.intel.com>2015-12-16 17:27:09 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-12-28 09:25:14 +0000
commitaa90b5dda8e05858a194e67b7a64903152accb2e (patch)
tree98c0a0b5f60caa875198ea055de81649f4529f4d /meta/recipes-core/ifupdown/ifupdown_0.8.2.bb
parent4c98105f76a426abdcd8ed587fc6967df461443f (diff)
downloadpoky-aa90b5dda8e05858a194e67b7a64903152accb2e.tar.gz
ifupdown: update to 0.8.2
Switch upstream to git, as old versions can disappear from archive.ubuntu.com (From OE-Core rev: 1b09449dedfa2421c662b1d6f2104c235443e566) Signed-off-by: Alexander Kanavin <alexander.kanavin@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core/ifupdown/ifupdown_0.8.2.bb')
-rw-r--r--meta/recipes-core/ifupdown/ifupdown_0.8.2.bb51
1 files changed, 51 insertions, 0 deletions
diff --git a/meta/recipes-core/ifupdown/ifupdown_0.8.2.bb b/meta/recipes-core/ifupdown/ifupdown_0.8.2.bb
new file mode 100644
index 0000000000..732b295b8e
--- /dev/null
+++ b/meta/recipes-core/ifupdown/ifupdown_0.8.2.bb
@@ -0,0 +1,51 @@
1SUMMARY = "ifupdown: basic ifup and ifdown used by initscripts"
2DESCRIPTION = "High level tools to configure network interfaces \
3This package provides the tools ifup and ifdown which may be used to \
4configure (or, respectively, deconfigure) network interfaces, based on \
5the file /etc/network/interfaces."
6LICENSE = "GPLv2"
7LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f"
8
9SRC_URI = "git://anonscm.debian.org/git/collab-maint/ifupdown.git;protocol=https \
10 file://defn2-c-man-don-t-rely-on-dpkg-architecture-to-set-a.patch \
11 file://inet-6-.defn-fix-inverted-checks-for-loopback.patch \
12 file://99_network \
13 "
14SRCREV = "05ea2fd4f49bb1201aeef2a42efbcff8f336112f"
15
16EXTRA_OEMAKE = ""
17
18S = "${WORKDIR}/git"
19
20
21inherit update-rc.d update-alternatives
22
23do_compile () {
24 chmod a+rx *.pl *.sh
25 oe_runmake 'CC=${CC}' "CFLAGS=${CFLAGS} -Wall -W -D'IFUPDOWN_VERSION=\"${PV}\"'"
26}
27
28do_install () {
29 install -d ${D}${mandir}/man8 \
30 ${D}${mandir}/man5 \
31 ${D}${base_sbindir}
32
33 # If volatiles are used, then we'll also need /run/network there too.
34 install -d ${D}/etc/default/volatiles
35 install -m 0644 ${WORKDIR}/99_network ${D}/etc/default/volatiles
36
37 install -m 0755 ifup ${D}${base_sbindir}/
38 ln ${D}${base_sbindir}/ifup ${D}${base_sbindir}/ifdown
39 install -m 0644 ifup.8 ${D}${mandir}/man8
40 install -m 0644 interfaces.5 ${D}${mandir}/man5
41 cd ${D}${mandir}/man8 && ln -s ifup.8 ifdown.8
42}
43
44ALTERNATIVE_PRIORITY = "100"
45ALTERNATIVE_${PN} = "ifup ifdown"
46
47ALTERNATIVE_LINK_NAME[ifup] = "${base_sbindir}/ifup"
48ALTERNATIVE_LINK_NAME[ifdown] = "${base_sbindir}/ifdown"
49
50INITSCRIPT_NAME = "ifup"
51INITSCRIPT_PARAMS = "start 39 S . stop 39 0 6 1 ."