summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/ifupdown/ifupdown_0.8.16.bb
diff options
context:
space:
mode:
authorMaxin B. John <maxin.john@intel.com>2016-12-21 17:20:28 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-01-05 13:54:06 +0000
commitbb7aecb2f9b1d0e03c798bcf308801976a59b98a (patch)
tree2b4d8a3a25d8822b906a95be78a83ce26845e6cc /meta/recipes-core/ifupdown/ifupdown_0.8.16.bb
parentcb8bf9a017540d37f0e997efc1994424958bb9cc (diff)
downloadpoky-bb7aecb2f9b1d0e03c798bcf308801976a59b98a.tar.gz
ifupdown: upgrade to 0.8.16
Refreshed the following patch: * inet-6-.defn-fix-inverted-checks-for-loopback.patch (From OE-Core rev: 1daa09aa82c528dcc7682553dd6704a93aafdc88) Signed-off-by: Maxin B. John <maxin.john@intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core/ifupdown/ifupdown_0.8.16.bb')
-rw-r--r--meta/recipes-core/ifupdown/ifupdown_0.8.16.bb49
1 files changed, 49 insertions, 0 deletions
diff --git a/meta/recipes-core/ifupdown/ifupdown_0.8.16.bb b/meta/recipes-core/ifupdown/ifupdown_0.8.16.bb
new file mode 100644
index 0000000000..eb8426cb97
--- /dev/null
+++ b/meta/recipes-core/ifupdown/ifupdown_0.8.16.bb
@@ -0,0 +1,49 @@
1SUMMARY = "ifupdown: basic ifup and ifdown used by initscripts"
2DESCRIPTION = "High level tools to configure network interfaces \
3This package provides the tools ifup and ifdown which may be used to \
4configure (or, respectively, deconfigure) network interfaces, based on \
5the file /etc/network/interfaces."
6LICENSE = "GPLv2"
7LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f"
8
9SRC_URI = "git://anonscm.debian.org/git/collab-maint/ifupdown.git \
10 file://defn2-c-man-don-t-rely-on-dpkg-architecture-to-set-a.patch \
11 file://inet-6-.defn-fix-inverted-checks-for-loopback.patch \
12 file://99_network \
13 "
14SRCREV = "11b9f99f7ecc7052497e6786156cfed531f11823"
15
16S = "${WORKDIR}/git"
17
18
19inherit update-rc.d update-alternatives
20
21do_compile () {
22 chmod a+rx *.pl *.sh
23 oe_runmake 'CC=${CC}' "CFLAGS=${CFLAGS} -Wall -W -D'IFUPDOWN_VERSION=\"${PV}\"'"
24}
25
26do_install () {
27 install -d ${D}${mandir}/man8 \
28 ${D}${mandir}/man5 \
29 ${D}${base_sbindir}
30
31 # If volatiles are used, then we'll also need /run/network there too.
32 install -d ${D}/etc/default/volatiles
33 install -m 0644 ${WORKDIR}/99_network ${D}/etc/default/volatiles
34
35 install -m 0755 ifup ${D}${base_sbindir}/
36 ln ${D}${base_sbindir}/ifup ${D}${base_sbindir}/ifdown
37 install -m 0644 ifup.8 ${D}${mandir}/man8
38 install -m 0644 interfaces.5 ${D}${mandir}/man5
39 cd ${D}${mandir}/man8 && ln -s ifup.8 ifdown.8
40}
41
42ALTERNATIVE_PRIORITY = "100"
43ALTERNATIVE_${PN} = "ifup ifdown"
44
45ALTERNATIVE_LINK_NAME[ifup] = "${base_sbindir}/ifup"
46ALTERNATIVE_LINK_NAME[ifdown] = "${base_sbindir}/ifdown"
47
48INITSCRIPT_NAME = "ifup"
49INITSCRIPT_PARAMS = "start 39 S . stop 39 0 6 1 ."