summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/glibc/glibc_2.31.bb
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2019-12-20 15:40:20 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2020-01-19 13:24:38 +0000
commit2b5cf2a067cb6d9ca32d851dacdc1aff0cbfe904 (patch)
treeb19c049d43c8b2f1a2eefcc1f257eeef03a62c62 /meta/recipes-core/glibc/glibc_2.31.bb
parentc7a903aaa10eadae4ec7f4af3f3fa30763c144fc (diff)
downloadpoky-2b5cf2a067cb6d9ca32d851dacdc1aff0cbfe904.tar.gz
glibc: Upgrade to 2.31
License-Update: Prefer https to http for gnu.org and fsf.org URLs [1] [1] https://sourceware.org/git/?p=glibc.git;a=commit;h=5a82c74822d3272df2f5929133680478c0cfb4bd (From OE-Core rev: b22626d996e153d6094e1f76ed33ee1bb3eea751) Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core/glibc/glibc_2.31.bb')
-rw-r--r--meta/recipes-core/glibc/glibc_2.31.bb113
1 files changed, 113 insertions, 0 deletions
diff --git a/meta/recipes-core/glibc/glibc_2.31.bb b/meta/recipes-core/glibc/glibc_2.31.bb
new file mode 100644
index 0000000000..b8c570db52
--- /dev/null
+++ b/meta/recipes-core/glibc/glibc_2.31.bb
@@ -0,0 +1,113 @@
1require glibc.inc
2require glibc-version.inc
3
4DEPENDS += "gperf-native bison-native make-native"
5
6NATIVESDKFIXES ?= ""
7NATIVESDKFIXES_class-nativesdk = "\
8 file://0003-nativesdk-glibc-Look-for-host-system-ld.so.cache-as-.patch \
9 file://0004-nativesdk-glibc-Fix-buffer-overrun-with-a-relocated-.patch \
10 file://0005-nativesdk-glibc-Raise-the-size-of-arrays-containing-.patch \
11 file://0006-nativesdk-glibc-Allow-64-bit-atomics-for-x86.patch \
12 file://0007-nativesdk-glibc-Make-relocatable-install-for-locales.patch \
13"
14
15SRC_URI = "${GLIBC_GIT_URI};branch=${SRCBRANCH};name=glibc \
16 file://etc/ld.so.conf \
17 file://generate-supported.mk \
18 file://makedbs.sh \
19 \
20 ${NATIVESDKFIXES} \
21 file://0008-fsl-e500-e5500-e6500-603e-fsqrt-implementation.patch \
22 file://0009-readlib-Add-OECORE_KNOWN_INTERPRETER_NAMES-to-known-.patch \
23 file://0010-ppc-sqrt-Fix-undefined-reference-to-__sqrt_finite.patch \
24 file://0011-__ieee754_sqrt-f-are-now-inline-functions-and-call-o.patch \
25 file://0012-Quote-from-bug-1443-which-explains-what-the-patch-do.patch \
26 file://0013-eglibc-run-libm-err-tab.pl-with-specific-dirs-in-S.patch \
27 file://0014-__ieee754_sqrt-f-are-now-inline-functions-and-call-o.patch \
28 file://0015-sysdeps-gnu-configure.ac-handle-correctly-libc_cv_ro.patch \
29 file://0016-Add-unused-attribute.patch \
30 file://0017-yes-within-the-path-sets-wrong-config-variables.patch \
31 file://0018-timezone-re-written-tzselect-as-posix-sh.patch \
32 file://0019-Remove-bash-dependency-for-nscd-init-script.patch \
33 file://0020-eglibc-Cross-building-and-testing-instructions.patch \
34 file://0021-eglibc-Help-bootstrap-cross-toolchain.patch \
35 file://0022-eglibc-Clear-cache-lines-on-ppc8xx.patch \
36 file://0023-eglibc-Resolve-__fpscr_values-on-SH4.patch \
37 file://0024-eglibc-Forward-port-cross-locale-generation-support.patch \
38 file://0025-Define-DUMMY_LOCALE_T-if-not-defined.patch \
39 file://0026-localedef-add-to-archive-uses-a-hard-coded-locale-pa.patch \
40 file://0027-elf-dl-deps.c-Make-_dl_build_local_scope-breadth-fir.patch \
41 file://0028-intl-Emit-no-lines-in-bison-generated-files.patch \
42 file://0029-inject-file-assembly-directives.patch \
43 file://0030-locale-prevent-maybe-uninitialized-errors-with-Os-BZ.patch \
44 file://0031-Refactor-FORTIFY-in-glibc.patch \
45 "
46S = "${WORKDIR}/git"
47B = "${WORKDIR}/build-${TARGET_SYS}"
48
49PACKAGES_DYNAMIC = ""
50
51# the -isystem in bitbake.conf screws up glibc do_stage
52BUILD_CPPFLAGS = "-I${STAGING_INCDIR_NATIVE}"
53TARGET_CPPFLAGS = "-I${STAGING_DIR_TARGET}${includedir}"
54
55GLIBC_BROKEN_LOCALES = ""
56
57GLIBCPIE ??= ""
58
59EXTRA_OECONF = "--enable-kernel=${OLDEST_KERNEL} \
60 --disable-profile \
61 --disable-debug --without-gd \
62 --enable-clocale=gnu \
63 --with-headers=${STAGING_INCDIR} \
64 --without-selinux \
65 --enable-tunables \
66 --enable-bind-now \
67 --enable-stack-protector=strong \
68 --enable-stackguard-randomization \
69 --disable-crypt \
70 --with-default-link \
71 --enable-nscd \
72 ${@bb.utils.contains_any('SELECTED_OPTIMIZATION', '-O0 -Og', '--disable-werror', '', d)} \
73 ${GLIBCPIE} \
74 ${GLIBC_EXTRA_OECONF}"
75
76EXTRA_OECONF += "${@get_libc_fpu_setting(bb, d)}"
77
78do_patch_append() {
79 bb.build.exec_func('do_fix_readlib_c', d)
80}
81
82do_fix_readlib_c () {
83 sed -i -e 's#OECORE_KNOWN_INTERPRETER_NAMES#${EGLIBC_KNOWN_INTERPRETER_NAMES}#' ${S}/elf/readlib.c
84}
85
86do_configure () {
87# override this function to avoid the autoconf/automake/aclocal/autoheader
88# calls for now
89# don't pass CPPFLAGS into configure, since it upsets the kernel-headers
90# version check and doesn't really help with anything
91 (cd ${S} && gnu-configize) || die "failure in running gnu-configize"
92 find ${S} -name "configure" | xargs touch
93 CPPFLAGS="" oe_runconf
94}
95
96do_compile () {
97 # -Wl,-rpath-link <staging>/lib in LDFLAGS can cause breakage if another glibc is in staging
98 LDFLAGS="-fuse-ld=bfd"
99 base_do_compile
100 echo "Adjust ldd script"
101 if [ -n "${RTLDLIST}" ]
102 then
103 prevrtld=`cat ${B}/elf/ldd | grep "^RTLDLIST=" | sed 's#^RTLDLIST="\?\([^"]*\)"\?$#\1#'`
104 # remove duplicate entries
105 newrtld=`echo $(printf '%s\n' ${prevrtld} ${RTLDLIST} | LC_ALL=C sort -u)`
106 echo "ldd \"${prevrtld} ${RTLDLIST}\" -> \"${newrtld}\""
107 sed -i ${B}/elf/ldd -e "s#^RTLDLIST=.*\$#RTLDLIST=\"${newrtld}\"#"
108 fi
109}
110
111require glibc-package.inc
112
113BBCLASSEXTEND = "nativesdk"