summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/glibc/glibc_2.30.bb
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2019-08-04 08:14:46 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-08-07 16:08:15 +0100
commit196e56a5d9cadba43bf014bf78f644add2d12e3a (patch)
treee3739ec31f8e9e41de82a1ccecdd559d694358fb /meta/recipes-core/glibc/glibc_2.30.bb
parente93572cda749c43cf4ec79870cb4335e03d4ab55 (diff)
downloadpoky-196e56a5d9cadba43bf014bf78f644add2d12e3a.tar.gz
glibc: Update to glibc 2.30
- Drop backported patches - Move common pieces between cross-localedef and glibc into a common file - Move latest checksums to glibc-common.inc and remove duplicates from glibc recipe - Detailed release notes [1] [1] https://sourceware.org/ml/libc-alpha/2019-08/msg00029.html (From OE-Core rev: fe75808dca4bb56ac703d18ebbad4004678f69da) Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core/glibc/glibc_2.30.bb')
-rw-r--r--meta/recipes-core/glibc/glibc_2.30.bb112
1 files changed, 112 insertions, 0 deletions
diff --git a/meta/recipes-core/glibc/glibc_2.30.bb b/meta/recipes-core/glibc/glibc_2.30.bb
new file mode 100644
index 0000000000..03add3363c
--- /dev/null
+++ b/meta/recipes-core/glibc/glibc_2.30.bb
@@ -0,0 +1,112 @@
1require glibc.inc
2require glibc-version.inc
3
4DEPENDS += "gperf-native bison-native make-native"
5
6NATIVESDKFIXES ?= ""
7NATIVESDKFIXES_class-nativesdk = "\
8 file://0001-nativesdk-glibc-Look-for-host-system-ld.so.cache-as-.patch \
9 file://0002-nativesdk-glibc-Fix-buffer-overrun-with-a-relocated-.patch \
10 file://0003-nativesdk-glibc-Raise-the-size-of-arrays-containing-.patch \
11 file://0004-nativesdk-glibc-Allow-64-bit-atomics-for-x86.patch \
12 file://0005-nativesdk-glibc-Make-relocatable-install-for-locales.patch \
13"
14
15SRC_URI = "${GLIBC_GIT_URI};branch=${SRCBRANCH};name=glibc \
16 file://etc/ld.so.conf \
17 file://generate-supported.mk \
18 file://makedbs.sh \
19 \
20 ${NATIVESDKFIXES} \
21 file://0006-fsl-e500-e5500-e6500-603e-fsqrt-implementation.patch \
22 file://0007-readlib-Add-OECORE_KNOWN_INTERPRETER_NAMES-to-known-.patch \
23 file://0008-ppc-sqrt-Fix-undefined-reference-to-__sqrt_finite.patch \
24 file://0009-__ieee754_sqrt-f-are-now-inline-functions-and-call-o.patch \
25 file://0010-Quote-from-bug-1443-which-explains-what-the-patch-do.patch \
26 file://0011-eglibc-run-libm-err-tab.pl-with-specific-dirs-in-S.patch \
27 file://0012-__ieee754_sqrt-f-are-now-inline-functions-and-call-o.patch \
28 file://0013-sysdeps-gnu-configure.ac-handle-correctly-libc_cv_ro.patch \
29 file://0014-Add-unused-attribute.patch \
30 file://0015-yes-within-the-path-sets-wrong-config-variables.patch \
31 file://0016-timezone-re-written-tzselect-as-posix-sh.patch \
32 file://0017-Remove-bash-dependency-for-nscd-init-script.patch \
33 file://0018-eglibc-Cross-building-and-testing-instructions.patch \
34 file://0019-eglibc-Help-bootstrap-cross-toolchain.patch \
35 file://0020-eglibc-Clear-cache-lines-on-ppc8xx.patch \
36 file://0021-eglibc-Resolve-__fpscr_values-on-SH4.patch \
37 file://0022-eglibc-Forward-port-cross-locale-generation-support.patch \
38 file://0023-Define-DUMMY_LOCALE_T-if-not-defined.patch \
39 file://0024-localedef-add-to-archive-uses-a-hard-coded-locale-pa.patch \
40 file://0025-elf-dl-deps.c-Make-_dl_build_local_scope-breadth-fir.patch \
41 file://0026-intl-Emit-no-lines-in-bison-generated-files.patch \
42 file://0027-inject-file-assembly-directives.patch \
43 file://0028-locale-prevent-maybe-uninitialized-errors-with-Os-BZ.patch \
44 "
45S = "${WORKDIR}/git"
46B = "${WORKDIR}/build-${TARGET_SYS}"
47
48PACKAGES_DYNAMIC = ""
49
50# the -isystem in bitbake.conf screws up glibc do_stage
51BUILD_CPPFLAGS = "-I${STAGING_INCDIR_NATIVE}"
52TARGET_CPPFLAGS = "-I${STAGING_DIR_TARGET}${includedir}"
53
54GLIBC_BROKEN_LOCALES = ""
55
56GLIBCPIE ??= ""
57
58EXTRA_OECONF = "--enable-kernel=${OLDEST_KERNEL} \
59 --disable-profile \
60 --disable-debug --without-gd \
61 --enable-clocale=gnu \
62 --with-headers=${STAGING_INCDIR} \
63 --without-selinux \
64 --enable-tunables \
65 --enable-bind-now \
66 --enable-stack-protector=strong \
67 --enable-stackguard-randomization \
68 --disable-crypt \
69 --with-default-link \
70 --enable-nscd \
71 ${@bb.utils.contains_any('SELECTED_OPTIMIZATION', '-O0 -Og', '--disable-werror', '', d)} \
72 ${GLIBCPIE} \
73 ${GLIBC_EXTRA_OECONF}"
74
75EXTRA_OECONF += "${@get_libc_fpu_setting(bb, d)}"
76
77do_patch_append() {
78 bb.build.exec_func('do_fix_readlib_c', d)
79}
80
81do_fix_readlib_c () {
82 sed -i -e 's#OECORE_KNOWN_INTERPRETER_NAMES#${EGLIBC_KNOWN_INTERPRETER_NAMES}#' ${S}/elf/readlib.c
83}
84
85do_configure () {
86# override this function to avoid the autoconf/automake/aclocal/autoheader
87# calls for now
88# don't pass CPPFLAGS into configure, since it upsets the kernel-headers
89# version check and doesn't really help with anything
90 (cd ${S} && gnu-configize) || die "failure in running gnu-configize"
91 find ${S} -name "configure" | xargs touch
92 CPPFLAGS="" oe_runconf
93}
94
95do_compile () {
96 # -Wl,-rpath-link <staging>/lib in LDFLAGS can cause breakage if another glibc is in staging
97 LDFLAGS="-fuse-ld=bfd"
98 base_do_compile
99 echo "Adjust ldd script"
100 if [ -n "${RTLDLIST}" ]
101 then
102 prevrtld=`cat ${B}/elf/ldd | grep "^RTLDLIST=" | sed 's#^RTLDLIST="\?\([^"]*\)"\?$#\1#'`
103 # remove duplicate entries
104 newrtld=`echo $(printf '%s\n' ${prevrtld} ${RTLDLIST} | LC_ALL=C sort -u)`
105 echo "ldd \"${prevrtld} ${RTLDLIST}\" -> \"${newrtld}\""
106 sed -i ${B}/elf/ldd -e "s#^RTLDLIST=.*\$#RTLDLIST=\"${newrtld}\"#"
107 fi
108}
109
110require glibc-package.inc
111
112BBCLASSEXTEND = "nativesdk"