summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/glibc/glibc_2.28.bb
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2018-08-08 10:04:18 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-08-15 09:44:33 +0100
commitfb535ac046697db5923575bb23ee419fe7cfbab2 (patch)
tree8f842469be51c8e27647d28f4f2e8d955354dd83 /meta/recipes-core/glibc/glibc_2.28.bb
parent19ee0f26cbaaacebacf552878ce98149957d0ac3 (diff)
downloadpoky-fb535ac046697db5923575bb23ee419fe7cfbab2.tar.gz
glibc: Upgrade to 2.28
License-Update: libidn is dropped from glibc and a testcase that was a particular contributor copyrighted see https://sourceware.org/git/?p=glibc.git;a=blobdiff;f=LICENSES;h=0e3a9fe39b26e97038d92f904508a4c3aa1bb43b;hp=b29efe01084af28cc40953d7317f22927c0ee3b7;hb=5a357506659f9a00fcf5bc9c5d8fc676175c89a7;hpb=7279af007c420a9d5f88a6909d11e7cb712c16a4 https://sourceware.org/git/?p=glibc.git;a=blobdiff;f=LICENSES;h=b29efe01084af28cc40953d7317f22927c0ee3b7;hp=80f7f1487947f57815b9fe076fadc8c7f94eeb8e;hb=7f9f1ecb710eac4d65bb02785ddf288cac098323;hpb=5f7b841d3aebdccc2baed27cb4b22ddb08cd7c0c Drop upstreamed and backported patches (From OE-Core rev: da8bf414922ce7af865fadc4a86fd96ab6262506) Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core/glibc/glibc_2.28.bb')
-rw-r--r--meta/recipes-core/glibc/glibc_2.28.bb129
1 files changed, 129 insertions, 0 deletions
diff --git a/meta/recipes-core/glibc/glibc_2.28.bb b/meta/recipes-core/glibc/glibc_2.28.bb
new file mode 100644
index 0000000000..086daed04c
--- /dev/null
+++ b/meta/recipes-core/glibc/glibc_2.28.bb
@@ -0,0 +1,129 @@
1require glibc.inc
2
3LIC_FILES_CHKSUM = "file://LICENSES;md5=cfc0ed77a9f62fa62eded042ebe31d72 \
4 file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
5 file://posix/rxspencer/COPYRIGHT;md5=dc5485bb394a13b2332ec1c785f5d83a \
6 file://COPYING.LIB;md5=4fbd65380cdd255951079008b364516c"
7
8DEPENDS += "gperf-native bison-native"
9
10SRCREV ?= "3c03baca37fdcb52c3881e653ca392bba7a99c2b"
11
12SRCBRANCH ?= "release/${PV}/master"
13
14GLIBC_GIT_URI ?= "git://sourceware.org/git/glibc.git"
15UPSTREAM_CHECK_GITTAGREGEX = "(?P<pver>\d+\.\d+(\.(?!90)\d+)*)"
16
17SRC_URI = "${GLIBC_GIT_URI};branch=${SRCBRANCH};name=glibc \
18 file://etc/ld.so.conf \
19 file://generate-supported.mk \
20 \
21 ${NATIVESDKFIXES} \
22 file://0006-fsl-e500-e5500-e6500-603e-fsqrt-implementation.patch \
23 file://0007-readlib-Add-OECORE_KNOWN_INTERPRETER_NAMES-to-known-.patch \
24 file://0008-ppc-sqrt-Fix-undefined-reference-to-__sqrt_finite.patch \
25 file://0009-__ieee754_sqrt-f-are-now-inline-functions-and-call-o.patch \
26 file://0010-Quote-from-bug-1443-which-explains-what-the-patch-do.patch \
27 file://0011-eglibc-run-libm-err-tab.pl-with-specific-dirs-in-S.patch \
28 file://0012-__ieee754_sqrt-f-are-now-inline-functions-and-call-o.patch \
29 file://0013-sysdeps-gnu-configure.ac-handle-correctly-libc_cv_ro.patch \
30 file://0014-Add-unused-attribute.patch \
31 file://0015-yes-within-the-path-sets-wrong-config-variables.patch \
32 file://0016-timezone-re-written-tzselect-as-posix-sh.patch \
33 file://0017-Remove-bash-dependency-for-nscd-init-script.patch \
34 file://0018-eglibc-Cross-building-and-testing-instructions.patch \
35 file://0019-eglibc-Help-bootstrap-cross-toolchain.patch \
36 file://0020-eglibc-Clear-cache-lines-on-ppc8xx.patch \
37 file://0021-eglibc-Resolve-__fpscr_values-on-SH4.patch \
38 file://0022-eglibc-Forward-port-cross-locale-generation-support.patch \
39 file://0023-Define-DUMMY_LOCALE_T-if-not-defined.patch \
40 file://0024-elf-dl-deps.c-Make-_dl_build_local_scope-breadth-fir.patch \
41 file://0025-locale-fix-hard-coded-reference-to-gcc-E.patch \
42 file://0026-reset-dl_load_write_lock-after-forking.patch \
43 file://0027-Acquire-ld.so-lock-before-switching-to-malloc_atfork.patch \
44 file://0028-bits-siginfo-consts.h-enum-definition-for-TRAP_HWBKP.patch \
45 file://0029-localedef-add-to-archive-uses-a-hard-coded-locale-pa.patch \
46 file://0030-intl-Emit-no-lines-in-bison-generated-files.patch \
47"
48
49NATIVESDKFIXES ?= ""
50NATIVESDKFIXES_class-nativesdk = "\
51 file://0001-nativesdk-glibc-Look-for-host-system-ld.so.cache-as-.patch \
52 file://0002-nativesdk-glibc-Fix-buffer-overrun-with-a-relocated-.patch \
53 file://0003-nativesdk-glibc-Raise-the-size-of-arrays-containing-.patch \
54 file://0004-nativesdk-glibc-Allow-64-bit-atomics-for-x86.patch \
55 file://0005-nativesdk-glibc-Make-relocatable-install-for-locales.patch \
56"
57
58S = "${WORKDIR}/git"
59B = "${WORKDIR}/build-${TARGET_SYS}"
60
61PACKAGES_DYNAMIC = ""
62
63# the -isystem in bitbake.conf screws up glibc do_stage
64BUILD_CPPFLAGS = "-I${STAGING_INCDIR_NATIVE}"
65TARGET_CPPFLAGS = "-I${STAGING_DIR_TARGET}${includedir}"
66
67GLIBC_BROKEN_LOCALES = ""
68#
69# We will skip parsing glibc when target system C library selection is not glibc
70# this helps in easing out parsing for non-glibc system libraries
71#
72COMPATIBLE_HOST_libc-musl_class-target = "null"
73
74GLIBCPIE ??= ""
75
76EXTRA_OECONF = "--enable-kernel=${OLDEST_KERNEL} \
77 --disable-profile \
78 --disable-debug --without-gd \
79 --enable-clocale=gnu \
80 --with-headers=${STAGING_INCDIR} \
81 --without-selinux \
82 --enable-tunables \
83 --enable-bind-now \
84 --enable-stack-protector=strong \
85 --enable-stackguard-randomization \
86 ${GLIBCPIE} \
87 ${GLIBC_EXTRA_OECONF}"
88
89EXTRA_OECONF += "${@get_libc_fpu_setting(bb, d)}"
90EXTRA_OECONF += "${@bb.utils.contains('DISTRO_FEATURES', 'libc-inet-anl', '--enable-nscd', '--disable-nscd', d)}"
91
92
93do_patch_append() {
94 bb.build.exec_func('do_fix_readlib_c', d)
95}
96
97do_fix_readlib_c () {
98 sed -i -e 's#OECORE_KNOWN_INTERPRETER_NAMES#${EGLIBC_KNOWN_INTERPRETER_NAMES}#' ${S}/elf/readlib.c
99}
100
101do_configure () {
102# override this function to avoid the autoconf/automake/aclocal/autoheader
103# calls for now
104# don't pass CPPFLAGS into configure, since it upsets the kernel-headers
105# version check and doesn't really help with anything
106 (cd ${S} && gnu-configize) || die "failure in running gnu-configize"
107 find ${S} -name "configure" | xargs touch
108 CPPFLAGS="" oe_runconf
109}
110
111do_compile () {
112 # -Wl,-rpath-link <staging>/lib in LDFLAGS can cause breakage if another glibc is in staging
113 unset LDFLAGS
114 base_do_compile
115 echo "Adjust ldd script"
116 if [ -n "${RTLDLIST}" ]
117 then
118 prevrtld=`cat ${B}/elf/ldd | grep "^RTLDLIST=" | sed 's#^RTLDLIST="\?\([^"]*\)"\?$#\1#'`
119 if [ "${prevrtld}" != "${RTLDLIST}" ]
120 then
121 sed -i ${B}/elf/ldd -e "s#^RTLDLIST=.*\$#RTLDLIST=\"${prevrtld} ${RTLDLIST}\"#"
122 fi
123 fi
124
125}
126
127require glibc-package.inc
128
129BBCLASSEXTEND = "nativesdk"