summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/glibc/glibc_2.20.bb
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2014-08-28 06:00:54 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-09-01 18:02:21 +0100
commit54a3375a1084f02ebd95886739e951228e945c57 (patch)
treefe139449256b0ed85504b896a9782bccd8a9d3a1 /meta/recipes-core/glibc/glibc_2.20.bb
parent954e45bc7464573ed4776dbcd72eb76d4fca0b3d (diff)
downloadpoky-54a3375a1084f02ebd95886739e951228e945c57.tar.gz
glibc: Migrate eglibc 2.19 -> glibc 2.20
- This is a big swoop change where we switch to using glibc - option-groups are forward ported - cross-localedef is extracted out from eglibc and hosted at github.com/kraj/localedef, its used for cross-localedef recipe - Other non ported patches from eglibc are forward ported ppc8xx cache line workaround SH fpcr values dynamic resolver installing PIC archives is there but is not applied libc header bootstrap - Delete eglibc recipes we moved back to using glibc now - Fix ppc/e500 build - Fix crypt module build when options are used - Fix fnmatch build when options OPTION_EGLIBC_LOCALE_CODE is unset HAVE_MBSTATE_T and HAVE_MBSRTOWCS should be defined conditionally based upon OPTION_EGLIBC_LOCALE_CODE being set/unset - Move the ports/ patches to relevant files now that ports is gone (From OE-Core rev: 1027c535ea753e63d9ffe469a423e04467cf8940) Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core/glibc/glibc_2.20.bb')
-rw-r--r--meta/recipes-core/glibc/glibc_2.20.bb154
1 files changed, 154 insertions, 0 deletions
diff --git a/meta/recipes-core/glibc/glibc_2.20.bb b/meta/recipes-core/glibc/glibc_2.20.bb
new file mode 100644
index 0000000000..c6ef34afb3
--- /dev/null
+++ b/meta/recipes-core/glibc/glibc_2.20.bb
@@ -0,0 +1,154 @@
1require glibc.inc
2
3DEPENDS += "gperf-native kconfig-frontends-native"
4
5PV = "2.20"
6
7SRCREV = "529bf51595fffbe80023e7d895b671391991bb1b"
8
9SRC_URI = "git://sourceware.org/git/glibc.git;branch=master \
10 file://IO-acquire-lock-fix.patch \
11 file://mips-rld-map-check.patch \
12 file://etc/ld.so.conf \
13 file://generate-supported.mk \
14 file://glibc.fix_sqrt2.patch \
15 file://multilib_readlib.patch \
16 file://ppc-sqrt_finite.patch \
17 file://ppc_slow_ieee754_sqrt.patch \
18 file://add_resource_h_to_wait_h.patch \
19 file://fsl-ppc-no-fsqrt.patch \
20 file://0001-R_ARM_TLS_DTPOFF32.patch \
21 file://0001-eglibc-run-libm-err-tab.pl-with-specific-dirs-in-S.patch \
22 file://fix-tibetian-locales.patch \
23 file://ppce6500-32b_slow_ieee754_sqrt.patch \
24 file://grok_gold.patch \
25 file://fix_am_rootsbindir.patch \
26 file://0001-Define-__GI_fegetenv-for-e500-libm.patch \
27 ${EGLIBCPATCHES} \
28 "
29EGLIBCPATCHES = "\
30 file://timezone-re-written-tzselect-as-posix-sh.patch \
31 file://eglibc.patch \
32 file://option-groups.patch \
33 file://GLRO_dl_debug_mask.patch \
34 file://eglibc-header-bootstrap.patch \
35 file://eglibc-resolv-dynamic.patch \
36 file://eglibc-ppc8xx-cache-line-workaround.patch \
37 file://eglibc-sh4-fpscr_values.patch \
38 file://eglibc-use-option-groups.patch \
39 "
40# file://eglibc-install-pic-archives.patch \
41# file://initgroups_keys.patch \
42#
43
44LIC_FILES_CHKSUM = "file://LICENSES;md5=e9a558e243b36d3209f380deb394b213 \
45 file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
46 file://posix/rxspencer/COPYRIGHT;md5=dc5485bb394a13b2332ec1c785f5d83a \
47 file://COPYING.LIB;md5=4fbd65380cdd255951079008b364516c"
48
49SRC_URI_append_class-nativesdk = " file://ld-search-order.patch \
50 file://relocatable_sdk.patch \
51 file://relocatable_sdk_fix_openpath.patch \
52 "
53S = "${WORKDIR}/git"
54B = "${WORKDIR}/build-${TARGET_SYS}"
55
56PACKAGES_DYNAMIC = ""
57
58# the -isystem in bitbake.conf screws up glibc do_stage
59BUILD_CPPFLAGS = "-I${STAGING_INCDIR_NATIVE}"
60TARGET_CPPFLAGS = "-I${STAGING_DIR_TARGET}${includedir}"
61
62GLIBC_BROKEN_LOCALES = " _ER _ET so_ET yn_ER sid_ET tr_TR mn_MN gez_ET gez_ER bn_BD te_IN es_CR.ISO-8859-1"
63
64#
65# For now, we will skip building of a gcc package if it is a uclibc one
66# and our build is not a uclibc one, and we skip a glibc one if our build
67# is a uclibc build.
68#
69# See the note in gcc/gcc_3.4.0.oe
70#
71
72python __anonymous () {
73 import re
74 uc_os = (re.match('.*uclibc$', d.getVar('TARGET_OS', True)) != None)
75 if uc_os:
76 raise bb.parse.SkipPackage("incompatible with target %s" %
77 d.getVar('TARGET_OS', True))
78}
79
80EXTRA_OECONF = "--enable-kernel=${OLDEST_KERNEL} \
81 --without-cvs --disable-profile \
82 --disable-debug --without-gd \
83 --enable-clocale=gnu \
84 --enable-add-ons \
85 --with-headers=${STAGING_INCDIR} \
86 --without-selinux \
87 --enable-obsolete-rpc \
88 --with-kconfig=${STAGING_BINDIR_NATIVE} \
89 ${GLIBC_EXTRA_OECONF}"
90
91EXTRA_OECONF += "${@get_libc_fpu_setting(bb, d)}"
92
93do_patch_append() {
94 bb.build.exec_func('do_fix_readlib_c', d)
95}
96
97# for mips glibc now builds syscall tables for all abi's
98# so we make sure that we choose right march option which is
99# compatible with o32,n32 and n64 abi's
100# e.g. -march=mips32 is not compatible with n32 and n64 therefore
101# we filter it out in such case -march=from-abi which will be
102# mips1 when using o32 and mips3 when using n32/n64
103
104TUNE_CCARGS_mips := "${@oe_filter_out('-march=mips32', '${TUNE_CCARGS}', d)}"
105TUNE_CCARGS_mipsel := "${@oe_filter_out('-march=mips32', '${TUNE_CCARGS}', d)}"
106
107do_fix_readlib_c () {
108 sed -i -e 's#OECORE_KNOWN_INTERPRETER_NAMES#${EGLIBC_KNOWN_INTERPRETER_NAMES}#' ${S}/elf/readlib.c
109}
110
111do_configure () {
112# override this function to avoid the autoconf/automake/aclocal/autoheader
113# calls for now
114# don't pass CPPFLAGS into configure, since it upsets the kernel-headers
115# version check and doesn't really help with anything
116 if [ -z "`which rpcgen`" ]; then
117 echo "rpcgen not found. Install glibc-devel."
118 exit 1
119 fi
120 (cd ${S} && gnu-configize) || die "failure in running gnu-configize"
121 find ${S} -name "configure" | xargs touch
122 CPPFLAGS="" oe_runconf
123}
124
125rpcsvc = "bootparam_prot.x nlm_prot.x rstat.x \
126 yppasswd.x klm_prot.x rex.x sm_inter.x mount.x \
127 rusers.x spray.x nfs_prot.x rquota.x key_prot.x"
128
129do_compile () {
130 # -Wl,-rpath-link <staging>/lib in LDFLAGS can cause breakage if another glibc is in staging
131 unset LDFLAGS
132 base_do_compile
133 (
134 cd ${S}/sunrpc/rpcsvc
135 for r in ${rpcsvc}; do
136 h=`echo $r|sed -e's,\.x$,.h,'`
137 rpcgen -h $r -o $h || bbwarn "unable to generate header for $r"
138 done
139 )
140 echo "Adjust ldd script"
141 if [ -n "${RTLDLIST}" ]
142 then
143 prevrtld=`cat ${B}/elf/ldd | grep "^RTLDLIST=" | sed 's#^RTLDLIST="\?\([^"]*\)"\?$#\1#'`
144 if [ "${prevrtld}" != "${RTLDLIST}" ]
145 then
146 sed -i ${B}/elf/ldd -e "s#^RTLDLIST=.*\$#RTLDLIST=\"${prevrtld} ${RTLDLIST}\"#"
147 fi
148 fi
149
150}
151
152require glibc-package.inc
153
154BBCLASSEXTEND = "nativesdk"