summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/glibc/glibc_2.10.1.bb
diff options
context:
space:
mode:
authorDongxiao Xu <dongxiao.xu@intel.com>2011-06-28 14:58:15 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-06-28 13:44:41 +0100
commit8fa9d64f1d5128f304a0d36dbf55f49ccaf784b1 (patch)
treead031554642f4b160ec5b9bd044577c03ef0c5a6 /meta/recipes-core/glibc/glibc_2.10.1.bb
parent671e580111c3f37f3c7835956db17e0425f9f937 (diff)
downloadpoky-8fa9d64f1d5128f304a0d36dbf55f49ccaf784b1.tar.gz
libc-locale: split locale handling from libc recipe.
*libc's do_package will cost a lot of time due to the locale handing, which may delay the other recipe's do_package task and affect the build performance. This commit moves locale handling into a separate recipe *libc-locale. [RP: Add fixup with recent eglibc commit conflict for FILES_pn-dbg and PACKAGES] (From OE-Core rev: c6d3242f7642f537b02870bb4eb650f0e2094b85) Signed-off-by: Dongxiao Xu <dongxiao.xu@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core/glibc/glibc_2.10.1.bb')
-rw-r--r--meta/recipes-core/glibc/glibc_2.10.1.bb12
1 files changed, 12 insertions, 0 deletions
diff --git a/meta/recipes-core/glibc/glibc_2.10.1.bb b/meta/recipes-core/glibc/glibc_2.10.1.bb
index 33ebe24b03..a2e7b834f5 100644
--- a/meta/recipes-core/glibc/glibc_2.10.1.bb
+++ b/meta/recipes-core/glibc/glibc_2.10.1.bb
@@ -154,6 +154,18 @@ do_compile () {
154 ) 154 )
155} 155}
156 156
157do_install_locale () {
158 dest=${D}/${includedir}/glibc-locale-internal-${MULTIMACH_TARGET_SYS}
159 install -d ${dest} ${dest}${bindir}
160 cp -fpPR ${D}${base_libdir} ${dest}${base_prefix}
161 cp -fpPR ${D}${libdir} ${dest}${exec_prefix}
162 cp -fpPR ${D}${datadir} ${dest}${exec_prefix}
163 cp -fpPR ${D}${bindir}/localedef ${dest}${bindir}
164 cp -fpPR ${WORKDIR}/SUPPORTED ${dest}
165}
166
167addtask do_install_locale after do_install before do_populate_sysroot
168
157require glibc-stage.inc 169require glibc-stage.inc
158 170
159require glibc-package.inc 171require glibc-package.inc