summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/glibc/glibc-testsuite_2.31.bb
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2019-12-20 15:40:20 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2020-01-19 13:24:38 +0000
commit2b5cf2a067cb6d9ca32d851dacdc1aff0cbfe904 (patch)
treeb19c049d43c8b2f1a2eefcc1f257eeef03a62c62 /meta/recipes-core/glibc/glibc-testsuite_2.31.bb
parentc7a903aaa10eadae4ec7f4af3f3fa30763c144fc (diff)
downloadpoky-2b5cf2a067cb6d9ca32d851dacdc1aff0cbfe904.tar.gz
glibc: Upgrade to 2.31
License-Update: Prefer https to http for gnu.org and fsf.org URLs [1] [1] https://sourceware.org/git/?p=glibc.git;a=commit;h=5a82c74822d3272df2f5929133680478c0cfb4bd (From OE-Core rev: b22626d996e153d6094e1f76ed33ee1bb3eea751) Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core/glibc/glibc-testsuite_2.31.bb')
-rw-r--r--meta/recipes-core/glibc/glibc-testsuite_2.31.bb60
1 files changed, 60 insertions, 0 deletions
diff --git a/meta/recipes-core/glibc/glibc-testsuite_2.31.bb b/meta/recipes-core/glibc/glibc-testsuite_2.31.bb
new file mode 100644
index 0000000000..657fd4dbc1
--- /dev/null
+++ b/meta/recipes-core/glibc/glibc-testsuite_2.31.bb
@@ -0,0 +1,60 @@
1require glibc_${PV}.bb
2
3# handle PN differences
4FILESEXTRAPATHS_prepend := "${THISDIR}/glibc:"
5
6# strip provides
7PROVIDES = ""
8# setup depends
9INHIBIT_DEFAULT_DEPS = ""
10
11python () {
12 libc = d.getVar("PREFERRED_PROVIDER_virtual/libc")
13 libclocale = d.getVar("PREFERRED_PROVIDER_virtual/libc-locale")
14 if libc != "glibc" or libclocale != "glibc-locale":
15 raise bb.parse.SkipRecipe("glibc-testsuite requires that virtual/libc is glibc")
16}
17
18DEPENDS += "glibc-locale libgcc gcc-runtime"
19
20# remove the initial depends
21DEPENDS_remove = "libgcc-initial"
22
23inherit qemu
24
25SRC_URI += "file://check-test-wrapper"
26
27DEPENDS += "${@'qemu-native' if d.getVar('TOOLCHAIN_TEST_TARGET') == 'user' else ''}"
28
29TOOLCHAIN_TEST_TARGET ??= "user"
30TOOLCHAIN_TEST_HOST ??= "localhost"
31TOOLCHAIN_TEST_HOST_USER ??= "root"
32TOOLCHAIN_TEST_HOST_PORT ??= "2222"
33
34do_check[dirs] += "${B}"
35do_check[nostamp] = "1"
36do_check () {
37 chmod 0755 ${WORKDIR}/check-test-wrapper
38
39 # clean out previous test results
40 oe_runmake tests-clean
41 # makefiles don't clean entirely (and also sometimes fails due to too many args)
42 find ${B} -type f -name "*.out" -delete
43 find ${B} -type f -name "*.test-result" -delete
44 find ${B}/catgets -name "*.cat" -delete
45 find ${B}/conform -name "symlist-*" -delete
46 [ ! -e ${B}/timezone/testdata ] || rm -rf ${B}/timezone/testdata
47
48 oe_runmake -i \
49 QEMU_SYSROOT="${RECIPE_SYSROOT}" \
50 QEMU_OPTIONS="${@qemu_target_binary(d)} ${QEMU_OPTIONS}" \
51 SSH_HOST="${TOOLCHAIN_TEST_HOST}" \
52 SSH_HOST_USER="${TOOLCHAIN_TEST_HOST_USER}" \
53 SSH_HOST_PORT="${TOOLCHAIN_TEST_HOST_PORT}" \
54 test-wrapper="${WORKDIR}/check-test-wrapper ${TOOLCHAIN_TEST_TARGET}" \
55 check
56}
57addtask do_check after do_compile
58
59inherit nopackages
60deltask do_stash_locale