summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/glibc/cross-localedef-native_2.32.bb
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2020-08-07 15:09:36 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2020-08-08 09:17:49 +0100
commit392c117e7ab05da10a374f695d5232e7527ab5de (patch)
tree96acdc69cdc0815a3b820101ba14225ae466535d /meta/recipes-core/glibc/cross-localedef-native_2.32.bb
parent470c58ba4586082de802759686460222cc04336d (diff)
downloadpoky-392c117e7ab05da10a374f695d5232e7527ab5de.tar.gz
glibc: Upgrade to 2.32 release
Drop 0001-localedef-Add-hardlink-resolver-to-build.patch as its applied to localedef upstream Drop CVE patches which are already part of 2.32 release Drop unused attribute patch as its fixed differently in 2.32 Add a patch to mitigate the sideffect of [1] for ppc which detect wrong cpu in OE since we are cross compiling [1] https://sourceware.org/git/?p=glibc.git;a=commit;h=146fea07640387c78e334933de24b6353e1f0eba (From OE-Core rev: fe3d5136ef02721f9bbe01d98c1743b8dbcb69c5) Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core/glibc/cross-localedef-native_2.32.bb')
-rw-r--r--meta/recipes-core/glibc/cross-localedef-native_2.32.bb50
1 files changed, 50 insertions, 0 deletions
diff --git a/meta/recipes-core/glibc/cross-localedef-native_2.32.bb b/meta/recipes-core/glibc/cross-localedef-native_2.32.bb
new file mode 100644
index 0000000000..5a0abbb70f
--- /dev/null
+++ b/meta/recipes-core/glibc/cross-localedef-native_2.32.bb
@@ -0,0 +1,50 @@
1SUMMARY = "Cross locale generation tool for glibc"
2HOMEPAGE = "http://www.gnu.org/software/libc/libc.html"
3SECTION = "libs"
4LICENSE = "LGPL-2.1"
5
6LIC_FILES_CHKSUM = "file://LICENSES;md5=1541fd8f5e8f1579512bf05f533371ba \
7 file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
8 file://posix/rxspencer/COPYRIGHT;md5=dc5485bb394a13b2332ec1c785f5d83a \
9 file://COPYING.LIB;md5=4fbd65380cdd255951079008b364516c"
10
11require glibc-version.inc
12
13# Tell autotools that we're working in the localedef directory
14#
15AUTOTOOLS_SCRIPT_PATH = "${S}/localedef"
16
17inherit native
18inherit autotools
19
20FILESEXTRAPATHS =. "${FILE_DIRNAME}/${PN}:${FILE_DIRNAME}/glibc:"
21
22SRC_URI = "${GLIBC_GIT_URI};branch=${SRCBRANCH};name=glibc \
23 git://github.com/kraj/localedef;branch=master;name=localedef;destsuffix=git/localedef \
24 \
25 file://0001-localedef-Add-hardlink-resolver-from-util-linux.patch \
26 file://0002-localedef-fix-ups-hardlink-to-make-it-compile.patch \
27 \
28 file://0016-timezone-re-written-tzselect-as-posix-sh.patch \
29 file://0017-Remove-bash-dependency-for-nscd-init-script.patch \
30 file://0018-eglibc-Cross-building-and-testing-instructions.patch \
31 file://0019-eglibc-Help-bootstrap-cross-toolchain.patch \
32 file://0020-eglibc-Resolve-__fpscr_values-on-SH4.patch \
33 file://0021-eglibc-Forward-port-cross-locale-generation-support.patch \
34 file://0022-Define-DUMMY_LOCALE_T-if-not-defined.patch \
35 file://0023-localedef-add-to-archive-uses-a-hard-coded-locale-pa.patch \
36"
37# Makes for a rather long rev (22 characters), but...
38#
39SRCREV_FORMAT = "glibc_localedef"
40
41S = "${WORKDIR}/git"
42
43EXTRA_OECONF = "--with-glibc=${S}"
44CFLAGS += "-fgnu89-inline -std=gnu99 -DIS_IN\(x\)='0'"
45
46do_install() {
47 install -d ${D}${bindir}
48 install -m 0755 ${B}/localedef ${D}${bindir}/cross-localedef
49 install -m 0755 ${B}/cross-localedef-hardlink ${D}${bindir}/cross-localedef-hardlink
50}