summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/glibc/cross-localedef-native_2.28.bb
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2018-08-08 10:04:18 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-08-15 09:44:33 +0100
commitfb535ac046697db5923575bb23ee419fe7cfbab2 (patch)
tree8f842469be51c8e27647d28f4f2e8d955354dd83 /meta/recipes-core/glibc/cross-localedef-native_2.28.bb
parent19ee0f26cbaaacebacf552878ce98149957d0ac3 (diff)
downloadpoky-fb535ac046697db5923575bb23ee419fe7cfbab2.tar.gz
glibc: Upgrade to 2.28
License-Update: libidn is dropped from glibc and a testcase that was a particular contributor copyrighted see https://sourceware.org/git/?p=glibc.git;a=blobdiff;f=LICENSES;h=0e3a9fe39b26e97038d92f904508a4c3aa1bb43b;hp=b29efe01084af28cc40953d7317f22927c0ee3b7;hb=5a357506659f9a00fcf5bc9c5d8fc676175c89a7;hpb=7279af007c420a9d5f88a6909d11e7cb712c16a4 https://sourceware.org/git/?p=glibc.git;a=blobdiff;f=LICENSES;h=b29efe01084af28cc40953d7317f22927c0ee3b7;hp=80f7f1487947f57815b9fe076fadc8c7f94eeb8e;hb=7f9f1ecb710eac4d65bb02785ddf288cac098323;hpb=5f7b841d3aebdccc2baed27cb4b22ddb08cd7c0c Drop upstreamed and backported patches (From OE-Core rev: da8bf414922ce7af865fadc4a86fd96ab6262506) Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core/glibc/cross-localedef-native_2.28.bb')
-rw-r--r--meta/recipes-core/glibc/cross-localedef-native_2.28.bb51
1 files changed, 51 insertions, 0 deletions
diff --git a/meta/recipes-core/glibc/cross-localedef-native_2.28.bb b/meta/recipes-core/glibc/cross-localedef-native_2.28.bb
new file mode 100644
index 0000000000..0992e0285d
--- /dev/null
+++ b/meta/recipes-core/glibc/cross-localedef-native_2.28.bb
@@ -0,0 +1,51 @@
1SUMMARY = "Cross locale generation tool for glibc"
2HOMEPAGE = "http://www.gnu.org/software/libc/libc.html"
3SECTION = "libs"
4LICENSE = "LGPL-2.1"
5
6LIC_FILES_CHKSUM = "file://LICENSES;md5=cfc0ed77a9f62fa62eded042ebe31d72 \
7 file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
8 file://posix/rxspencer/COPYRIGHT;md5=dc5485bb394a13b2332ec1c785f5d83a \
9 file://COPYING.LIB;md5=4fbd65380cdd255951079008b364516c"
10
11# Tell autotools that we're working in the localedef directory
12#
13AUTOTOOLS_SCRIPT_PATH = "${S}/localedef"
14
15inherit native
16inherit autotools
17
18FILESEXTRAPATHS =. "${FILE_DIRNAME}/${PN}:${FILE_DIRNAME}/glibc:"
19
20SRCBRANCH ?= "release/${PV}/master"
21GLIBC_GIT_URI ?= "git://sourceware.org/git/glibc.git"
22UPSTREAM_CHECK_GITTAGREGEX = "(?P<pver>\d+\.\d+(\.(?!90)\d+)*)"
23
24SRCREV_glibc ?= "3c03baca37fdcb52c3881e653ca392bba7a99c2b"
25SRCREV_localedef ?= "de5bdbd5e76b5403a4151b9b9f958b6cca36b3e7"
26
27SRC_URI = "${GLIBC_GIT_URI};branch=${SRCBRANCH};name=glibc \
28 git://github.com/kraj/localedef;branch=master;name=localedef;destsuffix=git/localedef \
29 file://0016-timezone-re-written-tzselect-as-posix-sh.patch \
30 file://0017-Remove-bash-dependency-for-nscd-init-script.patch \
31 file://0018-eglibc-Cross-building-and-testing-instructions.patch \
32 file://0019-eglibc-Help-bootstrap-cross-toolchain.patch \
33 file://0020-eglibc-Clear-cache-lines-on-ppc8xx.patch \
34 file://0021-eglibc-Resolve-__fpscr_values-on-SH4.patch \
35 file://0022-eglibc-Forward-port-cross-locale-generation-support.patch \
36 file://0023-Define-DUMMY_LOCALE_T-if-not-defined.patch \
37 file://0029-localedef-add-to-archive-uses-a-hard-coded-locale-pa.patch \
38"
39# Makes for a rather long rev (22 characters), but...
40#
41SRCREV_FORMAT = "glibc_localedef"
42
43S = "${WORKDIR}/git"
44
45EXTRA_OECONF = "--with-glibc=${S}"
46CFLAGS += "-fgnu89-inline -std=gnu99 -DIS_IN\(x\)='0'"
47
48do_install() {
49 install -d ${D}${bindir}
50 install -m 0755 ${B}/localedef ${D}${bindir}/cross-localedef
51}