summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/gettext/gettext_0.19.8.1.bb
diff options
context:
space:
mode:
authorRobert Yang <liezhi.yang@windriver.com>2016-07-25 01:16:29 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-07-26 08:56:26 +0100
commitcff21235c20adc2cfceb7923e3dc9c276445b29c (patch)
tree820b223514c36049043673f3f393857a7e6dfa28 /meta/recipes-core/gettext/gettext_0.19.8.1.bb
parent91a6f3a3756219ae91435d60a0ceb8fd36fd056f (diff)
downloadpoky-cff21235c20adc2cfceb7923e3dc9c276445b29c.tar.gz
gettext: 0.19.6 -> 0.19.8.1
(From OE-Core rev: 450f4597d491789b0680940218e0e0bee7104ada) Signed-off-by: Robert Yang <liezhi.yang@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core/gettext/gettext_0.19.8.1.bb')
-rw-r--r--meta/recipes-core/gettext/gettext_0.19.8.1.bb120
1 files changed, 120 insertions, 0 deletions
diff --git a/meta/recipes-core/gettext/gettext_0.19.8.1.bb b/meta/recipes-core/gettext/gettext_0.19.8.1.bb
new file mode 100644
index 0000000000..7b8c1e8eb4
--- /dev/null
+++ b/meta/recipes-core/gettext/gettext_0.19.8.1.bb
@@ -0,0 +1,120 @@
1SUMMARY = "Utilities and libraries for producing multi-lingual messages"
2DESCRIPTION = "GNU gettext is a set of tools that provides a framework to help other programs produce multi-lingual messages. These tools include a set of conventions about how programs should be written to support message catalogs, a directory and file naming organization for the message catalogs themselves, a runtime library supporting the retrieval of translated messages, and a few stand-alone programs to massage in various ways the sets of translatable and already translated strings."
3HOMEPAGE = "http://www.gnu.org/software/gettext/gettext.html"
4SECTION = "libs"
5LICENSE = "GPLv3+ & LGPL-2.1+"
6LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
7
8DEPENDS = "gettext-native virtual/libiconv expat"
9DEPENDS_class-native = "gettext-minimal-native"
10PROVIDES = "virtual/libintl virtual/gettext"
11PROVIDES_class-native = "virtual/gettext-native"
12RCONFLICTS_${PN} = "proxy-libintl"
13SRC_URI = "${GNU_MIRROR}/gettext/gettext-${PV}.tar.gz \
14 file://parallel.patch \
15 file://add-with-bisonlocaledir.patch \
16"
17
18SRC_URI[md5sum] = "97e034cf8ce5ba73a28ff6c3c0638092"
19SRC_URI[sha256sum] = "ff942af0e438ced4a8b0ea4b0b6e0d6d657157c5e2364de57baa279c1c125c43"
20
21PACKAGECONFIG[msgcat-curses] = "--with-libncurses-prefix=${STAGING_LIBDIR}/..,--disable-curses,ncurses,"
22
23LDFLAGS_prepend_libc-uclibc = " -lrt -lpthread "
24
25inherit autotools texinfo
26
27EXTRA_OECONF += "--without-lispdir \
28 --disable-csharp \
29 --disable-libasprintf \
30 --disable-java \
31 --disable-native-java \
32 --disable-openmp \
33 --disable-acl \
34 --with-included-glib \
35 --without-emacs \
36 --without-cvs \
37 --without-git \
38 --with-included-libxml \
39 --with-included-libcroco \
40 --with-included-libunistring \
41 "
42EXTRA_OECONF_append_class-target = " \
43 --with-bisonlocaledir=${datadir}/locale \
44"
45
46acpaths = '-I ${S}/gettext-runtime/m4 \
47 -I ${S}/gettext-tools/m4'
48
49do_install_append_libc-musl () {
50 rm -f ${D}${libdir}/charset.alias
51 rm -f ${D}${includedir}/libintl.h
52 rm -f ${D}${libdir}/libintl.la
53}
54
55# these lack the .x behind the .so, but shouldn't be in the -dev package
56# Otherwise you get the following results:
57# 7.4M glibc/images/ep93xx/Angstrom-console-image-glibc-ipk-2008.1-test-20080104-ep93xx.rootfs.tar.gz
58# 25M uclibc/images/ep93xx/Angstrom-console-image-uclibc-ipk-2008.1-test-20080104-ep93xx.rootfs.tar.gz
59# because gettext depends on gettext-dev, which pulls in more -dev packages:
60# 15228 KiB /ep93xx/libstdc++-dev_4.2.2-r2_ep93xx.ipk
61# 1300 KiB /ep93xx/uclibc-dev_0.9.29-r8_ep93xx.ipk
62# 140 KiB /armv4t/gettext-dev_0.14.1-r6_armv4t.ipk
63# 4 KiB /ep93xx/libgcc-s-dev_4.2.2-r2_ep93xx.ipk
64
65PACKAGES =+ "libgettextlib libgettextsrc"
66FILES_libgettextlib = "${libdir}/libgettextlib-*.so*"
67FILES_libgettextsrc = "${libdir}/libgettextsrc-*.so*"
68
69PACKAGES =+ "gettext-runtime gettext-runtime-dev gettext-runtime-doc"
70
71FILES_${PN} += "${libdir}/${BPN}/*"
72
73# The its/Makefile.am has defined:
74# itsdir = $(pkgdatadir)$(PACKAGE_SUFFIX)/its
75# not itsdir = $(pkgdatadir), so use wildcard to match the version.
76FILES_${PN} += "${datadir}/${BPN}-*/*"
77
78FILES_gettext-runtime = "${bindir}/gettext \
79 ${bindir}/ngettext \
80 ${bindir}/envsubst \
81 ${bindir}/gettext.sh \
82 ${libdir}/libasprintf.so* \
83 ${libdir}/GNU.Gettext.dll \
84 "
85FILES_gettext-runtime_append_libc-uclibc = " ${libdir}/libintl.so.* \
86 ${libdir}/charset.alias \
87 "
88FILES_gettext-runtime-dev += "${libdir}/libasprintf.a \
89 ${includedir}/autosprintf.h \
90 "
91FILES_gettext-runtime-dev_append_libc-uclibc = " ${libdir}/libintl.so \
92 ${includedir}/libintl.h \
93 "
94FILES_gettext-runtime-doc = "${mandir}/man1/gettext.* \
95 ${mandir}/man1/ngettext.* \
96 ${mandir}/man1/envsubst.* \
97 ${mandir}/man1/.* \
98 ${mandir}/man3/* \
99 ${docdir}/gettext/gettext.* \
100 ${docdir}/gettext/ngettext.* \
101 ${docdir}/gettext/envsubst.* \
102 ${docdir}/gettext/*.3.html \
103 ${datadir}/gettext/ABOUT-NLS \
104 ${docdir}/gettext/csharpdoc/* \
105 ${docdir}/libasprintf/autosprintf.html \
106 ${infodir}/autosprintf.info \
107 "
108
109do_install_append() {
110 rm -f ${D}${libdir}/preloadable_libintl.so
111}
112
113do_install_append_class-native () {
114 rm ${D}${datadir}/aclocal/*
115 rm ${D}${datadir}/gettext/config.rpath
116 rm ${D}${datadir}/gettext/po/Makefile.in.in
117 rm ${D}${datadir}/gettext/po/remove-potcdate.sin
118}
119
120BBCLASSEXTEND = "native nativesdk"