summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/gettext/gettext_0.18.3.2.bb
diff options
context:
space:
mode:
authorTudor Florea <tudor.florea@enea.com>2014-10-16 03:05:19 +0200
committerTudor Florea <tudor.florea@enea.com>2014-10-16 03:05:19 +0200
commitc527fd1f14c27855a37f2e8ac5346ce8d940ced2 (patch)
treebb002c1fdf011c41dbd2f0927bed23ecb5f83c97 /meta/recipes-core/gettext/gettext_0.18.3.2.bb
downloadpoky-daisy-140929.tar.gz
initial commit for Enea Linux 4.0-140929daisy-140929
Migrated from the internal git server on the daisy-enea-point-release branch Signed-off-by: Tudor Florea <tudor.florea@enea.com>
Diffstat (limited to 'meta/recipes-core/gettext/gettext_0.18.3.2.bb')
-rw-r--r--meta/recipes-core/gettext/gettext_0.18.3.2.bb106
1 files changed, 106 insertions, 0 deletions
diff --git a/meta/recipes-core/gettext/gettext_0.18.3.2.bb b/meta/recipes-core/gettext/gettext_0.18.3.2.bb
new file mode 100644
index 0000000000..553d52223e
--- /dev/null
+++ b/meta/recipes-core/gettext/gettext_0.18.3.2.bb
@@ -0,0 +1,106 @@
1SUMMARY = "Utilities and libraries for producing multi-lingual messages"
2DESCRIPTION = "GNU gettext is a set of tools that provides a framework to help other programs produce multi-lingual messages. These tools include a set of conventions about how programs should be written to support message catalogs, a directory and file naming organization for the message catalogs themselves, a runtime library supporting the retrieval of translated messages, and a few stand-alone programs to massage in various ways the sets of translatable and already translated strings."
3HOMEPAGE = "http://www.gnu.org/software/gettext/gettext.html"
4SECTION = "libs"
5LICENSE = "GPLv3+ & LGPL-2.1+"
6LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
7
8DEPENDS = "gettext-native virtual/libiconv expat"
9DEPENDS_class-native = "gettext-minimal-native"
10PROVIDES = "virtual/libintl virtual/gettext"
11PROVIDES_class-native = "virtual/gettext-native"
12RCONFLICTS_${PN} = "proxy-libintl"
13SRC_URI = "${GNU_MIRROR}/gettext/gettext-${PV}.tar.gz \
14 file://parallel.patch \
15 "
16
17PACKAGECONFIG[msgcat-curses] = "--with-libncurses-prefix=${STAGING_LIBDIR}/..,--disable-curses,ncurses,"
18
19LDFLAGS_prepend_libc-uclibc = " -lrt -lpthread "
20
21SRC_URI[md5sum] = "241aba309d07aa428252c74b40a818ef"
22SRC_URI[sha256sum] = "d1a4e452d60eb407ab0305976529a45c18124bd518d976971ac6dc7aa8b4c5d7"
23
24inherit autotools
25
26EXTRA_OECONF += "--without-lispdir \
27 --disable-csharp \
28 --disable-libasprintf \
29 --disable-java \
30 --disable-native-java \
31 --disable-openmp \
32 --disable-acl \
33 --with-included-glib \
34 --without-emacs \
35 --without-cvs \
36 --without-git \
37 --with-included-libxml \
38 --with-included-libcroco \
39 --with-included-libunistring \
40 "
41
42acpaths = '-I ${S}/gettext-runtime/m4 \
43 -I ${S}/gettext-tools/m4'
44
45
46# these lack the .x behind the .so, but shouldn't be in the -dev package
47# Otherwise you get the following results:
48# 7.4M glibc/images/ep93xx/Angstrom-console-image-glibc-ipk-2008.1-test-20080104-ep93xx.rootfs.tar.gz
49# 25M uclibc/images/ep93xx/Angstrom-console-image-uclibc-ipk-2008.1-test-20080104-ep93xx.rootfs.tar.gz
50# because gettext depends on gettext-dev, which pulls in more -dev packages:
51# 15228 KiB /ep93xx/libstdc++-dev_4.2.2-r2_ep93xx.ipk
52# 1300 KiB /ep93xx/uclibc-dev_0.9.29-r8_ep93xx.ipk
53# 140 KiB /armv4t/gettext-dev_0.14.1-r6_armv4t.ipk
54# 4 KiB /ep93xx/libgcc-s-dev_4.2.2-r2_ep93xx.ipk
55
56PACKAGES =+ "libgettextlib libgettextsrc"
57FILES_libgettextlib = "${libdir}/libgettextlib-*.so*"
58FILES_libgettextsrc = "${libdir}/libgettextsrc-*.so*"
59
60PACKAGES =+ "gettext-runtime gettext-runtime-dev gettext-runtime-doc"
61
62FILES_${PN} += "${libdir}/${BPN}/*"
63
64FILES_gettext-runtime = "${bindir}/gettext \
65 ${bindir}/ngettext \
66 ${bindir}/envsubst \
67 ${bindir}/gettext.sh \
68 ${libdir}/libasprintf.so* \
69 ${libdir}/GNU.Gettext.dll \
70 "
71FILES_gettext-runtime_append_libc-uclibc = " ${libdir}/libintl.so.* \
72 ${libdir}/charset.alias \
73 "
74FILES_gettext-runtime-dev += "${libdir}/libasprintf.a \
75 ${includedir}/autosprintf.h \
76 "
77FILES_gettext-runtime-dev_append_libc-uclibc = " ${libdir}/libintl.so \
78 ${includedir}/libintl.h \
79 "
80FILES_gettext-runtime-doc = "${mandir}/man1/gettext.* \
81 ${mandir}/man1/ngettext.* \
82 ${mandir}/man1/envsubst.* \
83 ${mandir}/man1/.* \
84 ${mandir}/man3/* \
85 ${docdir}/gettext/gettext.* \
86 ${docdir}/gettext/ngettext.* \
87 ${docdir}/gettext/envsubst.* \
88 ${docdir}/gettext/*.3.html \
89 ${datadir}/gettext/ABOUT-NLS \
90 ${docdir}/gettext/csharpdoc/* \
91 ${docdir}/libasprintf/autosprintf.html \
92 ${infodir}/autosprintf.info \
93 "
94
95do_install_append() {
96 rm -f ${D}${libdir}/preloadable_libintl.so
97}
98
99do_install_append_class-native () {
100 rm ${D}${datadir}/aclocal/*
101 rm ${D}${datadir}/gettext/config.rpath
102 rm ${D}${datadir}/gettext/po/Makefile.in.in
103 rm ${D}${datadir}/gettext/po/remove-potcdate.sin
104}
105
106BBCLASSEXTEND = "native nativesdk"