summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/gettext/gettext-minimal-native_0.19.4.bb
diff options
context:
space:
mode:
authorRobert Yang <liezhi.yang@windriver.com>2015-01-13 07:02:50 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-01-23 11:36:26 +0000
commitb3dd5ecd52901edc9a2ddd0233e99f3a1b82bda3 (patch)
tree12667393d13a102e2c2499963126ce27a5dc2717 /meta/recipes-core/gettext/gettext-minimal-native_0.19.4.bb
parentedd91b4b302e31e16cebff7934d620be4ca77f3c (diff)
downloadpoky-b3dd5ecd52901edc9a2ddd0233e99f3a1b82bda3.tar.gz
gettext: upgrade to 0.19.4
* gettext: - Update parallel.patch, we only need a part of it. * gettext-minimal-native: - Update related files from gettext-native. - Remove Makevars.template, we didn't use it. - Remove iconv-m4-remove-the-test-to-convert-euc-jp.patch (can be reverse applied). - Update the COPYING (1995 - 2014). * About upgrade gettext-minimal-native (for future's upgrade): - Build gettext-native - Copy gettext-runtime/po/Makefile.in.in, build-aux/config.rpath and gettext-runtime/po/remove-potcdate.sin from gettext-native. - Update COPYING when needed (usually update the year), do not copy the whole COPYING file from gettext-native. - Go to gettext-native's ${S}/gettext-runtime/m4: > Remove lt*.m4 and libtool.m4 > copy lib-ld.m4 lib-link.m4 lib-prefix.m4 from ${S}/gettext-runtime/m4/ > tar czvf /path/to/aclocal.tgz *.m4 (From OE-Core rev: cd91b748e83bd5c040538aecf76823549662b3c7) Signed-off-by: Robert Yang <liezhi.yang@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core/gettext/gettext-minimal-native_0.19.4.bb')
-rw-r--r--meta/recipes-core/gettext/gettext-minimal-native_0.19.4.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/meta/recipes-core/gettext/gettext-minimal-native_0.19.4.bb b/meta/recipes-core/gettext/gettext-minimal-native_0.19.4.bb
new file mode 100644
index 0000000000..ca97315a85
--- /dev/null
+++ b/meta/recipes-core/gettext/gettext-minimal-native_0.19.4.bb
@@ -0,0 +1,31 @@
1SUMMARY = "Minimal gettext for supporting native autoconf/automake"
2DESCRIPTION = "Contains the m4 macros sufficient to support building \
3autoconf/automake. This provides a significant build time speedup by \
4the removal of gettext-native from most dependency chains (now only \
5needed for gettext for the target)."
6SRC_URI = "file://aclocal.tgz \
7 file://config.rpath \
8 file://Makefile.in.in \
9 file://remove-potcdate.sin \
10 file://COPYING \
11"
12
13INHIBIT_DEFAULT_DEPS = "1"
14INHIBIT_AUTOTOOLS_DEPS = "1"
15
16LICENSE = "FSF-Unlimited"
17LIC_FILES_CHKSUM = "file://COPYING;md5=1b20675cd5158442f6007d022f46b35b"
18
19inherit native
20
21
22S = "${WORKDIR}"
23
24do_install () {
25 install -d ${D}${datadir}/aclocal/
26 cp ${WORKDIR}/*.m4 ${D}${datadir}/aclocal/
27 install -d ${D}${datadir}/gettext/po/
28 cp ${WORKDIR}/config.rpath ${D}${datadir}/gettext/
29 cp ${WORKDIR}/Makefile.in.in ${D}${datadir}/gettext/po/
30 cp ${WORKDIR}/remove-potcdate.sin ${D}${datadir}/gettext/po/
31}