summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/gettext/gettext-minimal-native_0.18.1.1.bb
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2011-10-18 18:26:26 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-11-02 08:58:03 +0000
commitb090fde5c184a64d3dd77c5f87b9596854e272ec (patch)
tree8e32d651888a27a5170c4222a4bd7134fb4ab09e /meta/recipes-core/gettext/gettext-minimal-native_0.18.1.1.bb
parent9497b27110d9a6857fc2befeedf57a4bb4555506 (diff)
downloadpoky-b090fde5c184a64d3dd77c5f87b9596854e272ec.tar.gz
gettext: Switch to disabling nls and reducing -native build dependencies to a set of pre built m4 macros
When analysing our build performance, its apparent that binutils-cross takes an age to get built. This is due to its dependencies on flex-native and bison-native which in turn depend on gettext-native. gettext-native is problematic as it has a significant dependency chain of its own and takes an age to build. What is worse is that we never care about the native language support in -native and -cross packages since we always force the C locale. This patch therefore disables nls for all -native packages (its already disabled for -cross) and adds a new gettext-minimal-native package which contains the m4 macros to keep autoconf/automake happy. This means we gain a significant build time speedup by the removal of gettext-native from most dependency chains (only being part of gettext for the target now). For now the LICENCE field says GPLv3, the macros are actually under a FSF MIT like licence so we need to update this part of the patch in due course. (From OE-Core rev: 01b2a16beb4a924077b74943ad4d6e7976563ff1) Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core/gettext/gettext-minimal-native_0.18.1.1.bb')
-rw-r--r--meta/recipes-core/gettext/gettext-minimal-native_0.18.1.1.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/meta/recipes-core/gettext/gettext-minimal-native_0.18.1.1.bb b/meta/recipes-core/gettext/gettext-minimal-native_0.18.1.1.bb
new file mode 100644
index 0000000000..71c60459e4
--- /dev/null
+++ b/meta/recipes-core/gettext/gettext-minimal-native_0.18.1.1.bb
@@ -0,0 +1,19 @@
1SRC_URI = "file://aclocal.tgz \
2 file://COPYING"
3
4INHIBIT_DEFAULT_DEPS = "1"
5INHIBIT_AUTOTOOLS_DEPS = "1"
6
7LICENSE = "FSF-Unlimited"
8LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
9
10inherit native
11
12PR = "r1"
13
14S = "${WORKDIR}"
15
16do_install () {
17 install -d ${D}${datadir}/aclocal/
18 cp ${WORKDIR}/*.m4 ${D}${datadir}/aclocal/
19}