summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/ell/ell_0.33.bb
diff options
context:
space:
mode:
authorOleksandr Kravchuk <open.source@oleksandr-kravchuk.com>2020-09-08 08:57:23 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2020-09-17 12:51:24 +0100
commit59b9e3c0ef95fb8176970802067392516e83b5b6 (patch)
tree3c797f6f5c5770d736782de9f313a96e9c2fb51a /meta/recipes-core/ell/ell_0.33.bb
parent7bd5cf65a6eedd01a48265923a284f9e093ea296 (diff)
downloadpoky-59b9e3c0ef95fb8176970802067392516e83b5b6.tar.gz
ell: update to 0.33
Changelog - Fix issue with uintset and number of bytes copied. - Fix issue with overflow in DHCP lease T2 computation. - Fix issue with side channel leak in l_ecc_scalar_new. - Fix issue with missing MSG_MORE in l_cipher_set_iv. - Add support for DHCP v6 client implementation. (From OE-Core rev: deb77c59b9c11738a93fc80c1b256b3df8e14827) Signed-off-by: Oleksandr Kravchuk <open.source@oleksandr-kravchuk.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org> (cherry picked from commit 3ad8ca257d40f5041b3ec167e4117c687da448a9) Signed-off-by: Steve Sakoman <steve@sakoman.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core/ell/ell_0.33.bb')
-rw-r--r--meta/recipes-core/ell/ell_0.33.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/meta/recipes-core/ell/ell_0.33.bb b/meta/recipes-core/ell/ell_0.33.bb
new file mode 100644
index 0000000000..2fa05104fb
--- /dev/null
+++ b/meta/recipes-core/ell/ell_0.33.bb
@@ -0,0 +1,21 @@
1SUMMARY = "Embedded Linux Library"
2DESCRIPTION = "The Embedded Linux Library (ELL) provides core, \
3low-level functionality for system daemons. It typically has no \
4dependencies other than the Linux kernel, C standard library, and \
5libdl (for dynamic linking). While ELL is designed to be efficient \
6and compact enough for use on embedded Linux platforms, it is not \
7limited to resource-constrained systems."
8SECTION = "libs"
9LICENSE = "LGPLv2.1"
10LIC_FILES_CHKSUM = "file://COPYING;md5=fb504b67c50331fc78734fed90fb0e09"
11
12DEPENDS = "dbus"
13
14inherit autotools pkgconfig
15
16SRC_URI = "https://mirrors.edge.kernel.org/pub/linux/libs/${BPN}/${BPN}-${PV}.tar.xz"
17SRC_URI[sha256sum] = "d9e40e641164150394b74b719b9726fc734f24b2cde679cf5f3be6915c34eded"
18
19do_configure_prepend () {
20 mkdir -p ${S}/build-aux
21}