summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/ell/ell_0.22.bb
diff options
context:
space:
mode:
authorOleksandr Kravchuk <open.source@oleksandr-kravchuk.com>2019-08-30 00:59:49 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-09-01 22:33:08 +0100
commit118fb26ac94f0ab616e9a224fd62a771cec34834 (patch)
treec571764e2c161456596e416932cbffff48334040 /meta/recipes-core/ell/ell_0.22.bb
parente1f4543f64529f0bdfdfe5ea5e2515305a3a9b1b (diff)
downloadpoky-118fb26ac94f0ab616e9a224fd62a771cec34834.tar.gz
ell: update to 0.22
Changelog: - Fix issue with DHCP and T1 timeout handling. - Fix issue with escape characters in peer identity string. - Add support for setting peer certificate's subject CN mask. (From OE-Core rev: cbf84908716c867b8bf530460a4eb0dff81da9f4) Signed-off-by: Oleksandr Kravchuk <open.source@oleksandr-kravchuk.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core/ell/ell_0.22.bb')
-rw-r--r--meta/recipes-core/ell/ell_0.22.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/meta/recipes-core/ell/ell_0.22.bb b/meta/recipes-core/ell/ell_0.22.bb
new file mode 100644
index 0000000000..b3942fc30e
--- /dev/null
+++ b/meta/recipes-core/ell/ell_0.22.bb
@@ -0,0 +1,22 @@
1SUMMARY = "Embedded Linux Library"
2DESCRIPTION = "The Embedded Linux Library (ELL) provides core, \
3low-level functionality for system daemons. It typically has no \
4dependencies other than the Linux kernel, C standard library, and \
5libdl (for dynamic linking). While ELL is designed to be efficient \
6and compact enough for use on embedded Linux platforms, it is not \
7limited to resource-constrained systems."
8SECTION = "libs"
9LICENSE = "LGPLv2.1"
10LIC_FILES_CHKSUM = "file://COPYING;md5=fb504b67c50331fc78734fed90fb0e09"
11
12DEPENDS = "dbus"
13
14inherit autotools pkgconfig
15
16SRC_URI = "https://mirrors.edge.kernel.org/pub/linux/libs/${BPN}/${BPN}-${PV}.tar.xz"
17SRC_URI[md5sum] = "a4e7d74404f11e71775b89f53a8f1c33"
18SRC_URI[sha256sum] = "3c1d6d997e17dfcbe4ebcd1331d9a7be5c64f2f0a0813bc223790e570d8da2e3"
19
20do_configure_prepend () {
21 mkdir -p ${S}/build-aux
22}