summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/eglibc/eglibc_2.18.bb
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2013-06-26 13:59:01 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-07-05 15:34:26 +0100
commit67c35e1072d4aa52fa1e5406bb3def909452c8b0 (patch)
tree4e5cd7b330a00cd88c3135d7778ea247cd490bdc /meta/recipes-core/eglibc/eglibc_2.18.bb
parent7450ff24160864bf93804eac6985782a4784e565 (diff)
downloadpoky-67c35e1072d4aa52fa1e5406bb3def909452c8b0.tar.gz
eglibc: Add 2.18 recipes
(From OE-Core rev: 59ae9fc07a6a89492c001de0b3322ecd6d3956be) Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Saul Wold <sgw@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core/eglibc/eglibc_2.18.bb')
-rw-r--r--meta/recipes-core/eglibc/eglibc_2.18.bb147
1 files changed, 147 insertions, 0 deletions
diff --git a/meta/recipes-core/eglibc/eglibc_2.18.bb b/meta/recipes-core/eglibc/eglibc_2.18.bb
new file mode 100644
index 0000000000..7c26829748
--- /dev/null
+++ b/meta/recipes-core/eglibc/eglibc_2.18.bb
@@ -0,0 +1,147 @@
1require eglibc.inc
2
3DEPENDS += "gperf-native kconfig-frontends-native"
4
5SRC_URI = "http://sakrah.dontexist.org/files/eglibc-${PV}-svnr23379.tar.bz2 \
6 file://eglibc-svn-arm-lowlevellock-include-tls.patch \
7 file://IO-acquire-lock-fix.patch \
8 file://mips-rld-map-check.patch \
9 file://etc/ld.so.conf \
10 file://generate-supported.mk \
11 file://glibc.fix_sqrt2.patch \
12 file://multilib_readlib.patch \
13 file://ppc-sqrt_finite.patch \
14 file://GLRO_dl_debug_mask.patch \
15 file://initgroups_keys.patch \
16 file://eglibc_fix_findidx_parameters.patch \
17 file://ppc_slow_ieee754_sqrt.patch \
18 file://fileops-without-wchar-io.patch \
19 file://add_resource_h_to_wait_h.patch \
20 file://0001-eglibc-menuconfig-support.patch \
21 file://0002-eglibc-menuconfig-hex-string-options.patch \
22 file://0003-eglibc-menuconfig-build-instructions.patch \
23 file://fsl-ppc-no-fsqrt.patch \
24 file://0001-R_ARM_TLS_DTPOFF32.patch \
25 file://tzselect-sh.patch \
26 file://tzselect-awk.patch \
27 file://0001-eglibc-run-libm-err-tab.pl-with-specific-dirs-in-S.patch \
28 file://fix-tibetian-locales.patch \
29 "
30SRC_URI[md5sum] = "7da8ab8c0af6889187b9ece6dafc12b0"
31SRC_URI[sha256sum] = "bd1cdb0528fd54d11ab896b878d71c0f89b4557e908e0f2561f32bbd7472aaeb"
32
33LIC_FILES_CHKSUM = "file://LICENSES;md5=e9a558e243b36d3209f380deb394b213 \
34 file://COPYING;md5=393a5ca445f6965873eca0259a17f833 \
35 file://posix/rxspencer/COPYRIGHT;md5=dc5485bb394a13b2332ec1c785f5d83a \
36 file://COPYING.LIB;md5=bbb461211a33b134d42ed5ee802b37ff "
37
38SRC_URI_append_class-nativesdk = " file://ld-search-order.patch \
39 file://relocatable_sdk.patch \
40 file://relocatable_sdk_fix_openpath.patch \
41 "
42S = "${WORKDIR}/eglibc-${PV}/libc"
43B = "${WORKDIR}/build-${TARGET_SYS}"
44
45PACKAGES_DYNAMIC = ""
46
47# the -isystem in bitbake.conf screws up glibc do_stage
48BUILD_CPPFLAGS = "-I${STAGING_INCDIR_NATIVE}"
49TARGET_CPPFLAGS = "-I${STAGING_DIR_TARGET}${includedir}"
50
51GLIBC_BROKEN_LOCALES = " _ER _ET so_ET yn_ER sid_ET tr_TR mn_MN gez_ET gez_ER bn_BD te_IN es_CR.ISO-8859-1"
52
53FILESPATH = "${@base_set_filespath([ '${FILE_DIRNAME}/eglibc-${PV}', '${FILE_DIRNAME}/eglibc', '${FILE_DIRNAME}/files', '${FILE_DIRNAME}' ], d)}"
54
55#
56# For now, we will skip building of a gcc package if it is a uclibc one
57# and our build is not a uclibc one, and we skip a glibc one if our build
58# is a uclibc build.
59#
60# See the note in gcc/gcc_3.4.0.oe
61#
62
63python __anonymous () {
64 import re
65 uc_os = (re.match('.*uclibc$', d.getVar('TARGET_OS', True)) != None)
66 if uc_os:
67 raise bb.parse.SkipPackage("incompatible with target %s" %
68 d.getVar('TARGET_OS', True))
69}
70
71export libc_cv_slibdir = "${base_libdir}"
72
73EXTRA_OECONF = "--enable-kernel=${OLDEST_KERNEL} \
74 --without-cvs --disable-profile \
75 --disable-debug --without-gd \
76 --enable-clocale=gnu \
77 --enable-add-ons \
78 --with-headers=${STAGING_INCDIR} \
79 --without-selinux \
80 --enable-obsolete-rpc \
81 --with-kconfig=${STAGING_BINDIR_NATIVE} \
82 ${GLIBC_EXTRA_OECONF}"
83
84EXTRA_OECONF += "${@get_libc_fpu_setting(bb, d)}"
85
86do_patch_append() {
87 bb.build.exec_func('do_fix_readlib_c', d)
88}
89
90# for mips eglibc now builds syscall tables for all abi's
91# so we make sure that we choose right march option which is
92# compatible with o32,n32 and n64 abi's
93# e.g. -march=mips32 is not compatible with n32 and n64 therefore
94# we filter it out in such case -march=from-abi which will be
95# mips1 when using o32 and mips3 when using n32/n64
96
97TUNE_CCARGS_mips := "${@oe_filter_out('-march=mips32', '${TUNE_CCARGS}', d)}"
98TUNE_CCARGS_mipsel := "${@oe_filter_out('-march=mips32', '${TUNE_CCARGS}', d)}"
99
100do_fix_readlib_c () {
101 sed -i -e 's#OECORE_KNOWN_INTERPRETER_NAMES#${EGLIBC_KNOWN_INTERPRETER_NAMES}#' ${S}/elf/readlib.c
102}
103
104do_configure () {
105# override this function to avoid the autoconf/automake/aclocal/autoheader
106# calls for now
107# don't pass CPPFLAGS into configure, since it upsets the kernel-headers
108# version check and doesn't really help with anything
109 if [ -z "`which rpcgen`" ]; then
110 echo "rpcgen not found. Install glibc-devel."
111 exit 1
112 fi
113 (cd ${S} && gnu-configize) || die "failure in running gnu-configize"
114 find ${S} -name "configure" | xargs touch
115 CPPFLAGS="" oe_runconf
116}
117
118rpcsvc = "bootparam_prot.x nlm_prot.x rstat.x \
119 yppasswd.x klm_prot.x rex.x sm_inter.x mount.x \
120 rusers.x spray.x nfs_prot.x rquota.x key_prot.x"
121
122do_compile () {
123 # -Wl,-rpath-link <staging>/lib in LDFLAGS can cause breakage if another glibc is in staging
124 unset LDFLAGS
125 base_do_compile
126 (
127 cd ${S}/sunrpc/rpcsvc
128 for r in ${rpcsvc}; do
129 h=`echo $r|sed -e's,\.x$,.h,'`
130 rpcgen -h $r -o $h || bbwarn "unable to generate header for $r"
131 done
132 )
133 echo "Adjust ldd script"
134 if [ -n "${RTLDLIST}" ]
135 then
136 prevrtld=`cat ${B}/elf/ldd | grep "^RTLDLIST=" | sed 's#^RTLDLIST="\?\([^"]*\)"\?$#\1#'`
137 if [ "${prevrtld}" != "${RTLDLIST}" ]
138 then
139 sed -i ${B}/elf/ldd -e "s#^RTLDLIST=.*\$#RTLDLIST=\"${prevrtld} ${RTLDLIST}\"#"
140 fi
141 fi
142
143}
144
145require eglibc-package.inc
146
147BBCLASSEXTEND = "nativesdk"