summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/eglibc/eglibc_2.14.bb
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2012-01-06 20:40:23 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-01-10 17:28:45 +0000
commit4b6df4f2668c6e85d8059e1896812a1a8db23786 (patch)
treea55b90043eafd9f9f00d5b9376833d51632c0663 /meta/recipes-core/eglibc/eglibc_2.14.bb
parentf164a95b43fdda1e774195622f31f0cd998138d3 (diff)
downloadpoky-4b6df4f2668c6e85d8059e1896812a1a8db23786.tar.gz
eglibc: Upgrade recipes 2.14 -> 2.15
Add patch to provide __finite_sqrt functions for ppc (From OE-Core rev: 289d09176f8b6f66f6a7807b57f10e86939942f5) Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core/eglibc/eglibc_2.14.bb')
-rw-r--r--meta/recipes-core/eglibc/eglibc_2.14.bb222
1 files changed, 0 insertions, 222 deletions
diff --git a/meta/recipes-core/eglibc/eglibc_2.14.bb b/meta/recipes-core/eglibc/eglibc_2.14.bb
deleted file mode 100644
index ad2161e1dd..0000000000
--- a/meta/recipes-core/eglibc/eglibc_2.14.bb
+++ /dev/null
@@ -1,222 +0,0 @@
1require eglibc.inc
2
3SRCREV = "15870"
4
5DEPENDS += "gperf-native"
6PR = "r3"
7PR_append = "+svnr${SRCPV}"
8
9EGLIBC_BRANCH="eglibc-2_14"
10SRC_URI = "svn://www.eglibc.org/svn/branches/;module=${EGLIBC_BRANCH};proto=http \
11 file://eglibc-svn-arm-lowlevellock-include-tls.patch \
12 file://IO-acquire-lock-fix.patch \
13 file://mips-rld-map-check.patch \
14 file://stack-protector-test.patch \
15 file://armv4-eabi-compile-fix.patch \
16 file://etc/ld.so.conf \
17 file://generate-supported.mk \
18 file://ppc-sqrt.patch \
19 file://multilib_readlib.patch \
20 file://eglibc-rpc-export-again.patch \
21 file://glibc-2.14-libdl-crash.patch \
22 file://use-sysroot-cxx-headers.patch \
23 "
24LIC_FILES_CHKSUM = "file://LICENSES;md5=98a1128c4b58120182cbea3b1752d8b9 \
25 file://COPYING;md5=393a5ca445f6965873eca0259a17f833 \
26 file://posix/rxspencer/COPYRIGHT;md5=dc5485bb394a13b2332ec1c785f5d83a \
27 file://COPYING.LIB;md5=bbb461211a33b134d42ed5ee802b37ff "
28
29SRC_URI_append_virtclass-nativesdk = " file://ld-search-order.patch"
30S = "${WORKDIR}/${EGLIBC_BRANCH}/libc"
31B = "${WORKDIR}/build-${TARGET_SYS}"
32
33PACKAGES_DYNAMIC = "libc6*"
34RPROVIDES_${PN}-dev = "libc6-dev virtual-libc-dev"
35PROVIDES_${PN}-dbg = "glibc-dbg"
36
37# the -isystem in bitbake.conf screws up glibc do_stage
38BUILD_CPPFLAGS = "-I${STAGING_INCDIR_NATIVE}"
39TARGET_CPPFLAGS = "-I${STAGING_DIR_TARGET}${layout_includedir}"
40
41GLIBC_ADDONS ?= "ports,nptl,libidn"
42
43GLIBC_BROKEN_LOCALES = " _ER _ET so_ET yn_ER sid_ET tr_TR mn_MN gez_ET gez_ER bn_BD te_IN es_CR.ISO-8859-1"
44
45FILESPATH = "${@base_set_filespath([ '${FILE_DIRNAME}/eglibc-${PV}', '${FILE_DIRNAME}/eglibc', '${FILE_DIRNAME}/files', '${FILE_DIRNAME}' ], d)}"
46
47#
48# For now, we will skip building of a gcc package if it is a uclibc one
49# and our build is not a uclibc one, and we skip a glibc one if our build
50# is a uclibc build.
51#
52# See the note in gcc/gcc_3.4.0.oe
53#
54
55python __anonymous () {
56 import bb, re
57 uc_os = (re.match('.*uclibc$', d.getVar('TARGET_OS', 1)) != None)
58 if uc_os:
59 raise bb.parse.SkipPackage("incompatible with target %s" %
60 d.getVar('TARGET_OS', 1))
61}
62
63export libc_cv_slibdir = "${base_libdir}"
64
65EXTRA_OECONF = "--enable-kernel=${OLDEST_KERNEL} \
66 --without-cvs --disable-profile --disable-debug --without-gd \
67 --enable-clocale=gnu \
68 --enable-add-ons=${GLIBC_ADDONS},ports \
69 --with-headers=${STAGING_INCDIR} \
70 --without-selinux \
71 ${GLIBC_EXTRA_OECONF}"
72
73EXTRA_OECONF += "${@get_libc_fpu_setting(bb, d)}"
74
75do_unpack_append() {
76 bb.build.exec_func('do_move_ports', d)
77}
78
79do_move_ports() {
80 if test -d ${WORKDIR}/${EGLIBC_BRANCH}/ports ; then
81 rm -rf ${S}/ports
82 mv ${WORKDIR}/${EGLIBC_BRANCH}/ports ${S}/
83 fi
84}
85
86do_patch_append() {
87 bb.build.exec_func('do_fix_ia_headers', d)
88 bb.build.exec_func('do_fix_readlib_c', d)
89}
90
91# We need to ensure that all of the i386 and x86_64 headers are identical
92# to support the multilib case. We do this by copying headers from x86_64
93# to i386 directories. Normally when hand building eglibc or a combined
94# system you would build 32-bit, and then overwrite any files with the x86_64
95# versions.
96#
97# Each time eglibc is updated, this will need to be re-evaluated. In order
98# to do this, disable this function. Build eglibc for a 32-bit and a 64-bit
99# IA32 target. Compare the contents of the include files -- comments specific
100# to the x86_64 version compared to the 32-bit one.
101#
102# For eglibc 2.13, each conflict noted below:
103# bits/a.out.h - Add support for __WORDSIZE = 64
104# bits/byteswap.h - Copyright date mismatch, add support for __WORDSIZE = 64
105# bits/endian.h - Comment mismatch
106# bits/environment.h - add support for __WORDSIZE = 64
107# bits/fcntl.h - Comment/Copyright date mismatch, add support for __WORDSIZE = 64
108# bits/fenv.h - Copyright date mismatch, add support for __WORDSIZE = 64
109# bits/huge_vall.h - Comment/Copyright date mismatch, remove support for older gcc
110# bits/link.h - Function name difference, add x86_64 definitions
111# bits/mathdef.h - Copyright date mismatch, add support for __WORDSIZE = 64
112# bits/mathinline.h - Copyright date mismatch, contributed by mismatch, remove support for older gcc/assembly optimization, add support for __WORDSIZE = 64
113# bits/mman.h - Header/Copyright date mismatch, add MAP_32BIT definition
114# bits/msq.h - Copyright date mismatch, add __WORDSIZE = 32 definitions
115# bits/pthread_type.h -- Contributed by added, add support for __WORDSIZE = 64
116# bits/select.h - Copyright date mismatch, add support for __WORDSIZE = 64
117# bits/semaphore.h - Copyright date mismatch, add support for __WORDSIZE = 64
118# bits/sem.h - Copyright date mismatch
119# bits/setjmp.h - Copyrgiht date mismatch, add support for __WORDSIZE = 64
120# bits/shm.h - Copyright date mismatch, add support for __WORDSIZE = 32
121# bits/sigcontext.h - Copyright date mismatch, license wording mismatch, add support for __WORDSIZE = 32
122# bits/stat.h - Copyright date mismatch, add support for __WORDSIZE = 32 and __WORDSIZE = 64
123# bits/string.h - Header/Copyright date mismatch, remove assembly optimizations
124# bits/syscall.h - different order, some different syscalls listed
125# bits/wchar.h - Change the way the definitions are done
126# bits/wordsize.h - Different header, remove license notice, add __x86_64__ support
127# bits/xtitypes.h - Header difference, different typedef format
128# bits/fpu_control.h - header difference, revised comments, updated assembly macros
129# sys/debugreg.h - Copyright date mismatch, new definition and added __WORDSIZE=64 support
130# sys/epoll.h - Copyright date mismatch, slightly different definitions
131# sys/io.h - Copyright date mismatch, slightly different assembly formats
132# sys/perm.h - Copyright date mismatch
133# sys/procfs.h - Copyright date mismatch, support for __WORDSIZE = 32
134# sys/reg.h - Copyright date mismatch, support for __WORDSIZE = 64
135# sys/ucontext.h - Copyright date mismatch, support for __WORDSIZE = 64
136# sys/user.h - Copyright date mismatch, support for __WORDSIZE = 64
137#
138# we rm something to return to the default version
139#
140do_fix_ia_headers() {
141 cp ${S}/sysdeps/unix/sysv/linux/x86_64/bits/a.out.h ${S}/sysdeps/unix/sysv/linux/i386/bits/a.out.h
142 cp ${S}/sysdeps/x86_64/bits/byteswap.h ${S}/sysdeps/i386/bits/byteswap.h
143 cp ${S}/sysdeps/x86_64/bits/endian.h ${S}/sysdeps/i386/bits/endian.h
144 cp ${S}/sysdeps/unix/sysv/linux/x86_64/bits/environments.h ${S}/sysdeps/unix/sysv/linux/i386/bits/environments.h
145 cp ${S}/sysdeps/unix/sysv/linux/x86_64/bits/fcntl.h ${S}/sysdeps/unix/sysv/linux/i386/bits/fcntl.h
146 cp ${S}/sysdeps/x86_64/fpu/bits/fenv.h ${S}/sysdeps/i386/fpu/bits/fenv.h
147 rm ${S}/sysdeps/i386/bits/huge_vall.h
148 cp ${S}/sysdeps/x86_64/bits/link.h ${S}/sysdeps/i386/bits/link.h
149 cp ${S}/sysdeps/x86_64/bits/mathdef.h ${S}/sysdeps/i386/bits/mathdef.h
150 cp ${S}/sysdeps/x86_64/fpu/bits/mathinline.h ${S}/sysdeps/i386/fpu/bits/mathinline.h
151 cp ${S}/sysdeps/unix/sysv/linux/x86_64/bits/mman.h ${S}/sysdeps/unix/sysv/linux/i386/bits/mman.h
152 cp ${S}/sysdeps/unix/sysv/linux/x86_64/bits/msq.h ${S}/sysdeps/unix/sysv/linux/i386/bits/msq.h
153 cp ${S}/nptl/sysdeps/unix/sysv/linux/x86_64/bits/pthreadtypes.h ${S}/nptl/sysdeps/unix/sysv/linux/i386/bits/pthreadtypes.h
154 cp ${S}/sysdeps/x86_64/bits/select.h ${S}/sysdeps/i386/bits/select.h
155 cp ${S}/nptl/sysdeps/unix/sysv/linux/x86_64/bits/semaphore.h ${S}/nptl/sysdeps/unix/sysv/linux/i386/bits/semaphore.h
156 rm ${S}/sysdeps/unix/sysv/linux/x86_64/bits/sem.h
157 cp ${S}/sysdeps/x86_64/bits/setjmp.h ${S}/sysdeps/i386/bits/setjmp.h
158 cp ${S}/sysdeps/unix/sysv/linux/x86_64/bits/shm.h ${S}/sysdeps/unix/sysv/linux/i386/bits/shm.h
159 cp ${S}/sysdeps/unix/sysv/linux/x86_64/bits/sigcontext.h ${S}/sysdeps/unix/sysv/linux/i386/bits/sigcontext.h
160 cp ${S}/sysdeps/unix/sysv/linux/x86_64/bits/stat.h ${S}/sysdeps/unix/sysv/linux/i386/bits/stat.h
161 rm ${S}/sysdeps/i386/i486/bits/string.h ; cp ${S}/sysdeps/x86_64/bits/string.h ${S}/sysdeps/i386/bits/string.h
162 # Skip syscall.h, see do_install
163 rm ${S}/sysdeps/unix/sysv/linux/i386/bits/wchar.h
164 cp ${S}/sysdeps/x86_64/bits/wordsize.h ${S}/sysdeps/i386/bits/wordsize.h
165 cp ${S}/sysdeps/x86_64/bits/xtitypes.h ${S}/sysdeps/i386/bits/xtitypes.h
166 # i386 version is correct, x86_64 is incorrect for fpu_control.h
167 cp ${S}/sysdeps/i386/fpu_control.h ${S}/sysdeps/x86_64/fpu_control.h
168 cp ${S}/sysdeps/unix/sysv/linux/x86_64/sys/debugreg.h ${S}/sysdeps/unix/sysv/linux/i386/sys/debugreg.h
169 cp ${S}/sysdeps/unix/sysv/linux/x86_64/sys/epoll.h ${S}/sysdeps/unix/sysv/linux/i386/sys/epoll.h
170 cp ${S}/sysdeps/unix/sysv/linux/x86_64/sys/io.h ${S}/sysdeps/unix/sysv/linux/i386/sys/io.h
171 cp ${S}/sysdeps/unix/sysv/linux/x86_64/sys/perm.h ${S}/sysdeps/unix/sysv/linux/i386/sys/perm.h
172 cp ${S}/sysdeps/unix/sysv/linux/x86_64/sys/procfs.h ${S}/sysdeps/unix/sysv/linux/i386/sys/procfs.h
173 cp ${S}/sysdeps/unix/sysv/linux/x86_64/sys/reg.h ${S}/sysdeps/unix/sysv/linux/i386/sys/reg.h
174 cp ${S}/sysdeps/unix/sysv/linux/x86_64/sys/ucontext.h ${S}/sysdeps/unix/sysv/linux/i386/sys/ucontext.h
175 cp ${S}/sysdeps/unix/sysv/linux/x86_64/sys/user.h ${S}/sysdeps/unix/sysv/linux/i386/sys/user.h
176}
177
178do_fix_readlib_c () {
179 sed -i -e 's#OECORE_KNOWN_INTERPRETER_NAMES#${EGLIBC_KNOWN_INTERPRETER_NAMES}#' ${S}/elf/readlib.c
180}
181
182do_configure () {
183# override this function to avoid the autoconf/automake/aclocal/autoheader
184# calls for now
185# don't pass CPPFLAGS into configure, since it upsets the kernel-headers
186# version check and doesn't really help with anything
187 if [ -z "`which rpcgen`" ]; then
188 echo "rpcgen not found. Install glibc-devel."
189 exit 1
190 fi
191 (cd ${S} && gnu-configize) || die "failure in running gnu-configize"
192 find ${S} -name "configure" | xargs touch
193 CPPFLAGS="" oe_runconf
194}
195
196rpcsvc = "bootparam_prot.x nlm_prot.x rstat.x \
197 yppasswd.x klm_prot.x rex.x sm_inter.x mount.x \
198 rusers.x spray.x nfs_prot.x rquota.x key_prot.x"
199
200do_compile () {
201 # -Wl,-rpath-link <staging>/lib in LDFLAGS can cause breakage if another glibc is in staging
202 unset LDFLAGS
203 base_do_compile
204 (
205 cd ${S}/sunrpc/rpcsvc
206 for r in ${rpcsvc}; do
207 h=`echo $r|sed -e's,\.x$,.h,'`
208 rpcgen -h $r -o $h || bbwarn "unable to generate header for $r"
209 done
210 )
211 echo "Adjust ldd script"
212 if [ -n "${RTLDLIST}" ]
213 then
214 sed -i ${B}/elf/ldd -e 's#^\(RTLDLIST=\)"\(.*\)"$#\1\2#'
215 sed -i ${B}/elf/ldd -e 's#^\(RTLDLIST=\)\(.*\)$#\1"${RTLDLIST} \2"#'
216 fi
217
218}
219
220require eglibc-package.inc
221
222BBCLASSEXTEND = "nativesdk"