summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/eglibc/eglibc_2.13.bb
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2011-06-22 23:49:42 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-06-22 23:49:42 +0100
commitb914de55a45029658116f729ffda3abead654c90 (patch)
tree3534a939a356ce79e9d371c23c40227f29fcde6f /meta/recipes-core/eglibc/eglibc_2.13.bb
parent82e0e0a15373c4be4d9231f17f72d78de95c2f2a (diff)
downloadpoky-b914de55a45029658116f729ffda3abead654c90.tar.gz
Revert "eglibc: Upgrade recipes from 2.13 -> 2.14"
This reverts commit 16837d4cc39415709f744afa9532d53e0382d6bd. 2.14 isn't ready for prime time :( (A load of files no longer seem to get installed for example)
Diffstat (limited to 'meta/recipes-core/eglibc/eglibc_2.13.bb')
-rw-r--r--meta/recipes-core/eglibc/eglibc_2.13.bb115
1 files changed, 115 insertions, 0 deletions
diff --git a/meta/recipes-core/eglibc/eglibc_2.13.bb b/meta/recipes-core/eglibc/eglibc_2.13.bb
new file mode 100644
index 0000000000..3490d2db9f
--- /dev/null
+++ b/meta/recipes-core/eglibc/eglibc_2.13.bb
@@ -0,0 +1,115 @@
1require eglibc.inc
2
3SRCREV = "14157"
4
5DEPENDS += "gperf-native"
6FILESPATHPKG =. "eglibc-svn:"
7PR = "r2"
8PR_append = "+svnr${SRCPV}"
9
10EGLIBC_BRANCH="eglibc-2_13"
11SRC_URI = "svn://www.eglibc.org/svn/branches/;module=${EGLIBC_BRANCH};proto=http \
12 file://eglibc-svn-arm-lowlevellock-include-tls.patch \
13 file://IO-acquire-lock-fix.patch \
14 file://shorten-build-commands.patch \
15 file://mips-rld-map-check.patch \
16 file://stack-protector-test.patch \
17 file://etc/ld.so.conf \
18 file://generate-supported.mk \
19 "
20LIC_FILES_CHKSUM = "file://LICENSES;md5=98a1128c4b58120182cbea3b1752d8b9 \
21 file://COPYING;md5=393a5ca445f6965873eca0259a17f833 \
22 file://posix/rxspencer/COPYRIGHT;md5=dc5485bb394a13b2332ec1c785f5d83a \
23 file://COPYING.LIB;md5=bbb461211a33b134d42ed5ee802b37ff "
24
25SRC_URI_append_virtclass-nativesdk = " file://ld-search-order.patch"
26S = "${WORKDIR}/${EGLIBC_BRANCH}/libc"
27B = "${WORKDIR}/build-${TARGET_SYS}"
28
29PACKAGES_DYNAMIC = "libc6*"
30RPROVIDES_${PN}-dev = "libc6-dev virtual-libc-dev"
31PROVIDES_${PN}-dbg = "glibc-dbg"
32
33# the -isystem in bitbake.conf screws up glibc do_stage
34BUILD_CPPFLAGS = "-I${STAGING_INCDIR_NATIVE}"
35TARGET_CPPFLAGS = "-I${STAGING_DIR_TARGET}${layout_includedir}"
36
37GLIBC_ADDONS ?= "ports,nptl,libidn"
38
39GLIBC_BROKEN_LOCALES = " _ER _ET so_ET yn_ER sid_ET tr_TR mn_MN gez_ET gez_ER bn_BD te_IN es_CR.ISO-8859-1"
40
41FILESPATH = "${@base_set_filespath([ '${FILE_DIRNAME}/eglibc-${PV}', '${FILE_DIRNAME}/eglibc', '${FILE_DIRNAME}/files', '${FILE_DIRNAME}' ], d)}"
42
43#
44# For now, we will skip building of a gcc package if it is a uclibc one
45# and our build is not a uclibc one, and we skip a glibc one if our build
46# is a uclibc build.
47#
48# See the note in gcc/gcc_3.4.0.oe
49#
50
51python __anonymous () {
52 import bb, re
53 uc_os = (re.match('.*uclibc$', bb.data.getVar('TARGET_OS', d, 1)) != None)
54 if uc_os:
55 raise bb.parse.SkipPackage("incompatible with target %s" %
56 bb.data.getVar('TARGET_OS', d, 1))
57}
58
59export libc_cv_slibdir = "${base_libdir}"
60
61EXTRA_OECONF = "--enable-kernel=${OLDEST_KERNEL} \
62 --without-cvs --disable-profile --disable-debug --without-gd \
63 --enable-clocale=gnu \
64 --enable-add-ons=${GLIBC_ADDONS},ports \
65 --with-headers=${STAGING_INCDIR} \
66 --without-selinux \
67 ${GLIBC_EXTRA_OECONF}"
68
69EXTRA_OECONF += "${@get_libc_fpu_setting(bb, d)}"
70
71do_unpack_append() {
72 bb.build.exec_func('do_move_ports', d)
73}
74
75do_move_ports() {
76 if test -d ${WORKDIR}/${EGLIBC_BRANCH}/ports ; then
77 rm -rf ${S}/ports
78 mv ${WORKDIR}/${EGLIBC_BRANCH}/ports ${S}/
79 fi
80}
81
82do_configure () {
83# override this function to avoid the autoconf/automake/aclocal/autoheader
84# calls for now
85# don't pass CPPFLAGS into configure, since it upsets the kernel-headers
86# version check and doesn't really help with anything
87 if [ -z "`which rpcgen`" ]; then
88 echo "rpcgen not found. Install glibc-devel."
89 exit 1
90 fi
91 (cd ${S} && gnu-configize) || die "failure in running gnu-configize"
92 find ${S} -name "configure" | xargs touch
93 CPPFLAGS="" oe_runconf
94}
95
96rpcsvc = "bootparam_prot.x nlm_prot.x rstat.x \
97 yppasswd.x klm_prot.x rex.x sm_inter.x mount.x \
98 rusers.x spray.x nfs_prot.x rquota.x key_prot.x"
99
100do_compile () {
101 # -Wl,-rpath-link <staging>/lib in LDFLAGS can cause breakage if another glibc is in staging
102 unset LDFLAGS
103 base_do_compile
104 (
105 cd ${S}/sunrpc/rpcsvc
106 for r in ${rpcsvc}; do
107 h=`echo $r|sed -e's,\.x$,.h,'`
108 rpcgen -h $r -o $h || oewarn "unable to generate header for $r"
109 done
110 )
111}
112
113require eglibc-package.inc
114
115BBCLASSEXTEND = "nativesdk"