summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/eglibc/eglibc_2.13.bb
diff options
context:
space:
mode:
authorDongxiao Xu <dongxiao.xu@intel.com>2011-06-28 14:58:15 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-06-28 13:44:41 +0100
commit8fa9d64f1d5128f304a0d36dbf55f49ccaf784b1 (patch)
treead031554642f4b160ec5b9bd044577c03ef0c5a6 /meta/recipes-core/eglibc/eglibc_2.13.bb
parent671e580111c3f37f3c7835956db17e0425f9f937 (diff)
downloadpoky-8fa9d64f1d5128f304a0d36dbf55f49ccaf784b1.tar.gz
libc-locale: split locale handling from libc recipe.
*libc's do_package will cost a lot of time due to the locale handing, which may delay the other recipe's do_package task and affect the build performance. This commit moves locale handling into a separate recipe *libc-locale. [RP: Add fixup with recent eglibc commit conflict for FILES_pn-dbg and PACKAGES] (From OE-Core rev: c6d3242f7642f537b02870bb4eb650f0e2094b85) Signed-off-by: Dongxiao Xu <dongxiao.xu@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core/eglibc/eglibc_2.13.bb')
-rw-r--r--meta/recipes-core/eglibc/eglibc_2.13.bb12
1 files changed, 12 insertions, 0 deletions
diff --git a/meta/recipes-core/eglibc/eglibc_2.13.bb b/meta/recipes-core/eglibc/eglibc_2.13.bb
index 3490d2db9f..603d9cdc62 100644
--- a/meta/recipes-core/eglibc/eglibc_2.13.bb
+++ b/meta/recipes-core/eglibc/eglibc_2.13.bb
@@ -110,6 +110,18 @@ do_compile () {
110 ) 110 )
111} 111}
112 112
113do_install_locale () {
114 dest=${D}/${includedir}/eglibc-locale-internal-${MULTIMACH_TARGET_SYS}
115 install -d ${dest} ${dest}${bindir}
116 cp -fpPR ${D}${base_libdir} ${dest}${base_prefix}
117 cp -fpPR ${D}${libdir} ${dest}${exec_prefix}
118 cp -fpPR ${D}${datadir} ${dest}${exec_prefix}
119 cp -fpPR ${D}${bindir}/localedef ${dest}${bindir}
120 cp -fpPR ${WORKDIR}/SUPPORTED ${dest}
121}
122
123addtask do_install_locale after do_install before do_populate_sysroot
124
113require eglibc-package.inc 125require eglibc-package.inc
114 126
115BBCLASSEXTEND = "nativesdk" 127BBCLASSEXTEND = "nativesdk"