summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/eglibc/eglibc_2.12.bb
diff options
context:
space:
mode:
authorNitin A Kamble <nitin.a.kamble@intel.com>2010-08-05 19:38:06 -0700
committerRichard Purdie <rpurdie@linux.intel.com>2010-09-02 09:52:31 +0100
commit561d875404ef1783f94f37314b6e756766db8411 (patch)
tree664f8afe01c9ba8828ab02b19367e97e52dae842 /meta/recipes-core/eglibc/eglibc_2.12.bb
parent436d590c4a5b7b5942bac5b51af128bcdd30621f (diff)
downloadpoky-561d875404ef1783f94f37314b6e756766db8411.tar.gz
libc-package.bbclass: merge glibc & eglibc class files
Other enhancements: print qemu's stdio & error on failure glibc: enable locale generation for all arches eglibc: enable binary locale generation for mips And cleanup of code based on the code review. [e]glibc: move common definition in the common file bitbake was complaining about duplicate definition of get_libc_fpu_setting in eglibc.inc & glibc.inc files. And bump PRs Signed-off-by: Nitin A Kamble <nitin.a.kamble@intel.com> Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
Diffstat (limited to 'meta/recipes-core/eglibc/eglibc_2.12.bb')
-rw-r--r--meta/recipes-core/eglibc/eglibc_2.12.bb6
1 files changed, 3 insertions, 3 deletions
diff --git a/meta/recipes-core/eglibc/eglibc_2.12.bb b/meta/recipes-core/eglibc/eglibc_2.12.bb
index a214980707..f1b84967b4 100644
--- a/meta/recipes-core/eglibc/eglibc_2.12.bb
+++ b/meta/recipes-core/eglibc/eglibc_2.12.bb
@@ -2,7 +2,7 @@ require eglibc.inc
2 2
3DEPENDS += "gperf-native" 3DEPENDS += "gperf-native"
4FILESPATHPKG =. "eglibc-svn:" 4FILESPATHPKG =. "eglibc-svn:"
5PR = "r0" 5PR = "r2"
6SRCREV="10809" 6SRCREV="10809"
7EGLIBC_BRANCH="eglibc-2_12" 7EGLIBC_BRANCH="eglibc-2_12"
8SRC_URI = "svn://www.eglibc.org/svn/branches/;module=${EGLIBC_BRANCH};proto=http \ 8SRC_URI = "svn://www.eglibc.org/svn/branches/;module=${EGLIBC_BRANCH};proto=http \
@@ -50,7 +50,7 @@ EXTRA_OECONF = "--enable-kernel=${OLDEST_KERNEL} \
50 --without-selinux \ 50 --without-selinux \
51 ${GLIBC_EXTRA_OECONF}" 51 ${GLIBC_EXTRA_OECONF}"
52 52
53EXTRA_OECONF += "${@get_eglibc_fpu_setting(bb, d)}" 53EXTRA_OECONF += "${@get_libc_fpu_setting(bb, d)}"
54 54
55do_unpack_append() { 55do_unpack_append() {
56 bb.build.exec_func('do_move_ports', d) 56 bb.build.exec_func('do_move_ports', d)
@@ -94,4 +94,4 @@ do_compile () {
94 ) 94 )
95} 95}
96 96
97require eglibc-package.bbclass 97require eglibc-package.inc