summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/eglibc/eglibc-locale_2.13.bb
diff options
context:
space:
mode:
authorDongxiao Xu <dongxiao.xu@intel.com>2011-06-28 14:58:15 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-06-28 13:44:41 +0100
commit8fa9d64f1d5128f304a0d36dbf55f49ccaf784b1 (patch)
treead031554642f4b160ec5b9bd044577c03ef0c5a6 /meta/recipes-core/eglibc/eglibc-locale_2.13.bb
parent671e580111c3f37f3c7835956db17e0425f9f937 (diff)
downloadpoky-8fa9d64f1d5128f304a0d36dbf55f49ccaf784b1.tar.gz
libc-locale: split locale handling from libc recipe.
*libc's do_package will cost a lot of time due to the locale handing, which may delay the other recipe's do_package task and affect the build performance. This commit moves locale handling into a separate recipe *libc-locale. [RP: Add fixup with recent eglibc commit conflict for FILES_pn-dbg and PACKAGES] (From OE-Core rev: c6d3242f7642f537b02870bb4eb650f0e2094b85) Signed-off-by: Dongxiao Xu <dongxiao.xu@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core/eglibc/eglibc-locale_2.13.bb')
-rw-r--r--meta/recipes-core/eglibc/eglibc-locale_2.13.bb58
1 files changed, 58 insertions, 0 deletions
diff --git a/meta/recipes-core/eglibc/eglibc-locale_2.13.bb b/meta/recipes-core/eglibc/eglibc-locale_2.13.bb
new file mode 100644
index 0000000000..ed6c099c6c
--- /dev/null
+++ b/meta/recipes-core/eglibc/eglibc-locale_2.13.bb
@@ -0,0 +1,58 @@
1INHIBIT_DEFAULT_DEPS = "1"
2LICENSE = "LGPL"
3
4BPN = "eglibc"
5
6do_fetch[noexec] = "1"
7do_unpack[noexec] = "1"
8do_patch[noexec] = "1"
9do_configure[noexec] = "1"
10do_compile[noexec] = "1"
11
12# Binary locales are generated at build time if ENABLE_BINARY_LOCALE_GENERATION
13# is set. The idea is to avoid running localedef on the target (at first boot)
14# to decrease initial boot time and avoid localedef being killed by the OOM
15# killer which used to effectively break i18n on machines with < 128MB RAM.
16
17# default to disabled
18ENABLE_BINARY_LOCALE_GENERATION ?= "0"
19ENABLE_BINARY_LOCALE_GENERATION_pn-eglibc-locale-nativesdk = "0"
20
21#enable locale generation on these arches
22# BINARY_LOCALE_ARCHES is a space separated list of regular expressions
23BINARY_LOCALE_ARCHES ?= "arm.* i[3-6]86 x86_64 powerpc mips"
24
25# set "1" to use cross-localedef for locale generation
26# set "0" for qemu emulation of native localedef for locale generation
27LOCALE_GENERATION_WITH_CROSS-LOCALEDEF = "1"
28
29PR = "r0"
30
31PKGSUFFIX = ""
32PKGSUFFIX_virtclass-nativesdk = "-nativesdk"
33
34PACKAGES = "eglibc-locale localedef${PKGSUFFIX}"
35
36PACKAGES_DYNAMIC = "locale-base-* \
37 eglibc-gconv-* eglibc-charmap-* eglibc-localedata-* eglibc-binary-localedata-* \
38 glibc-gconv-*${PKGSUFFIX} glibc-charmap-* glibc-localedata-* glibc-binary-localedata-*"
39
40PROVIDES = "virtual/libc-locale${PKGSUFFIX}"
41
42RPROVIDES_eglibc-locale = "glibc-locale"
43
44FILES_eglibc-gconv = "${libdir}/gconv/*"
45FILES_localedef${PKGSUFFIX} = "${bindir}/localedef"
46
47do_install () {
48 cp -fpPR ${STAGING_INCDIR}/eglibc-locale-internal-${MULTIMACH_TARGET_SYS}/* ${D}
49 cp -fpPR ${D}/SUPPORTED ${WORKDIR}
50}
51
52DESCRIPTION_localedef = "eglibc: compile locale definition files"
53
54inherit libc-package
55
56do_install[depends] += "virtual/libc${PKGSUFFIX}:do_populate_sysroot"
57
58BBCLASSEXTEND = "nativesdk"