summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/eglibc/cross-localedef-native_2.19.bb
diff options
context:
space:
mode:
authorTudor Florea <tudor.florea@enea.com>2014-10-16 03:05:19 +0200
committerTudor Florea <tudor.florea@enea.com>2014-10-16 03:05:19 +0200
commitc527fd1f14c27855a37f2e8ac5346ce8d940ced2 (patch)
treebb002c1fdf011c41dbd2f0927bed23ecb5f83c97 /meta/recipes-core/eglibc/cross-localedef-native_2.19.bb
downloadpoky-daisy-140929.tar.gz
initial commit for Enea Linux 4.0-140929daisy-140929
Migrated from the internal git server on the daisy-enea-point-release branch Signed-off-by: Tudor Florea <tudor.florea@enea.com>
Diffstat (limited to 'meta/recipes-core/eglibc/cross-localedef-native_2.19.bb')
-rw-r--r--meta/recipes-core/eglibc/cross-localedef-native_2.19.bb49
1 files changed, 49 insertions, 0 deletions
diff --git a/meta/recipes-core/eglibc/cross-localedef-native_2.19.bb b/meta/recipes-core/eglibc/cross-localedef-native_2.19.bb
new file mode 100644
index 0000000000..3ce0e1d394
--- /dev/null
+++ b/meta/recipes-core/eglibc/cross-localedef-native_2.19.bb
@@ -0,0 +1,49 @@
1SUMMARY = "Cross locale generation tool for eglibc"
2HOMEPAGE = "http://www.eglibc.org/home"
3SECTION = "libs"
4LICENSE = "LGPL-2.1"
5
6LIC_DIR = "${WORKDIR}/eglibc-${PV}/libc"
7LIC_FILES_CHKSUM = "file://${LIC_DIR}/LICENSES;md5=e9a558e243b36d3209f380deb394b213 \
8 file://${LIC_DIR}/COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
9 file://${LIC_DIR}/posix/rxspencer/COPYRIGHT;md5=dc5485bb394a13b2332ec1c785f5d83a \
10 file://${LIC_DIR}/COPYING.LIB;md5=4fbd65380cdd255951079008b364516c"
11
12
13inherit native
14inherit autotools
15
16# pick up an eglibc patch
17FILESPATH = "${FILE_DIRNAME}/eglibc-${PV}"
18
19SRC_URI = "http://downloads.yoctoproject.org/releases/eglibc/eglibc-${PV}-svnr25243.tar.bz2 \
20 file://fix_for_centos_5.8.patch;patchdir=.. \
21 "
22SRC_URI[md5sum] = "197836c2ba42fb146e971222647198dd"
23SRC_URI[sha256sum] = "baaa030531fc308f7820c46acdf8e1b2f8e3c1f40bcd28b6e440d1c95d170d4c"
24
25S = "${WORKDIR}/eglibc-${PV}/localedef"
26
27do_unpack_append() {
28 bb.build.exec_func('do_move_ports', d)
29}
30
31do_move_ports() {
32 if test -d ${WORKDIR}/eglibc-${PV}/ports ; then
33 rm -rf ${WORKDIR}/libc/ports
34 mv ${WORKDIR}/eglibc-${PV}/ports ${WORKDIR}/libc/
35 fi
36}
37
38EXTRA_OECONF = "--with-glibc=${WORKDIR}/eglibc-${PV}/libc"
39CFLAGS += "-DNOT_IN_libc=1"
40
41do_configure () {
42 ${S}/configure ${EXTRA_OECONF}
43}
44
45
46do_install() {
47 install -d ${D}${bindir}
48 install -m 0755 ${B}/localedef ${D}${bindir}/cross-localedef
49}