summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/eglibc/cross-localedef-native_2.15.bb
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2012-01-06 20:40:23 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-01-10 17:28:45 +0000
commit4b6df4f2668c6e85d8059e1896812a1a8db23786 (patch)
treea55b90043eafd9f9f00d5b9376833d51632c0663 /meta/recipes-core/eglibc/cross-localedef-native_2.15.bb
parentf164a95b43fdda1e774195622f31f0cd998138d3 (diff)
downloadpoky-4b6df4f2668c6e85d8059e1896812a1a8db23786.tar.gz
eglibc: Upgrade recipes 2.14 -> 2.15
Add patch to provide __finite_sqrt functions for ppc (From OE-Core rev: 289d09176f8b6f66f6a7807b57f10e86939942f5) Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core/eglibc/cross-localedef-native_2.15.bb')
-rw-r--r--meta/recipes-core/eglibc/cross-localedef-native_2.15.bb44
1 files changed, 44 insertions, 0 deletions
diff --git a/meta/recipes-core/eglibc/cross-localedef-native_2.15.bb b/meta/recipes-core/eglibc/cross-localedef-native_2.15.bb
new file mode 100644
index 0000000000..6f311fc33c
--- /dev/null
+++ b/meta/recipes-core/eglibc/cross-localedef-native_2.15.bb
@@ -0,0 +1,44 @@
1DESCRIPTION = "Cross locale generation tool for eglibc"
2HOMEPAGE = "http://www.eglibc.org/home"
3SECTION = "libs"
4LICENSE = "LGPL"
5
6LIC_DIR = "${WORKDIR}/${EGLIBC_BRANCH}/libc"
7LIC_FILES_CHKSUM = "file://${LIC_DIR}/LICENSES;md5=98a1128c4b58120182cbea3b1752d8b9\
8 file://${LIC_DIR}/COPYING;md5=393a5ca445f6965873eca0259a17f833 \
9 file://${LIC_DIR}/posix/rxspencer/COPYRIGHT;md5=dc5485bb394a13b2332ec1c785f5d83a \
10 file://${LIC_DIR}/COPYING.LIB;md5=bbb461211a33b134d42ed5ee802b37ff "
11
12
13inherit native
14inherit autotools
15
16PR = "r0"
17SRCREV="15225"
18EGLIBC_BRANCH="eglibc-2_14"
19SRC_URI = "svn://www.eglibc.org/svn/branches/;module=${EGLIBC_BRANCH};proto=http "
20S = "${WORKDIR}/${EGLIBC_BRANCH}/localedef"
21
22do_unpack_append() {
23 bb.build.exec_func('do_move_ports', d)
24}
25
26do_move_ports() {
27 if test -d ${WORKDIR}/${EGLIBC_BRANCH}/ports ; then
28 rm -rf ${WORKDIR}/libc/ports
29 mv ${WORKDIR}/${EGLIBC_BRANCH}/ports ${WORKDIR}/libc/
30 fi
31}
32
33EXTRA_OECONF = "--with-glibc=${WORKDIR}/${EGLIBC_BRANCH}/libc"
34CFLAGS += "-DNOT_IN_libc=1"
35
36do_configure () {
37 ./configure ${EXTRA_OECONF}
38}
39
40
41do_install() {
42 install -d ${D}${bindir}
43 install -m 0755 ${S}/localedef ${D}${bindir}/cross-localedef
44}