summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/dbus/dbus-test_1.8.20.bb
diff options
context:
space:
mode:
authorChen Qi <Qi.Chen@windriver.com>2015-07-29 11:33:45 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-08-01 07:34:06 +0100
commit8f12739542ea2afa77b307546ff17e45456c5c76 (patch)
tree5a434c02efb9e797b696d28a595fe5a3129f41c6 /meta/recipes-core/dbus/dbus-test_1.8.20.bb
parentf494fc25ea884dd262d83739e05f0e5d440cdcad (diff)
downloadpoky-8f12739542ea2afa77b307546ff17e45456c5c76.tar.gz
dbus: upgrade to 1.8.20
(From OE-Core rev: bee8ba766b16d2a7ac7885747b51f08d34bd633d) Signed-off-by: Chen Qi <Qi.Chen@windriver.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core/dbus/dbus-test_1.8.20.bb')
-rw-r--r--meta/recipes-core/dbus/dbus-test_1.8.20.bb61
1 files changed, 61 insertions, 0 deletions
diff --git a/meta/recipes-core/dbus/dbus-test_1.8.20.bb b/meta/recipes-core/dbus/dbus-test_1.8.20.bb
new file mode 100644
index 0000000000..704070bf20
--- /dev/null
+++ b/meta/recipes-core/dbus/dbus-test_1.8.20.bb
@@ -0,0 +1,61 @@
1SUMMARY = "D-Bus test package (for D-bus functionality testing only)"
2HOMEPAGE = "http://dbus.freedesktop.org"
3SECTION = "base"
4LICENSE = "AFL-2 | GPLv2+"
5LIC_FILES_CHKSUM = "file://COPYING;md5=10dded3b58148f3f1fd804b26354af3e \
6 file://dbus/dbus.h;beginline=6;endline=20;md5=7755c9d7abccd5dbd25a6a974538bb3c"
7
8DEPENDS = "python-pygobject dbus dbus-glib"
9
10RDEPENDS_${PN} += "make"
11RDEPENDS_${PN}-dev = ""
12
13SRC_URI = "http://dbus.freedesktop.org/releases/dbus/dbus-${PV}.tar.gz \
14 file://tmpdir.patch \
15 file://dbus-1.init \
16 file://run-ptest \
17 file://python-config.patch \
18 file://clear-guid_from_server-if-send_negotiate_unix_f.patch \
19 "
20
21SRC_URI[md5sum] = "b49890bbabedab3a1c3f4f73c7ff8b2b"
22SRC_URI[sha256sum] = "5c4fbf4c64621c96e871da91d2b729a5b00536e116d3c4612a469d924b1b703a"
23
24S="${WORKDIR}/dbus-${PV}"
25FILESEXTRAPATHS =. "${FILE_DIRNAME}/dbus:"
26
27inherit autotools pkgconfig gettext ptest
28
29EXTRA_OECONF_X = "${@bb.utils.contains('DISTRO_FEATURES', 'x11', '--with-x', '--without-x', d)}"
30EXTRA_OECONF_X_class-native = "--without-x"
31
32EXTRA_OECONF = "--enable-tests \
33 --enable-modular-tests \
34 --enable-installed-tests \
35 --enable-checks \
36 --enable-asserts \
37 --enable-verbose-mode \
38 --disable-xml-docs \
39 --disable-doxygen-docs \
40 --disable-libaudit \
41 --disable-systemd \
42 --without-systemdsystemunitdir \
43 --with-dbus-test-dir=${PTEST_PATH} \
44 ${EXTRA_OECONF_X}"
45
46do_install() {
47 :
48}
49
50do_install_ptest() {
51 install -d ${D}${PTEST_PATH}/test
52 case1="shell printf refs syslog"
53 for i in ${case1}; do install ${B}/test/test-$i ${D}${PTEST_PATH}/test; done
54 case2="marshal syntax corrupt dbus-daemon dbus-daemon-eavesdrop loopback relay"
55 for i in ${case2}; do install ${B}/test/.libs/test-$i ${D}${PTEST_PATH}/test; done
56 case3="bus bus-system bus-launch-helper"
57 for i in ${case3}; do install ${B}/bus/test-$i ${D}${PTEST_PATH}/test; done
58 install ${B}/dbus/test-dbus ${D}${PTEST_PATH}/test
59 cp -r ${B}/test/data ${D}${PTEST_PATH}/test
60}
61RDEPENDS_${PN}-ptest += "bash"