summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/dbus/dbus-test_1.6.18.bb
diff options
context:
space:
mode:
authorChong Lu <Chong.Lu@windriver.com>2014-04-08 11:30:56 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-04-25 17:19:20 +0100
commit2bef523c08793b363b33d682a790d4d786982512 (patch)
treec5dcd5bb5422e5d953d21db708b6f1ca61066d24 /meta/recipes-core/dbus/dbus-test_1.6.18.bb
parent20ded0a263333a1eaef7a717cf8d764b47115e68 (diff)
downloadpoky-2bef523c08793b363b33d682a790d4d786982512.tar.gz
dbus: fix a hard dependency about dbus-ptest
If image contains dbus and ptest is in DISTRO_FEATURES, dbus-ptest package is installed, regardless of whether ptest-pkgs is in IMAGE_FEATURES. This issue will increase size for most small images. This patch fixes this problem. [YOCTO #5702] (From OE-Core rev: 0416583f014138656babdf78a574357ae5ff25bd) Signed-off-by: Chong Lu <Chong.Lu@windriver.com> Signed-off-by: Saul Wold <sgw@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core/dbus/dbus-test_1.6.18.bb')
-rw-r--r--meta/recipes-core/dbus/dbus-test_1.6.18.bb53
1 files changed, 53 insertions, 0 deletions
diff --git a/meta/recipes-core/dbus/dbus-test_1.6.18.bb b/meta/recipes-core/dbus/dbus-test_1.6.18.bb
new file mode 100644
index 0000000000..9ea0f4d374
--- /dev/null
+++ b/meta/recipes-core/dbus/dbus-test_1.6.18.bb
@@ -0,0 +1,53 @@
1SUMMARY = "D-Bus test package (for D-bus functionality testing only)"
2HOMEPAGE = "http://dbus.freedesktop.org"
3SECTION = "base"
4LICENSE = "AFL-2 | GPLv2+"
5LIC_FILES_CHKSUM = "file://COPYING;md5=10dded3b58148f3f1fd804b26354af3e \
6 file://dbus/dbus.h;beginline=6;endline=20;md5=7755c9d7abccd5dbd25a6a974538bb3c"
7
8DEPENDS = "python-pygobject dbus dbus-glib"
9
10RDEPENDS_${PN} += "make"
11RDEPENDS_${PN}-dev = ""
12
13SRC_URI = "http://dbus.freedesktop.org/releases/dbus/dbus-${PV}.tar.gz \
14 file://tmpdir.patch \
15 file://ptest.patch \
16 file://dbus-1.init \
17 file://run-ptest \
18 file://python-config.patch \
19 file://clear-guid_from_server-if-send_negotiate_unix_f.patch \
20 "
21
22SRC_URI[md5sum] = "b02e9c95027a416987b81f9893831061"
23SRC_URI[sha256sum] = "7085a0895a9eb11a952394cdbea6d8b4358e17cb991fed0e8fb85e2b9e686dcd"
24
25S="${WORKDIR}/dbus-${PV}"
26FILESPATH = "${FILE_DIRNAME}/dbus"
27
28inherit autotools pkgconfig gettext ptest
29
30EXTRA_OECONF_X = "${@bb.utils.contains('DISTRO_FEATURES', 'x11', '--with-x', '--without-x', d)}"
31EXTRA_OECONF_X_class-native = "--without-x"
32
33EXTRA_OECONF = "--enable-tests \
34 --enable-modular-tests \
35 --enable-installed-tests \
36 --enable-checks \
37 --enable-asserts \
38 --enable-verbose-mode \
39 --disable-xml-docs \
40 --disable-doxygen-docs \
41 --disable-libaudit \
42 --with-xml=expat \
43 --disable-systemd \
44 --without-systemdsystemunitdir \
45 --with-dbus-test-dir=${PTEST_PATH} \
46 ${EXTRA_OECONF_X}"
47
48do_install() {
49}
50
51do_install_ptest() {
52 find ${D}${PTEST_PATH} -name Makefile | xargs sed -i 's/^Makefile:/_Makefile:/'
53}