summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/coreutils/coreutils_8.5.bb
diff options
context:
space:
mode:
authorQing He <qing.he@intel.com>2011-01-20 14:01:08 +0800
committerSaul Wold <sgw@linux.intel.com>2011-01-21 01:36:16 -0800
commitc0d1ccad65a251e8c0a7cad6476d84403484face (patch)
tree083007edad0e8e78aa45dcf4a38c51cd8a09b03d /meta/recipes-core/coreutils/coreutils_8.5.bb
parent5ee3d0921f2a357e5be33e7db5a75381146535f5 (diff)
downloadpoky-c0d1ccad65a251e8c0a7cad6476d84403484face.tar.gz
coreutils: upgrade to version 8.9
from 8.5 coreutils now depends on gmp Signed-off-by: Qing He <qing.he@intel.com>
Diffstat (limited to 'meta/recipes-core/coreutils/coreutils_8.5.bb')
-rw-r--r--meta/recipes-core/coreutils/coreutils_8.5.bb73
1 files changed, 0 insertions, 73 deletions
diff --git a/meta/recipes-core/coreutils/coreutils_8.5.bb b/meta/recipes-core/coreutils/coreutils_8.5.bb
deleted file mode 100644
index 3944e34314..0000000000
--- a/meta/recipes-core/coreutils/coreutils_8.5.bb
+++ /dev/null
@@ -1,73 +0,0 @@
1SUMMARY = "The basic file, shell and text manipulation utilities."
2DESCRIPTION = "The GNU Core Utilities provide the basic file, shell and text \
3manipulation utilities. These are the core utilities which are expected to exist on \
4every system."
5HOMEPAGE = "http://www.gnu.org/software/coreutils/"
6BUGTRACKER = "http://debbugs.gnu.org/coreutils"
7LICENSE = "GPLv3+"
8LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504\
9 file://src/ls.c;startline=5;endline=16;md5=bb14ed3c4cda583abc85401304b5cd4e"
10PR = "r0"
11DEPENDS = "perl-native"
12
13inherit autotools gettext
14
15SRC_URI = "http://ftp.gnu.org/gnu/coreutils/${BP}.tar.gz"
16
17SRC_URI[md5sum] = "c1ffe586d001e87d66cd80c4536ee823"
18SRC_URI[sha256sum] = "dd243e2ac7d0ed203b170ecfb8299643779e7501fec2b45ae1cea8a450fa8ca0"
19
20# [ gets a special treatment and is not included in this
21bindir_progs = "base64 basename chcon cksum comm csplit cut dir dircolors dirname du \
22 env expand expr factor fmt fold groups head hostid id install \
23 join link logname md5sum mkfifo mktemp nice nl nohup nproc od paste pathchk \
24 pinky pr printenv printf ptx readlink runcon seq sha1sum sha224sum sha256sum \
25 sha384sum sha512sum shred shuf sort split stat stdbuf sum tac tail tee test timeout\
26 tr truncate tsort tty unexpand uniq unlink uptime users vdir wc who whoami yes"
27
28# hostname gets a special treatment and is not included in this
29base_bindir_progs = "cat chgrp chmod chown cp date dd echo false kill ln ls mkdir \
30 mknod mv pwd rm rmdir sleep stty sync touch true uname"
31
32sbindir_progs= "chroot"
33
34do_install_append() {
35 for i in ${bindir_progs}; do mv ${D}${bindir}/$i ${D}${bindir}/$i.${PN}; done
36
37 install -d ${D}${base_bindir}
38 for i in ${base_bindir_progs}; do mv ${D}${bindir}/$i ${D}${base_bindir}/$i.${PN}; done
39
40 install -d ${D}${sbindir}
41 for i in ${sbindir_progs}; do mv ${D}${bindir}/$i ${D}${sbindir}/$i.${PN}; done
42
43 # [ requires special handling because [.coreutils will cause the sed stuff
44 # in update-alternatives to fail, therefore use lbracket - the name used
45 # for the actual source file.
46 mv ${D}${bindir}/[ ${D}${bindir}/lbracket.${PN}
47}
48
49pkg_postinst_${PN} () {
50 for i in ${bindir_progs}; do update-alternatives --install ${bindir}/$i $i $i.${PN} 100; done
51
52 for i in ${base_bindir_progs}; do update-alternatives --install ${base_bindir}/$i $i $i.${PN} 100; done
53
54 for i in ${sbindir_progs}; do update-alternatives --install ${sbindir}/$i $i $i.${PN} 100; done
55
56 # Special cases. [ needs to be treated separately.
57 update-alternatives --install '${bindir}/[' '[' 'lbracket.${PN}' 100
58}
59
60pkg_prerm_${PN} () {
61 for i in ${bindir_progs}; do update-alternatives --remove $i $i.${PN}; done
62
63 for i in ${base_bindir_progs}; do update-alternatives --remove $i $i.${PN}; done
64
65 for i in ${sbindir_progs}; do update-alternatives --remove $i $i.${PN}; done
66
67 # The special cases
68 update-alternatives --remove hostname hostname.${PN}
69 update-alternatives --remove uptime uptime.${PN}
70 update-alternatives --remove '[' 'lbracket.${PN}'
71}
72
73BBCLASSEXTEND = "native"