summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/coreutils/coreutils_8.14.bb
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2011-10-20 12:24:46 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-10-24 17:27:18 +0100
commiteee0b5aadba34130080df8aebc7e8dd57c7d5ccb (patch)
tree7845ac646acd73d4a6db541c4d0202f3fa5907dc /meta/recipes-core/coreutils/coreutils_8.14.bb
parent74d1c5e4ad50d4d5465105cc0afe35f4f4a9a8d4 (diff)
downloadpoky-eee0b5aadba34130080df8aebc7e8dd57c7d5ccb.tar.gz
coreutils: Upgrade recipe 8.12 -> 8.14
Change in site files is needed since in cross build envrionment the test to check for gl_cv_func_fstatat_zero_flag is a runtime test (From OE-Core rev: 906c46d17146bc91e79999d861274e802e9fc745) Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core/coreutils/coreutils_8.14.bb')
-rw-r--r--meta/recipes-core/coreutils/coreutils_8.14.bb79
1 files changed, 79 insertions, 0 deletions
diff --git a/meta/recipes-core/coreutils/coreutils_8.14.bb b/meta/recipes-core/coreutils/coreutils_8.14.bb
new file mode 100644
index 0000000000..f3b7af7d13
--- /dev/null
+++ b/meta/recipes-core/coreutils/coreutils_8.14.bb
@@ -0,0 +1,79 @@
1SUMMARY = "The basic file, shell and text manipulation utilities."
2DESCRIPTION = "The GNU Core Utilities provide the basic file, shell and text \
3manipulation utilities. These are the core utilities which are expected to exist on \
4every system."
5HOMEPAGE = "http://www.gnu.org/software/coreutils/"
6BUGTRACKER = "http://debbugs.gnu.org/coreutils"
7LICENSE = "GPLv3+"
8LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504\
9 file://src/ls.c;startline=5;endline=16;md5=e1a509558876db58fb6667ba140137ad"
10PR = "r0"
11DEPENDS = "gmp"
12DEPENDS_virtclass-native = ""
13
14inherit autotools gettext
15
16SRC_URI = "${GNU_MIRROR}/coreutils/${BP}.tar.xz \
17 file://remove-usr-local-lib-from-m4.patch \
18 "
19SRC_URI[md5sum] = "bcb135ce553493a45aba01b39eb3920a"
20SRC_URI[sha256sum] = "0d120817c19292edb19e92ae6b8eac9020e03d51e0af9cb116cf82b65d18b02d"
21
22EXTRA_OECONF_virtclass-native = "--without-gmp"
23
24# [ gets a special treatment and is not included in this
25bindir_progs = "base64 basename chcon cksum comm csplit cut dir dircolors dirname du \
26 env expand expr factor fmt fold groups head hostid id install \
27 join link logname md5sum mkfifo mktemp nice nl nohup nproc od paste pathchk \
28 pinky pr printenv printf ptx readlink runcon seq sha1sum sha224sum sha256sum \
29 sha384sum sha512sum shred shuf sort split stat stdbuf sum tac tail tee test timeout\
30 tr truncate tsort tty unexpand uniq unlink uptime users vdir wc who whoami yes"
31
32# hostname gets a special treatment and is not included in this
33base_bindir_progs = "cat chgrp chmod chown cp date dd echo false kill ln ls mkdir \
34 mknod mv pwd rm rmdir sleep stty sync touch true uname"
35
36sbindir_progs= "chroot"
37
38do_install_append() {
39 for i in ${bindir_progs}; do mv ${D}${bindir}/$i ${D}${bindir}/$i.${PN}; done
40
41 install -d ${D}${base_bindir}
42 for i in ${base_bindir_progs}; do mv ${D}${bindir}/$i ${D}${base_bindir}/$i.${PN}; done
43
44 install -d ${D}${sbindir}
45 for i in ${sbindir_progs}; do mv ${D}${bindir}/$i ${D}${sbindir}/$i.${PN}; done
46
47 # [ requires special handling because [.coreutils will cause the sed stuff
48 # in update-alternatives to fail, therefore use lbracket - the name used
49 # for the actual source file.
50 mv ${D}${bindir}/[ ${D}${bindir}/lbracket.${PN}
51 install -d ${D}${libdir}/coreutils
52 mv ${D}${libexecdir}/coreutils/libstdbuf.so ${D}${libdir}/coreutils
53}
54
55pkg_postinst_${PN} () {
56 for i in ${bindir_progs}; do update-alternatives --install ${bindir}/$i $i $i.${PN} 100; done
57
58 for i in ${base_bindir_progs}; do update-alternatives --install ${base_bindir}/$i $i $i.${PN} 100; done
59
60 for i in ${sbindir_progs}; do update-alternatives --install ${sbindir}/$i $i $i.${PN} 100; done
61
62 # Special cases. [ needs to be treated separately.
63 update-alternatives --install '${bindir}/[' '[' 'lbracket.${PN}' 100
64}
65
66pkg_prerm_${PN} () {
67 for i in ${bindir_progs}; do update-alternatives --remove $i $i.${PN}; done
68
69 for i in ${base_bindir_progs}; do update-alternatives --remove $i $i.${PN}; done
70
71 for i in ${sbindir_progs}; do update-alternatives --remove $i $i.${PN}; done
72
73 # The special cases
74 update-alternatives --remove hostname hostname.${PN}
75 update-alternatives --remove uptime uptime.${PN}
76 update-alternatives --remove '[' 'lbracket.${PN}'
77}
78
79BBCLASSEXTEND = "native"