summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/console-tools/console-tools_0.3.2.bb
diff options
context:
space:
mode:
authorRichard Purdie <rpurdie@linux.intel.com>2010-08-27 15:14:24 +0100
committerRichard Purdie <rpurdie@linux.intel.com>2010-08-27 15:29:45 +0100
commit29d6678fd546377459ef75cf54abeef5b969b5cf (patch)
tree8edd65790e37a00d01c3f203f773fe4b5012db18 /meta/recipes-core/console-tools/console-tools_0.3.2.bb
parentda49de6885ee1bc424e70bc02f21f6ab920efb55 (diff)
downloadpoky-29d6678fd546377459ef75cf54abeef5b969b5cf.tar.gz
Major layout change to the packages directory
Having one monolithic packages directory makes it hard to find things and is generally overwhelming. This commit splits it into several logical sections roughly based on function, recipes.txt gives more information about the classifications used. The opportunity is also used to switch from "packages" to "recipes" as used in OpenEmbedded as the term "packages" can be confusing to people and has many different meanings. Not all recipes have been classified yet, this is just a first pass at separating things out. Some packages are moved to meta-extras as they're no longer actively used or maintained. Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
Diffstat (limited to 'meta/recipes-core/console-tools/console-tools_0.3.2.bb')
-rw-r--r--meta/recipes-core/console-tools/console-tools_0.3.2.bb49
1 files changed, 49 insertions, 0 deletions
diff --git a/meta/recipes-core/console-tools/console-tools_0.3.2.bb b/meta/recipes-core/console-tools/console-tools_0.3.2.bb
new file mode 100644
index 0000000000..3c5067f102
--- /dev/null
+++ b/meta/recipes-core/console-tools/console-tools_0.3.2.bb
@@ -0,0 +1,49 @@
1SECTION = "base"
2LICENSE = "GPL"
3DESCRIPTION = "Allows you to set-up and manipulate the Linux console."
4DEPENDS = "gettext"
5PR = "r2"
6
7SRC_URI = "${SOURCEFORGE_MIRROR}/lct/console-tools-${PV}.tar.gz \
8 file://codepage.patch;patch=1 \
9 file://configure.patch;patch=1 \
10 file://compile.patch;patch=1 \
11 file://kbdrate.patch;patch=1 \
12 file://uclibc-fileno.patch;patch=1 \
13 file://config/*.m4"
14
15export SUBDIRS = "fontfiletools vttools kbdtools screenfonttools contrib \
16 examples po intl compat"
17
18acpaths = "-I config"
19do_configure_prepend () {
20 mkdir -p config
21 cp ${WORKDIR}/config/*.m4 config/
22}
23
24do_compile () {
25 oe_runmake -C lib
26 oe_runmake 'SUBDIRS=${SUBDIRS}'
27}
28
29inherit autotools
30
31do_install () {
32 autotools_do_install
33 mv ${D}${bindir}/chvt ${D}${bindir}/chvt.${PN}
34 mv ${D}${bindir}/deallocvt ${D}${bindir}/deallocvt.${PN}
35 mv ${D}${bindir}/openvt ${D}${bindir}/openvt.${PN}
36}
37
38pkg_postinst_${PN} () {
39 update-alternatives --install ${bindir}/chvt chvt chvt.${PN} 100
40 update-alternatives --install ${bindir}/deallocvt deallocvt deallocvt.${PN} 100
41 update-alternatives --install ${bindir}/openvt openvt openvt.${PN} 100
42}
43
44pkg_prerm_${PN} () {
45 update-alternatives --remove chvt chvt.${PN}
46 update-alternatives --remove deallocvt deallocvt.${PN}
47 update-alternatives --remove openvt openvt.${PN}
48}
49