summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/console-tools/console-tools_0.3.2.bb
diff options
context:
space:
mode:
authorTudor Florea <tudor.florea@enea.com>2014-10-16 03:05:19 +0200
committerTudor Florea <tudor.florea@enea.com>2014-10-16 03:05:19 +0200
commitc527fd1f14c27855a37f2e8ac5346ce8d940ced2 (patch)
treebb002c1fdf011c41dbd2f0927bed23ecb5f83c97 /meta/recipes-core/console-tools/console-tools_0.3.2.bb
downloadpoky-daisy-140929.tar.gz
initial commit for Enea Linux 4.0-140929daisy-140929
Migrated from the internal git server on the daisy-enea-point-release branch Signed-off-by: Tudor Florea <tudor.florea@enea.com>
Diffstat (limited to 'meta/recipes-core/console-tools/console-tools_0.3.2.bb')
-rw-r--r--meta/recipes-core/console-tools/console-tools_0.3.2.bb36
1 files changed, 36 insertions, 0 deletions
diff --git a/meta/recipes-core/console-tools/console-tools_0.3.2.bb b/meta/recipes-core/console-tools/console-tools_0.3.2.bb
new file mode 100644
index 0000000000..80fab55214
--- /dev/null
+++ b/meta/recipes-core/console-tools/console-tools_0.3.2.bb
@@ -0,0 +1,36 @@
1SECTION = "base"
2LICENSE = "GPLv2"
3LIC_FILES_CHKSUM = "file://COPYING.kbd;md5=9b2d91511d3d80d4d20ac6e6b0137fe9"
4SUMMARY = "Allows you to set-up and manipulate the Linux console"
5DESCRIPTION = "Provides tools that enable the set-up and manipulation of the linux console and console-font files."
6PR = "r8"
7
8SRC_URI = "${SOURCEFORGE_MIRROR}/lct/console-tools-${PV}.tar.gz \
9 file://codepage.patch \
10 file://configure.patch \
11 file://compile.patch \
12 file://kbdrate.patch \
13 file://uclibc-fileno.patch \
14 file://nodocs.patch \
15 file://fix-libconsole-linking.patch \
16 file://lcmessage.m4 \
17 file://Makevars"
18
19SRC_URI[md5sum] = "bf21564fc38b3af853ef724babddbacd"
20SRC_URI[sha256sum] = "eea6b441672dacd251079fc85ed322e196282e0e66c16303ec64c3a2b1c126c2"
21
22do_configure_prepend () {
23 mkdir -p ${S}/m4
24 cp ${WORKDIR}/lcmessage.m4 ${S}/m4/
25 rm -f ${S}/acinclude.m4
26 cp ${WORKDIR}/Makevars ${S}/po/
27}
28
29inherit autotools gettext update-alternatives
30
31ALTERNATIVE_PRIORITY = "100"
32
33bindir_progs = "chvt deallocvt fgconsole openvt"
34ALTERNATIVE_${PN} = "${bindir_progs}"
35
36RDEPENDS_${PN} = "bash"