summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/busybox/busybox_1.23.2.bb
diff options
context:
space:
mode:
authorChen Qi <Qi.Chen@windriver.com>2015-04-07 15:03:00 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-04-10 18:10:23 +0100
commiteac96036ddad001e50c38699c57277aa2cb2fef3 (patch)
treeea57725f51c582fd828de2ed777739034df472bd /meta/recipes-core/busybox/busybox_1.23.2.bb
parent462e7cc2a166e4a557aa433a2d3656982b5586a4 (diff)
downloadpoky-eac96036ddad001e50c38699c57277aa2cb2fef3.tar.gz
busybox: upgrade to 1.23.2
(From OE-Core rev: 2b7258c19dc8c286d19e9067b62374b754deeca2) Signed-off-by: Chen Qi <Qi.Chen@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core/busybox/busybox_1.23.2.bb')
-rw-r--r--meta/recipes-core/busybox/busybox_1.23.2.bb45
1 files changed, 45 insertions, 0 deletions
diff --git a/meta/recipes-core/busybox/busybox_1.23.2.bb b/meta/recipes-core/busybox/busybox_1.23.2.bb
new file mode 100644
index 0000000000..0af292df6f
--- /dev/null
+++ b/meta/recipes-core/busybox/busybox_1.23.2.bb
@@ -0,0 +1,45 @@
1require busybox.inc
2
3SRC_URI = "http://www.busybox.net/downloads/busybox-${PV}.tar.bz2;name=tarball \
4 file://get_header_tar.patch \
5 file://busybox-appletlib-dependency.patch \
6 file://busybox-udhcpc-no_deconfig.patch \
7 file://find-touchscreen.sh \
8 file://busybox-cron \
9 file://busybox-httpd \
10 file://busybox-udhcpd \
11 file://default.script \
12 file://simple.script \
13 file://hwclock.sh \
14 file://mount.busybox \
15 file://syslog \
16 file://syslog-startup.conf \
17 file://syslog.conf \
18 file://busybox-syslog.default \
19 file://mdev \
20 file://mdev.conf \
21 file://mdev-mount.sh \
22 file://umount.busybox \
23 file://defconfig \
24 file://busybox-syslog.service.in \
25 file://busybox-klogd.service.in \
26 file://fail_on_no_media.patch \
27 file://run-ptest \
28 file://inetd.conf \
29 file://inetd \
30 file://login-utilities.cfg \
31 file://recognize_connmand.patch \
32 file://busybox-cross-menuconfig.patch \
33 file://CVE-2014-9645_busybox_reject_module_names_with_slashes.patch \
34"
35
36SRC_URI[tarball.md5sum] = "7925683d7dd105aabe9b6b618d48cc73"
37SRC_URI[tarball.sha256sum] = "05a6f9e21aad8c098e388ae77de7b2361941afa7157ef74216703395b14e319a"
38
39EXTRA_OEMAKE += "V=1 ARCH=${TARGET_ARCH} CROSS_COMPILE=${TARGET_PREFIX} SKIP_STRIP=y"
40
41do_install_ptest () {
42 cp -r ${B}/testsuite ${D}${PTEST_PATH}/
43 cp ${B}/.config ${D}${PTEST_PATH}/
44 ln -s /bin/busybox ${D}${PTEST_PATH}/busybox
45}