summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/busybox/busybox_1.22.1.bb
diff options
context:
space:
mode:
authorChen Qi <Qi.Chen@windriver.com>2014-01-22 10:39:46 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-02-02 11:22:12 +0000
commitb1ea3455379e38d4e56970505c05b4104d5f1234 (patch)
tree0900ad3eef7a6bd6d31d18abf0ce932e819da9cb /meta/recipes-core/busybox/busybox_1.22.1.bb
parent47208175027686339dd18df52b60ec2c43594918 (diff)
downloadpoky-b1ea3455379e38d4e56970505c05b4104d5f1234.tar.gz
busybox: upgrade to stable 1.22.1
Upgrade busybox to the stable release 1.22.1. During this upgrade, 9 patches are removed. Reasons are detailed below. The following 6 patches are removed as they have been merged. meta/recipes-core/busybox/busybox/busybox-lineedit-initialize-delptr.patch meta/recipes-core/busybox/busybox/busybox-list-suid-and-non-suid-app-configs.patch meta/recipes-core/busybox/busybox/busybox-sed-fix-sed-clusternewline-testcase.patch meta/recipes-core/busybox/busybox/busybox-sulogin-empty-root-password.patch meta/recipes-core/busybox/busybox/find-get-rid-of-nested-functions.patch meta/recipes-core/busybox/busybox/testsuite-du-du-k-works-fix-false-positive.patch The following three patches are removed because they are mainly about moving binaries from /bin to /usr/bin to make the update-alternative work correctly at rootfs time. We can easily solve this problem by changing recipes. There's no compelling reason why such patches are needed. meta/recipes-core/busybox/busybox/run-parts.in.usr-bin.patch meta/recipes-core/busybox/busybox/stat-usr-bin.patch meta/recipes-core/busybox/busybox/watch.in.usr-bin.patch (From OE-Core rev: fa282186d82e8fe3c590d4ea79e464116e5ceea2) Signed-off-by: Chen Qi <Qi.Chen@windriver.com> Signed-off-by: Saul Wold <sgw@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core/busybox/busybox_1.22.1.bb')
-rw-r--r--meta/recipes-core/busybox/busybox_1.22.1.bb41
1 files changed, 41 insertions, 0 deletions
diff --git a/meta/recipes-core/busybox/busybox_1.22.1.bb b/meta/recipes-core/busybox/busybox_1.22.1.bb
new file mode 100644
index 0000000000..ffc9435398
--- /dev/null
+++ b/meta/recipes-core/busybox/busybox_1.22.1.bb
@@ -0,0 +1,41 @@
1require busybox.inc
2
3SRC_URI = "http://www.busybox.net/downloads/busybox-${PV}.tar.bz2;name=tarball \
4 file://get_header_tar.patch \
5 file://busybox-appletlib-dependency.patch \
6 file://busybox-udhcpc-no_deconfig.patch \
7 file://find-touchscreen.sh \
8 file://busybox-cron \
9 file://busybox-httpd \
10 file://busybox-udhcpd \
11 file://default.script \
12 file://simple.script \
13 file://hwclock.sh \
14 file://mount.busybox \
15 file://syslog \
16 file://syslog-startup.conf \
17 file://syslog.conf \
18 file://busybox-syslog.default \
19 file://mdev \
20 file://mdev.conf \
21 file://umount.busybox \
22 file://defconfig \
23 file://busybox-syslog.service.in \
24 file://busybox-klogd.service.in \
25 file://fail_on_no_media.patch \
26 file://run-ptest \
27 file://inetd.conf \
28 file://inetd \
29 file://login-utilities.cfg \
30"
31
32SRC_URI[tarball.md5sum] = "337d1a15ab1cb1d4ed423168b1eb7d7e"
33SRC_URI[tarball.sha256sum] = "ae0b029d0a9e4dd71a077a790840e496dd838998e4571b87b60fed7462b6678b"
34
35EXTRA_OEMAKE += "V=1 ARCH=${TARGET_ARCH} CROSS_COMPILE=${TARGET_PREFIX} SKIP_STRIP=y"
36
37do_install_ptest () {
38 cp -r ${B}/testsuite ${D}${PTEST_PATH}/
39 cp ${B}/.config ${D}${PTEST_PATH}/
40 ln -s /bin/busybox ${D}${PTEST_PATH}/busybox
41}