summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/busybox/busybox_1.22.1.bb
diff options
context:
space:
mode:
authorTudor Florea <tudor.florea@enea.com>2014-10-16 03:05:19 +0200
committerTudor Florea <tudor.florea@enea.com>2014-10-16 03:05:19 +0200
commitc527fd1f14c27855a37f2e8ac5346ce8d940ced2 (patch)
treebb002c1fdf011c41dbd2f0927bed23ecb5f83c97 /meta/recipes-core/busybox/busybox_1.22.1.bb
downloadpoky-daisy-140929.tar.gz
initial commit for Enea Linux 4.0-140929daisy-140929
Migrated from the internal git server on the daisy-enea-point-release branch Signed-off-by: Tudor Florea <tudor.florea@enea.com>
Diffstat (limited to 'meta/recipes-core/busybox/busybox_1.22.1.bb')
-rw-r--r--meta/recipes-core/busybox/busybox_1.22.1.bb42
1 files changed, 42 insertions, 0 deletions
diff --git a/meta/recipes-core/busybox/busybox_1.22.1.bb b/meta/recipes-core/busybox/busybox_1.22.1.bb
new file mode 100644
index 0000000000..782752c2aa
--- /dev/null
+++ b/meta/recipes-core/busybox/busybox_1.22.1.bb
@@ -0,0 +1,42 @@
1require busybox.inc
2
3SRC_URI = "http://www.busybox.net/downloads/busybox-${PV}.tar.bz2;name=tarball \
4 file://get_header_tar.patch \
5 file://busybox-appletlib-dependency.patch \
6 file://busybox-udhcpc-no_deconfig.patch \
7 file://find-touchscreen.sh \
8 file://busybox-cron \
9 file://busybox-httpd \
10 file://busybox-udhcpd \
11 file://default.script \
12 file://simple.script \
13 file://hwclock.sh \
14 file://mount.busybox \
15 file://syslog \
16 file://syslog-startup.conf \
17 file://syslog.conf \
18 file://busybox-syslog.default \
19 file://mdev \
20 file://mdev.conf \
21 file://umount.busybox \
22 file://defconfig \
23 file://busybox-syslog.service.in \
24 file://busybox-klogd.service.in \
25 file://fail_on_no_media.patch \
26 file://run-ptest \
27 file://inetd.conf \
28 file://inetd \
29 file://login-utilities.cfg \
30 file://0001-build-system-Specify-nostldlib-when-linking-to-.o-fi.patch \
31"
32
33SRC_URI[tarball.md5sum] = "337d1a15ab1cb1d4ed423168b1eb7d7e"
34SRC_URI[tarball.sha256sum] = "ae0b029d0a9e4dd71a077a790840e496dd838998e4571b87b60fed7462b6678b"
35
36EXTRA_OEMAKE += "V=1 ARCH=${TARGET_ARCH} CROSS_COMPILE=${TARGET_PREFIX} SKIP_STRIP=y"
37
38do_install_ptest () {
39 cp -r ${B}/testsuite ${D}${PTEST_PATH}/
40 cp ${B}/.config ${D}${PTEST_PATH}/
41 ln -s /bin/busybox ${D}${PTEST_PATH}/busybox
42}