summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/busybox/busybox-inittab_1.27.2.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denys@ti.com>2018-03-02 20:46:50 -0500
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-03-04 21:23:03 +0000
commit55baf5b707ada71d9e1b924b2793064012a3ed41 (patch)
treed643bbe414c620970aaecea10871656ef4027d8d /meta/recipes-core/busybox/busybox-inittab_1.27.2.bb
parent4e884c8723cf2e3e89d6ac412fb472e64e51bac1 (diff)
downloadpoky-55baf5b707ada71d9e1b924b2793064012a3ed41.tar.gz
busybox: separate inittab into own package, due to SERIAL_CONSOLES being machine-specific
* Create busybox-inittab recipe to produce machine-specific package with /etc/inittab and necessary getty calls for a machine, based on SERIAL_CONSOLES, similar to how sysvinit-inittab was done * Since CONFIG_FEATURE_USE_INITTAB is controlled by VIRTUAL-RUNTIME_init_manager, make main busybox package RDEPENDS on busybox-inittab when init_manager is set to busybox (From OE-Core rev: afb09abd2f0f7555ba156260a87fd3867f591310) Signed-off-by: Denys Dmytriyenko <denys@ti.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core/busybox/busybox-inittab_1.27.2.bb')
-rw-r--r--meta/recipes-core/busybox/busybox-inittab_1.27.2.bb32
1 files changed, 32 insertions, 0 deletions
diff --git a/meta/recipes-core/busybox/busybox-inittab_1.27.2.bb b/meta/recipes-core/busybox/busybox-inittab_1.27.2.bb
new file mode 100644
index 0000000000..a83620e859
--- /dev/null
+++ b/meta/recipes-core/busybox/busybox-inittab_1.27.2.bb
@@ -0,0 +1,32 @@
1SUMMARY = "inittab configuration for BusyBox"
2LICENSE = "GPLv2"
3LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6"
4
5SRC_URI = "file://inittab"
6
7S = "${WORKDIR}"
8
9INHIBIT_DEFAULT_DEPS = "1"
10
11do_compile() {
12 :
13}
14
15do_install() {
16 install -d ${D}${sysconfdir}
17 install -D -m 0644 ${WORKDIR}/inittab ${D}${sysconfdir}/inittab
18 tmp="${SERIAL_CONSOLES}"
19 for i in $tmp
20 do
21 j=`echo ${i} | sed s/\;/\ /g`
22 id=`echo ${i} | sed -e 's/^.*;//' -e 's/;.*//'`
23 echo "$id::respawn:${base_sbindir}/getty ${j}" >> ${D}${sysconfdir}/inittab
24 done
25}
26
27# SERIAL_CONSOLES is generally defined by the MACHINE .conf.
28# Set PACKAGE_ARCH appropriately.
29PACKAGE_ARCH = "${MACHINE_ARCH}"
30
31FILES_${PN} = "${sysconfdir}/inittab"
32CONFFILES_${PN} = "${sysconfdir}/inittab"