summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/base-passwd/base-passwd_3.5.22.bb
diff options
context:
space:
mode:
authorRichard Purdie <rpurdie@linux.intel.com>2010-08-27 15:14:24 +0100
committerRichard Purdie <rpurdie@linux.intel.com>2010-08-27 15:29:45 +0100
commit29d6678fd546377459ef75cf54abeef5b969b5cf (patch)
tree8edd65790e37a00d01c3f203f773fe4b5012db18 /meta/recipes-core/base-passwd/base-passwd_3.5.22.bb
parentda49de6885ee1bc424e70bc02f21f6ab920efb55 (diff)
downloadpoky-29d6678fd546377459ef75cf54abeef5b969b5cf.tar.gz
Major layout change to the packages directory
Having one monolithic packages directory makes it hard to find things and is generally overwhelming. This commit splits it into several logical sections roughly based on function, recipes.txt gives more information about the classifications used. The opportunity is also used to switch from "packages" to "recipes" as used in OpenEmbedded as the term "packages" can be confusing to people and has many different meanings. Not all recipes have been classified yet, this is just a first pass at separating things out. Some packages are moved to meta-extras as they're no longer actively used or maintained. Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
Diffstat (limited to 'meta/recipes-core/base-passwd/base-passwd_3.5.22.bb')
-rw-r--r--meta/recipes-core/base-passwd/base-passwd_3.5.22.bb50
1 files changed, 50 insertions, 0 deletions
diff --git a/meta/recipes-core/base-passwd/base-passwd_3.5.22.bb b/meta/recipes-core/base-passwd/base-passwd_3.5.22.bb
new file mode 100644
index 0000000000..f0ca8e6280
--- /dev/null
+++ b/meta/recipes-core/base-passwd/base-passwd_3.5.22.bb
@@ -0,0 +1,50 @@
1DESCRIPTION = "Base system password/group files."
2SECTION = "base"
3PR = "r0"
4LICENSE = "GPLv2+"
5LIC_FILES_CHKSUM = "file://COPYING;md5=eb723b61539feef013de476e68b5c50a"
6
7SRC_URI = "${DEBIAN_MIRROR}/main/b/base-passwd/base-passwd_${PV}.tar.gz \
8 file://nobash.patch \
9 file://root-home.patch"
10
11S = "${WORKDIR}/base-passwd"
12
13inherit autotools
14
15do_install () {
16 install -d -m 755 ${D}${sbindir}
17 install -p -m 755 update-passwd ${D}${sbindir}/
18 install -d -m 755 ${D}${mandir}/man8 ${D}${mandir}/pl/man8
19 install -p -m 644 man/update-passwd.8 ${D}${mandir}/man8/
20 install -p -m 644 man/update-passwd.pl.8 \
21 ${D}${mandir}/pl/man8/update-passwd.8
22 gzip -9 ${D}${mandir}/man8/* ${D}${mandir}/pl/man8/*
23 install -d -m 755 ${D}${datadir}/base-passwd
24 install -p -m 644 passwd.master ${D}${datadir}/base-passwd/
25 install -p -m 644 group.master ${D}${datadir}/base-passwd/
26
27 install -d -m 755 ${D}${docdir}/${PN}
28 install -p -m 644 debian/changelog ${D}${docdir}/${PN}/
29 gzip -9 ${D}${docdir}/${PN}/*
30 install -p -m 644 README ${D}${docdir}/${PN}/
31 install -p -m 644 debian/copyright ${D}${docdir}/${PN}/
32}
33
34do_install_append_openmn() {
35 echo "0:Jn6tcg/qjqvUE:0:0:root:/root:/bin/sh" >>${D}${datadir}/base-passwd/passwd.master
36}
37
38
39pkg_postinst () {
40 set -e
41
42 if [ ! -e $D${sysconfdir}/passwd ] ; then
43 cp $D${datadir}/base-passwd/passwd.master $D${sysconfdir}/passwd
44 fi
45
46 if [ ! -e $D${sysconfdir}/group ] ; then
47 cp $D${datadir}/base-passwd/group.master $D${sysconfdir}/group
48 fi
49 exit 0
50}